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Preface

Since its inception at the Institute of Optics at the University of Rochester, the software
written by Doug Sinclair has played a key role in the teaching as well as in the performance
of optical design. So OSLO, perhaps more than any other optical design software, shows
signs of its origins in a teaching establishment. The flexibility of the user interface, the open
source nature of much of the code, the CCL programming language which is very similar to
C, and real capability of OSLO-EDU, the free version of OSLO, to carry out real design
tasks, make it the ideal choice for the teaching environment.

This manual has been written to supplement the current documentation for commercial users
of OSLO software. Its second aim is to provide a gentle introduction to the experience of
optical design for those who have only just downloaded OSLO-EDU from the internet. The
first chapter is written expressly for them. More experienced designers may wish to skip
straight to the second chapter.




Chapter 1 - Your first OSLO session

Introduction

This chapter gives a click-by-click description of how OSLO can be used to carry out a very
simple task involving synthesis, analysis, and optimization of a spherical concave mirror. It
is in general applicable to all editions of OSLO, including OSLO EDU. This means that
more advanced facilities, which may only be available in OSLO Standard and Premium
editions, are not included.

The exercise will demonstrate the two main modes of calculation:

e the geometrical approximation, in which light is treated as a ray, or the path of a
photon

e the physical mode of calculation, in which the light is treated as propagating as a
wave front, and the results take account of the effects of diffraction.

Symbols used in this chapter

A left-click on the mouse is indicated by a white arrow, and a right-click by the box with the
word “Right”. If a drop-down menu is selected by a left-click, then it is
represented by a black circle and arrow. %

Step by step instructions are marked with bullet points. Instructions
about what to do if things go badly wrong are in italics and labeled \

HELP! . Right]|

Anything typed from the keyboard (whether as a command or as an entry in a dialog box) is
shown in this typeface.

Labels and headers in spreadsheets and dialog boxes are given in this typeface.
Buttons to be clicked are shown in | gray .
Check-boxes (called “radio buttons” in the documentation) are shown like this: @

Messages which appear whenever the cursor hovers above an icon are shown in a shaded
box. These are known as tooltips. | Tooltips |

Questions and answers, representing a typical dialog between a lens designer and the
customer, are given in bold type.
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Running OSLO

® EITHER click on the shortcut icon on the desktop in the Windows desktop,
OR click on Start » All Programs » OSLO» OSLO [EDU etc]
Edition...
OR locate the .exe file in C:\Program Files\OSLO
(e.g. osloedu.exe) - in some installations the
directory name is Lambda Research\OSLO).

OSLO EPUV Edition

® The program opens with an introductory dialog box.
Click anywhere in the box to close it.

Hdi
® [fa message about re-building the CCL database .

appears, click on | OK & pidyou know..

® The “Tip of the Day” is a useful tutorial for new users.
Click on | Close Alternatively it can be suppressed
permanently by removing the tick from the box in the
bottom left corner. % Shontpe ot s teato | [a

® The Get_startup_option window opens.

® Choose the default option: @Start a new lens and <t_startup_optic

3 Would you like to
CIICk on OK (9 5tar a new lenst {" Open the cument lens
Rn anexistinglens " Browse the lens ibrary

® The OSLO main window should now appear, similar in _
his dialog box at startup?

appearance to that shown here. We will now discuss the F e Mo
individual components of this window in detail. Conod | Hep

The user interface

A number of terms are defined here, and given in bold print.
At the top of the main window in the blue border is the title
bar, which gives the lens identifier, the file name under

which the current lens was last saved, and the edition of OSLO currently runmng

Beneath this lies a row of menu headers, File, Lens, Evaluate, etc, each of which its
own drop-down menu has. Many of the program commands can be accessed through these
menus. The last of the menu headers is Help which gives access to the on-line
documentation. In Windows, this can also be accessed via the F1 key on the keyboard.

Below that is a row of icons forming the main window toolbar,
which give one-click access to the most frequently used control
functions. The first of these is the Setup Window/Toolbar
icon which gives access to a list of further groups of icons which
can be added to the toolbar. Other icons are to Open surface data spreadsheet, Open
a new lens, Open an existing lens, Save the current lens, Open the standard
text editor, etc. Each icon has a description of its function which pops up as a tooltip
when the cursor is placed over the icon.

Setup Window/Toolbar

At the bottom of the main window, there is a status bar which can be expanded and
customized by the user. This will be described in chapter 2.

Running OSLO
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MAIN WINDOW

28 No name [untitled.len] - OSLO EDU

File Lens Evaluate Optimize Tolerance Source Tools Window Help Menu headers

Title bar

Gen Setup wavelengths |[ variables |[ Draw off |[ Group |[ Notes
Lens: No name ET1 1.0000e+54
Ent beam radius 5.7 Toolbar
SRE RADTUS THICKNESS APERTURE Surface data

081 0.000000 ] 1.0000e+20 [ | 1.0000e+:

0.000000[ ] 0.000000[ ]  1.00004 Spreadsheet

IS, o.000000 [ ] o0.o00000[ ]  1.00004

Graphics
window

BBl Lon Spe Fin Ape Wav Pxo Abr Mrg Chf Tra Sop Ref Salliinetail Toolbar

<

r'l';ctcutput: Oon ‘Page mode: On ‘Graph\cs autoclear: On F-number: Se+1S
= e Status bar e

The window which opens in the top left hand corner is called the surface data spreadsheet.
This is the area where all the properties of the lens and its working conditions are defined.
Entering data into this spreadsheet is described in chapter 4. Other spreadsheets are
available, but only one spreadsheet can be open at a time.

Open surface data spreadsheet

HELP! If the surface data spreadsheet does not open, click
on the blue lens icon on the left of the toolbar in the main window. Alternatively,
select from the Lens menu header the option .
Immediately above the surface data spreadsheet is the command line where

OSLO commands are typed. They are executed either by pressing Enter or by clicking
on the green tick:

J Accept pending entry/Close spreadsheet

Online documentation for any command may be accessed by typing the command in the
command line, and then pressing the yellow question mark beside it.

? Help for the command/spreadsheet

If no command is entered the documentation for any currently open spreadsheet is given.

Below the command line there is a message area, and on the right hand end there is the
history button. The command line is described in detail in chapter 3.

5] i Vo (e B

The user interface
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There should also be a text window visible. This is where printed output is directed. Along
the top of this there lays a toolbar consisting of a row of text labels, which are OSLO
commands, executed by clicking. Numerical analysis is described in chapter 6.

HELP! If the text window toolbar does not look like the one in
the diagram, click on the Setup Window/Toolbar icon in the
top left-hand corner of the text window, and select Standard
Tools from the menu. Any or all of the toolbar groups may be
selected for a text window. Either one or two, but not more, text
windows can be shown at a time.

Setup Window/Toolbar

Tile windows
Set window title...

Right-click actions. ..
Set Toolbars/Row...

The user may create additional toolbar entries using the CCL
programming language. Detailed instructions of how to do this are

iven in chapter on programming, chapter 8.
g p prog g P w Standard Tools

Lens Data Tools
Aberrations

Ray Trace
Image Analysis
Tolerancing Data

Also on the main screen there is at least one graphics window. This has a toolbar
consisting of a row of icons. All graphical output is displayed in one of the graphics
windows. Graphical analysis is discussed in chapter 5. There is an index of OSLO graphics
facilities in Appendix 2 at the end of this book.

HELP! If the graphics window toolbar does not look like the
one in the diagram, click on the Setup Window/Toolbar icon
on the left-hand side of the graphics window toolbar, and select
Standard Tools from the menu. Only one of the graphics
window icon groups may be displayed at a time, but different graphics windows may have
different groups. Up to 30 graphics windows may be created and displayed by the user at
any one time. Two more may be generated automatically.

Setup Window/Toolbar

The user may generate icons in any of the graphics toolbars. This is described in chapter 8.

HELP! If you have trouble finding the text window or the graphics window, then from the
Window menu header select Tile Windows. Alternatively you can type the command

ti le into the command line and then either click on the green tick v or press « (Enter)
on the keyboard.

The user interface
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Spherical mirror example

The remainder of this chapter will consist of instructions on how to specify a concave
spherical mirror of radius 16 mm, and then to assess its on-axis performance at apertures of
f/4 and f/2.3. Finally its performance at 18° off axis will be assessed, and the stop position
and image radius of curvature optimized to give the best performance over the field of view.

For clarity, each section will be prefaced by a question from a “customer,” given in bold

type.

2 mm ek — R R I

ll e R=16

é— 8 mm

Question: Does a spherical mirror working at f/4 give a “diffraction limited”
image at its focus when used with a 2 mm diameter parallel axial beam of green light?

Defining the lens system data

The working conditions of the lens (such as units, paraxial setup data, wavelengths and field
points) are defined by entries in the surface data spreadsheet above the double line.

EE Surface Data

Select glazs option:
k,eﬂ ect (hatch)

Setup wavelengths variables Draw on Group [ wotes |

Lens: Spherical mirror EFf1 1.0000e+54
Ent beam radius 1. Dum;e 5.7296e-05 imary wavin 0.587560
SR.F RADTIUS APERTURE RADIUS LASS SPECIAL

0OB] 0. 000000 l:l 1. 0000e 1.0000e+14 o~

-16.00Q000 |:| -g.gooooo | 1.o00000 [AS |
D. yoo [ | 1.o00008 [ s |

Reflect (hatch)
Pickup... {F)
Catalog (C)
Maodel... (M)
Direct...

On the surface data spreadsheet:

1. Left-click with the mouse on Draw Off  to open the Autodraw window The label
on the button changes to  Draw On  while the Autodraw window is active.

2. Add the lens identifier (up to 32 characters): Lens: Spherical mirror
Click once on the green tick.

HELP! If you were to choose a different name for the lens identifier, and the first word of
the name happened to be a valid OSLO command words (such as SP€), the name would be

Spherical mirror example
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rejected and the relevant command executed instead. To avoid this, the title might be
enclosed in quotation marks: e.g. “‘spe”.

The default value of Ent beam radius is 1.0 mm, the default primary wavelength is
0.58756 pm (the green helium d-line), and the default units are mm, so for this exercise
these do not need to be changed. Also at this stage it is only necessary to assess the mirror
on axis, so the field angle does not need to be changed from the default value of 1
milliradian.

Defining the lens surface data

Turning now to the data below the double line, the first line (labeled OBJ) refers to the
object space, numbered 0. A parallel beam is the default condition for a new lens. So the
THICKNESS - that is the object distance - is infinity (in OSLO, that means 10%°, written
1.0000e+20 lens units). Nothing has to be changed on this line since in the object space a
medium (GLASS) of AIR is also the default. The object radius (1.0000e+14) is calculated
from the field angle by the program, and is not specified by the user.

On the second line for surface 1 (AST):

3. Because the aperture is “f/4” the focal length must be 4 times the beam diameter of 2
mm, and the focal length is half the radius of curvature. Change the RADIUS to a
value of-16 (mm). Since this is measured from the surface to its center, a negative
radius implies a surface concave to the incoming beam.

4. Click on the gray button next to AIR under GLASS and select [REHEGHEN1)] (or
- the only difference being the appearance of the drawing).

5. Change the THICKNESS from 0.000000 to: -8 (mm). This is the separation from
surface 1 to surface 2. It is negative because after reflection the light travels in the
opposite direction to the local z-axis.

6. Once again, click on the green tick (\/) to confirm the changes.

Note that for surface 1, the APERTURE RADIUS (1.000000) has AS in the gray box
next to it. A means that this surface is the aperture stop. S means that the size of the
surface is governed by a “paraxial solve,” which means that it will be adjusted to
accommodate (approximately) both axial and off-axis beams without truncation.

On the third line, which corresponds to the image (IMS) a RADIUS of 0.0 means that the
image is plane. Once again its size is the default - it is adjusted using a “paraxial solve.” The
box for the next space (THICKNESS) will used for a defocus value, but is zero at present.
The box showing the medium after the image (GLASS) is of course blank.

There is no need to close the surface data spreadsheet before starting the next section.

Spherical mirror example



8 Your first OSLO session Chapter 1

Drawing the lens in the Autodraw window % 17 ~tled lens] - OSLO EDU

Fild @ Evaluate Optimize Tolerance

In the main window:
Glass Catalogs

e Click on the Lens menu header to open the menu list Costros
ShOWIl. Show Surface Data...

Show Tolerance Data

Show Optimization Data
Show Operating Conditions.. .
Show Auxiliary Data

o Select the last item, [RJERE\iToTe[oFeToTe [1{{eTs 3

The Lens Drawing Conditions spreadsheet will appear. This
is the spreadsheet where the overall appearance of lens system
drawings is determined.

&2 Lens Drawing Conditions

% =
%

Initial distance: Final distance:
Horizontal view angle: 240 vertical view angle:
First surface to draw: [ 0| Last surface to draw: [0 | Autodraw:
X shift: ¥ shift: DXF/IGES view:
Apertures: Rings: Spokes: Image Space rays:

Draw aperture stop: & off (O on Hatch back of reflectors: O off {ao0n
shaded solid color - Red: Green: [18% Elue:
Number of ray fans in lens drawings: Paoints for aspheric profiles:

I =

Frac ¥ 0Obj Frac X Obj Rays Min Pupil Max Pupil affset FY FX Wwn
| 0. oo0000 | o.ooo0000] [13N [ -1.o00000 | 1. 000000 | 0.o00000 @ [ 1]
[ o.7ooo00] [ 0.o000000 0.000000] [ o0.000000 [ o.oo0000 @ [ 1]
[ 1.o000000 [ o.oo00000 [ 2] -1.000000 [ 1.000000 [ o.oo0000 @ [ 1]

In the Lens Drawing Conditions spreadsheet:

o After Image space rays: select e\ TREVERCRINE Rl

e The table at the bottom determines what rays will be displayed. In the column
headed Rays type on the first line 11 for the number of rays to be drawn for
the first (on axis) field point - for which Frac Y Obj = 0.00000. These rays
will be drawn with a green pen.

e [Leave everything else unchanged, and close with the green tick v,

The Autodraw window should now have the
appearance shown in the diagram, provided the Yaria | orawon [ _Spup |
surface data spreadsheet is open. % | Autodraw

Spherianl mirrer
LEMGTH = —8 b = 0,175

HELP! The Autodraw window may be Ty
hidden behind one of the others. If this happens

to be the case, from the Window menu header -
select Tile Windows

Spherical mirror example
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Plotting the on axis spot diagram

A spot diagram is a map of the pattern of rays
incident on the image from a single object point,
using the “geometrical approximation” which
ignores the wave nature of light.

® From the Evaluate menu header select:
gSingle spot diagram...
® In the Print or plot spot diagram
spreadsheet, click on three radio buttons as
shown:
@ Plot spot diagram.

Evaluate OgPmize Tolerance Source Tools Window Help

I'mirror [SPHERICAL_MIRROR_.len] - OSLO EDU

perration Coeffidents. ..

bom Aberrations

Wavefront
Transfer Function
Spread Function
Energy Distribution

Single Spot Diagram...
Spot Size Analysis. ..

Recipolar Spot Diagram. ..
Plot ray intersection points as: Polarization P —
@ Symbols Autofocus » | =
Show AI(:)deISC n pIOt: Print or plot spot diagram E|
es
e Leave the other entries as defaults; the " Prnt spot diagam ¥ Plot spot diagrem (' Spet diagram data
axial (FBY = 0, FBX = 0) is the default so Refrncepan
there is no need to use the Set Object e =
Point button. g r
e Clickon OK - -
Plot ray intersection points as
The colored symbols in this diagram represent the | % \Imeek
distribution in the image plane of rays which
evenly fill the pupil from a single point on axis.
The three colors represent the three default 0000000 2 dection shift o reference point focus )
wavelengths. The black circle represents the first ] =
minimum of the Airy disc, which is the intensity D'DDDE‘_DDd kSCE‘TDi“"”‘ e
in the image of a perfect lens of the same N Mo
aperture, in monochromatic light of the default —
central wavelength of 0.58756 um. — —
H ancel elp
The most important aspect of the diagram is that
all the rays fall within this circle. This is one of 'ﬁ
the criteria by which the assertion can be
. Spher 1al mirror ‘ FEY O FBX O ‘ FEFHT ©
made. SPOT DIAGRAM FCCUS O W 1-3 420
0.008
Answer: Yes, the image quality
at the focal point is “diffraction
o . o GEOMETRICAL GEOMETRIGAL
limited” - i.e. limited by the wave _ A F SIe ey SIzE
nature of light and not by aberrations.
. . DIFFRACTION GEOMETRICAL
HELP! Once again, if you have L e x 12E
trouble finding the graphics window,
from the Window menu header select o o

Tile Windows or type the command
ti le into the command line.

e (lose the surface data spreadsheet by clicking

on the green tick v,

Spherical mirror example
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Listing the lens surface data

® (Click on the Len header in the text window to list radii, thicknesses, apertures, glass
types and surface notes:

*LENS DATA
Spherical mirror

SRF RADIUS THICKNESS  APERTURE RADIUS GLASS SPE NOTE
0BJ - 1.0000e+20 1.0000e+14 AIR

AST  -16.000000 -8.000000 1.000000 AS  REFL_HATCH

IMS - - 8.0000e-06 S

® (Click on Rin to list the indices and thermal expansion coefficients:
*REFRACTIVE INDICES

SRF GLASS/CATALOG RN1 RN2 RN3 VNBR TCE
0 AIR 1.000000 1.000000 1.000000 -- -
1 REFL_HATCH 1.000000 1.000000 1.000000 - -—

2 IMAGE SURFACE

® Click on Ape to list apertures and any special apertures.

*APERTURES

SRF  TYPE APERTURE RADIUS
0 SPC 1.0000e+14
1 CMP 1.000000
2 CMP  8.0000e-06

® (Click on Wav to give the wavelengths and the spectral weighting factors on each.
*WAVELENGTHS
CURRENT  WV1/wWW1 WV2/Ww2 WV3/Ww3
1 0.587560  0.486130  0.656270
1.000000  1.000000  1.000000

® Click on Pxc to list the focal length and some of the operating conditions.
*PARAXIAL CONSTANTS

Effective focal length: -8.000000 Lateral magnification: -8.0000e-20
Numerical aperture: 0.125000 Gaussian image height: 8.0000e-06
Working F-number: 4._.000000 Petzval radius: -8.000000
Lagrange invariant: -1.0000e-06

HELP! There are occasions when the text output _;

gets turned off inadvertently. This is most likely to Text output: Off Page mode: Off |
occur if a CCL command is interrupted before it
has had time to complete its task. If nothing appears Page Mode
in the text window when text output is expected,
look at the first panel on the status bar at the
bottom of the main window. If it reads Text output:
Off, right click within the text window, and select

I ESRIC Iy A Set Text Output On. Remave Toolbar
Clear Window and 55 buffer

Log

Set Text Output On

Right

Spherical mirror example
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Saving the lens

To

create a new folder and save the lens in it:

® From the File menu header select

Of the two buttons labeled Library Directories at the bottom of the Save Lens As

WindOW, click on = Private Save Lens As

2%

Savein: | I3 User_Guide

At the top of the window, click on the
icon:

£ | Create new folder

Type the name for the new folder:

x| & ®E ok E-

User_Guide and click on Open

Under File name type:
spherical_mirror

Click on Save to save the lens with the
file name spherical_mirror.len

File name: [spherical_mirror len N 5
Save as typs: ‘Lens files \_“Ian:'.osl“ j Cai

Help
Library Directories: Private Public:

Note that OSLO is case insensitive, so this file cannot coexist with another file called, for

/7
LEN
EBR
ANG
DES
UNI
/7
AIR
TH
AP
NXT
RFH
RD
TH
NXT
AIR
wv
ww
END
DLR
DLN

An

example, SPHERICAL_MIRROR. len

Close the surface data spreadsheet with the green tick 4
The lens will be stored in the private lens directory e.g.
C:\Program Files\OSLO\EDUG64\private\len in the
newly created \User_Guide subdirectory. The file is in
ASCII format and contains the following text:

0SLO 6.4 39660 0 16046

NEW "'Spherical mirror"™ -8 2

1.0
0.0000572957795
"0SLO"
1.0
SRF 0
1.0e+20
9.9999999995e+13
// SRF 1
-16.0
-8.0
// SRF 2
0.58756 0.48613 0.65627
1.0 1.0 1.0
2
S 3
R 011
explanation of these commands will be found in Appendix 1.

Savejn: |3 len
trip.len

==

Spherical mirror example
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Changing the aperture

Question: If the aperture of the spherical mirror is increased to 3.44 mm is it still
“diffraction limited” at the new aperture?

® [n the surface data spreadsheet increase the entrance beam radius from 1 mm to
1.72 mm.

® (Confirm with the green tick v,

Select graphics window option: i
w B <o N b
2 Spherical mirrer FBY & FEX 0 REFHT 0
[een |[_setup |[ wavelengths | SPOT DIAGRA FOOUS O W= +an

Lens: Spherical mirror

Ent beam radius Field = =
Update window using cur-ent data
SRF RADIUS THICKNESS -
Re-calculate using new ol
0BJ 0.000000 1.0000e+20 [|
-16.000000 |  -8.000000 [] Zoom In
NS 0.000000 | o.ooo000 [|| GEQMETRICAL RICAL
FMS R STZE 5 1 SIZE
0. 001018 Q007178
E E Set Zoom Center

Now recalculate the spot didg;im:

® Right-click anywhere inside the graphics window containing the spot diagram plotted

previously.
LINIEMdUpdate window using current data:

to create the diagram

. Spherical mirror FBY O FBX O REFHT O
shown at right. SPOT DIAGRAM FOCUS 0 W1-3 +ao
0.02
Because the aperture has
increased, the spot diagram is
bigger (because of greater CEOMETRICAL es GEOMETRICAL
: o d RMS R SIZE RMS Y SIZE
flberratlons? qnsl the Airy disc 0 005239 0 003705
is smaller (it is inversely
proportional to the aperture).
DIFFRACTION GEOMETRICAL
Most pf the rays there.fore. LIVIT RV X STZE
now lie outside the Airy disc 0.001686 0.003705
circle.
-0.02
Answer: No, it is far from diffraction limited.

Spherical mirror example
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Drawing the lens in the graphics window, with “zooming”

To draw the lens system in a @ asluste  Optimize Tolerance Source Tools Window  Help
graphics window: t, =l
»

Glass Catalogs

® From the Lens menu
header select

Lens Drawinag Show Surface Data...

Coatings 4

Show Tolerance Data 4
> System Show Opﬁmiz.ah'on Da1.:e.| 4
; Show Operating Conditions... ¥ 2 |[ variabies |[ Draw
® Accepting all the defaults Show Auxiiary Data r
click on OK Lens Drawing..
Alternatively, : OO0 5,4 Zoom Layout...

. . . T| -1s.000000 -8.01

® (Click on the first icon in Ll ] Element Drawing Conditions. ..

5] o.oooooo[ ] o.m " )
54 Zoom Conditions Weights. ..

the graphics window
standard toolbar for Draw

system (2D plan view).
. Select_ View ... % %ﬁ' ?é ——] % n i
== 11

To view the paths of rays near the focus
at a higher magnification:

®  On the graphics window, left- Draw system |:E|:' |:I|E|I'| '-.l'iE'.n'-.':I
click-and-drag around the focus
as shown below.

® [ eft click twice within the graphics window to return to the full frame image.

Spherical mirror UNITS: MM
FOCAL LENGTH = -8 NA = 0.215 DES: OSLO

0.889
=

Note that the zooming action will work on all graphics windows except the Autodraw
window.

Clearly a better focal plane can be chosen, a short distance to the right of the current one.

Spherical mirror example
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Finding the best focal plane
Question: At this new aperture, where should the focal plane be chosen to give the
best image quality for green light on axis?

This can be found most quickly using the “autofocus” facility in the surface data
spreadsheet, one of a number of built-in optimization functions.

Open the surface data spreadsheet.

® (Click on the gray button next to the thickness for the image surface (surface IMS).

L INAIA utofocus - minimize RMS OPD ... @On-axis (monochromatic)
In this context, RMS OPD refers to the root mean square “optical path difference” (or wave
aberration). This autofocus action has the effect of finding the focal plane which minimizes

the RMS OPD and entering the necessary displacement as the thickness for the image space.
The thickness for the space preceding the image space is left unchanged.

THICKMESS AFERTURE RADIUS GLASS SPECIAL

1.0000e+20 | 1.0000e+14 arr [ ] [
-8. 000000 | 1.720000 REFL_HaTeH | ]
o. DDDDDD‘ Direct spedification :l

Variable (V)
Spedial variable. .. (V)

Autofocus - paraxial focus

Autofor - mipirgyrn BVS o i
Autofocus - minimum RMS OPD On axis (monochromatic)

— On-axis (polychromatic)

Listing the lens data - click on the Len header in the text window - gives the extent of
defocus needed:

*LENS DATA
Spherical mirror /2.33
SRF RADIUS THICKNESS ~ APERTURE RADIUS GLASS SPE NOTE
0BJ -- 1.0000e+20  1.0000e+14 AIR
AST  -16.000000 -8.000000 1.720000 AS REFL_HATCH
IMS - 0.023809 0.005127 S
The value listed for the defocus, shown as the
thickness at the image plane, is 0.023809 mm. To 0.023809 mm
get the actual distance from the mirror to the image <>

it is necessary to add the defocus value to the

nominal distance of -8 mm.

This is the only case in OSLO where an entry in the /
thickness column of the surface data spreadsheet

for a surface affects the axial position of that Nominal focus Best focus
surface rather than the surface which follows.
Answer: The best focus at an aperture of f/2.33 is at 7.976 mm from the mirror.

Spherical mirror example
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Plotting the on axis point spread function (PSF)

Question: Is the image “diffraction limited” at the new focal plane?
The evaluations carried out hitherto only show approximations to the actual distribution of
light in the image of a point source, since a spot diagram takes no account of diffraction.

To plot the true distribution of light in the image of a monochromatic point source, that is to
say, the point spread function:

® From the Evaluate menu header
select:

Spread Function
| dPlot PSF Map/Contour...
In the Sprd window which opens: Aberration Coefidents...

® Click on the radio button ?;:r 1';:;1;22 :
® Gray scale map

Faraxial Setup
Paraxial Ray Analysis...
g Z00m Lens Parameters

Single Ray Trace. .. velengths |[ wvariable:
® Click on the radio button Ray Fans 8 _
. Other Ray Analysis y (20000 Field angle ]
©® Monochromatic THICKNESS APERTL
Spot Diagram * | 1.0000e+20 ] 1.000¢

® Typein 0.01 for the
Size of patch on image surface.
® (lick on the radio button:
® Normalize to peak of PSF

Wavefront

Polarization Flot PSF IMap/Contour..
g o S
TmPlot Contours...
® Typein 128 for —— ' PrintPSF Value...
Number of lines/points in RS R STZE » BoPrint PSF Grid...
drawing E= x|

and click on  OK | —

Display type

" Color Map rey scale Map  ( Contour
T G : :
evie'e — Chromatic option

8 Monochromatic Palychromatic

G.8123 |§
HonMnital direction on plot is

X Y

oo [}EDEE Size of patch on image suface

Spherical mirror
Direct Integrotion-bosed

DACE BATEH S12F
Q.00 0.0

R
(e, Cremiy

Vertical pl alization
Nomalize\Ypeak of PSF " Perfectlenspeak =1.0 © Input nomalization valus

Computation mode
irect integration  ( FFT - pupil sampling control only

£ a3 o 3

Note that the first bright ring around the e - ,n

central maximum can just be seen.

Note also the figure at the top of the [T

scale on the right: 0.8123. This figure is [ 128\lunberof inespoirts in diawing
called the “Strehl ratio,” which is the ’O—K'\L Cancel Help

intensity at the central peak of the image '-‘\\

of a point source, normalized to that of

the Airy diffraction pattern of an ideal lens. The Maréchal criterion states that if the Strehl
ratio exceeds 0.8, a lens system may be described as “diffraction limited”.

Answer: Yes, the image is diffraction limited on axis at the new focal plane.

Spherical mirror example
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| Edit Lens Drawing Conditions

L

Extending the rays in the lens drawing

® Open the Lens Drawing Conditions spreadsheet by clicking on the
icon in the main window toolbar.

EH Lens Drawing Conditions

e .

nitial distance: Final distance: 0. 000000

e After Initial distance enter 16.
e (Close the spreadsheet with the green tick v,

Calculating the off axis optical path difference (OPD)

Question: What is the maximum OPD at full field for a semi-field angle of 18°
(total field angle 36°)?

® Open the surface data spreadsheet.
Enter 18.0 degrees as the (semi-field) Field angle
Left click on the gray SRF button for surface 1 (AST) to highlight the whole row.

Right click to bring up the menu of options.
Select ([ Me IS (o] to insert a new surface as surface 1.

EH Surface Data ‘:”:

o Selectspreadshest option =4
X v
?
[Gen | [Setup| [wavelength ] [Variables | [Draw on | [Group| [ Notes |
Lens: Spherical mirror Ef1 -8.000000
Ent beam radius 1.720000 Field angle 18.000RQ0 Primary wavin 0.587560
SRF RADIUS THICKNESS APERTURE RADLé GLASS SPECIAL
0.000000 [ | 1.0000e+20 [ | 3.2492e+19 ~ \y AR | ]

TE-ANAAAA __-8.000000 1.720000 | AS [ REFL_HATCH
0.023809 ]  2.596741

UNITS: b
DES: OSLO

Spher ical mirror
FOCAL LENGTH = -8 NA = 0.215

Reverse
Invert

Insert Catalog Lens...
Insert Lens File...

Scale Selection...
Scale Lens

Spherical mirror example
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® Under APERTURE RADIUS for the new surface 1, click on the gray button.

LENREIAperture stop (A

EEE Surface Data

o Selectaperure option: e
X ~
?
[Gen | [Setup | [wavelength | [Variables | [Draw on | [ Group | [ Notes
Lens: Spherical mirror Ef1 -8.000000
Ent beam radius 1.720000 Field angle 18.000000 Primary wavin 0.587560
SRF RADIUS THICKNESS APERTURE RADIUS GLASS SPECIAL
0BJ 0.000000 [ | 1.0000e+20 [ | 3.2492e+19 arr [ ] [
0.000000 [ |  0.000000[ | 1.7200 rect Speciication 1
.000000 [ | -8.000000 [ | Not Checked
.000000 [ | 0.023809 [ | Checked (K)

Pickup... (P)

C

=)
Aperture Stop (A)

Spherical mirror
FOCAL LENGTH = -8 NA =

Special Aperture Data... (X)

The aperture stop indication (AST) on the gray button under SRF will now move to surface
1, which at the moment is in contact with surface 2.

Note that the aberrations of the rays in the off-axis beam (drawn in blue) are so large that
they can easily be seen in the lens drawing.

To calculate the optical path difference, or wave aberration, over the whole pupil for three
field points (on axis, 0.7 field and full field):

® From the Evaluate menu header select:

| gReport graphic...

and in the dialog box which opens: [T Wavslengh nambr
® Enter 128 as the Number of lines Wﬁ””"“’"“s
0. Scale for pseudo-3D wavefront plot
[ ) Select@ Reference ray WavAynt Reference Pm’nt(apphedmdiw’duaﬂymﬁeldpa'\nts)
. . " Minimize RMS on image suface  ( BestFocus Reference ray intersection
intersection
Cancel
® (lickon  OK IN

FLOW FIELD=12de

Note the peak-to-valley figure of 37.05 wavelengths
under the map for the full field wave aberration.

Answer: The axial performance is better
than the standard criterion of a quarter of a
wavelength for the diffraction limit, but at full field
off axis the maximum OPD is 37 wavelengths.

v
P-v 37 05 RMS 7 722

Spherical mirror example
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Optimizing
The aperture stop is the limiting aperture of the axial beam. Its longitudinal position

determines the beam which is selected to form the off-axis image, and if the field is large,
this can have a significant effect on image quality.

Also the image has been assessed only over a plane surface - this is of course the usual
convention. For this exercise, however, we will investigate the benefits of allowing the
image to become curved.

Question: Where should the stop be placed, and what curvature of the image is
needed, to obtain the best performance over the whole field?

The answer to this question will demonstrate slider wheel Open the slider wheel spreadsheet |

optimization, one of the most useful features of OSLO.

e (lose the surface data spreadsheet. @

e Open the Slider-wheel Setup spreadsheet, by clicking on the

9
icon on the main window header. m

EEE Slider-wheel Setup

s

O No Internal evaluation
3 Draw only ¢ Ray-intercept NPD O Field sag ¢ Spot diagram (O Long. SA

Gcraphics scale: [ 0.000000| & Field point at R A1l points
Number of sliders: 1 '\\ ® Use dr‘i@ar‘ocessing
surf  cfg Item value
[ 1] [ Thickness\WTH) N\ | 0. 000000
3] 0.000000
oE e sw_callback ccL fun

Setup \\ame: | A\ |

The entries above the line define the contents of the window(s) which will be displayed
during slider-wheel optimization.

e Select® OPD (optical path difference, another name for wavefront aberration)

e Select® All points
Entries below the line determine which parameters will be adjusted with slider-wheels:

e Leave the default of 2 for the Number of sliders (up to 32 can be defined at any

one time). . o
. Curvature
e  On the first line, enter 1 under Surf and type th Curvature pickup multiplier (CVM)
in the box under ltem. Alternatively click on the Conic constant (CC)

box and select I GQEEERENS)] from the menu of

X decentration (DCX)

op tons. . Y decentration (DCY)
e On the second line, enter 3 under Surf and type 7 decentration (DCZ)
cv under Item. Apha tilt angle (TLA)
. . . Beta tilt angle (TLB)
e Click on the green tick v to close the Slider- Gamma tit angle (TLC)
wheel Setup spreadsheet. Titt vertex offset in x (TOX)

Tilt vertex offset in y (TOY)
The two graphics window which open, GW31 and GW32, Tit vertex offset n = (T02)

Spherical mirror example
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are specific to slider-wheel optimization. The scrollbar at the right of each slider wheel track
can be used to adjust the step increment of the slider-wheel motion. Changing the step size
also has the effect of centralizing the slider-wheel in the track.

= =
LB St

i

i 0.000000
Cv 3 0.000000

_Ik _>| Step 0.1

% ¥ Step 0.001 j

e  Watching the lens drawing in GW 32, and the plots of the optical path difference in
GW 31, move the upper slider to the extreme right (th 1 = 10) and the lower slider
to the extreme left (cv 3 = -0.1).

=

on the icon. However this time just close it again immediately. This
has the effect of centralizing the two slider-wheels and re-drawing
both windows with different scales.

e  Once again, open the Slider-wheel Setup spreadsheet, by clicking -|;

Although the OPD graphs
give no indication of scale,
it can be seen that the
performance is much

improved.
X
TH 1 10.000000 | M »| Stepol =
cv 3 -0.100000 Bl M | Stepooot =]

® Repeat the
sequence once more
until the best result

is given. This

should be when TH

1=16.0 mm and

CV3=-0.125

mm’’
= Slider Window
TH 1 16.000000 <_| _| j Step 0.1 j
cv 3 -0.125000 Ll _J _>| Step 0.001 j

Answer: The aperture stop must be at the centre of curvature of the mirror, and the
image surface must be a sphere with its centre at the aperture stop.

Spherical mirror example
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Assessing the final design
To evaluate the optical path difference of the new system, once again:
® From the Evaluate menu header select:

| gReport graphic...

and in the dialog box which opens: [ Wavslengt amber
® Enter 128 as the Number of lines Tft Hmperetines
0. Scale for pseuda-30 wavefront plot
) Select@ Reference ray Wav\Wnt Reference Point (applied i tofeld points)
. t tion " Minimize RMS on image suface (~ BestFacus Reference ray inlersectiont
intersec
. [qd o
® (Clickon OK R
FULL FIELD=12de 0.7 FIELD:_12 Hdeg Oh-Adlo=deg . 52

The peak-to-valley wave
aberration at the edge of the field
is less than a quarter wavelength,
so the lens is diffraction limited
over the whole (curved) field.

/

Listing the data

To list the correct prescription of | ol
the final design, the image kit

WRYELENGTH 1 = (557 um Spherical mirrar CELD
Z1Fep (7

separation needs to be adjusted. 3rscid P ) 128 b o i WAVEFRONT AMALYSIS oL

In the command line:
® Enter the command: th 2 -7.976 (note the spaces after th and after 2)

SRF 2:
TH -7.976000

® Enter the command: th 3 O;rtg to give the final listing (again note the spaces):
SRF  3:

TH -
*LENS DATA
Spherical mirror
SRF RADIUS THICKNESS APERTURE RADIUS GLASS SPE
0BJ -— 1.0000e+20 3.2492e+19 AIR
1 - - 1.720000 S AIR Save the current lens
AST -16.000000 -7.976000 1.720000 AS REFL_HATCH
IMS -8.000000 - 2.596719 S

e  Click on the save lens icon in the main toolbar to save the lens.

Exiting the program

® From the File menu header select @ If any
more changes have been made a message label
will give a warning to save the lens, otherwise
those changes will be lost.

Warning

L E Save changes to current lens file?
L

Mo ¥J Cancel |
A\

v

® Clickon No and the program terminates.

Spherical mirror example
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Conclusion

. . W ] "
This introduction shows that OSLO corpmands can be accessed | e Back ,_@
from the menu headers, from the text window headers, from
icons or entered directly into the command line. Commands | Corterts | index | Search |
can also be combined into programs in the languages SCL or [£] ©5L0 Help Overview
CCL, as will be shown in chapter 8. 1 [@: Getting Started

. . o [R® User Interface
Command names are important for accessing the 3 @ Lens Data Entry
documentation in the on-line help. Here are some of the B Evalugtion
commands that have been used (either explicitly or via the d [ Optimization
menus and icons) in this chapter: o [§ Telerancing
& Sources
file_new  Opens anew lens file ® Programming
0
uoc drl Updates lens drawing conditions [£] Command Name Detai
. @ Argument Definttions
pls Plots spot diagram =] List Specifications
+ a
len Lists lens data - g b
save Saves lens : g;
drl Draws lens i g f
auf Autofocus « @ a
+ @ h
sprd Plots the point spread function + g i
+ i
Ise Opens the surface data spreadsheet + @k
+ % |
rpt_wvf Plots wavefront map at 3 field points + g m
swe Opens the slider-wheel spreadsheet : & 2
. A @
th Changes a thickness 5@ q
rtg Lists radii/thicknesses/glass types I g ;
exit Terminates OSLO. o @t
+ @ u
To obtain a full list of commands: 4@
+ @ W
® From the Help menu header select (@3] MO} g[:1]¢) + g x
@y
® Seclect the Contents tab and click on © @

. The commands are listed in the alphabetic
sub-directories shown here.

Conclusion



Chapter 2 - Configuring OSLO

Introduction

Some ways in which the user interface can be adapted will be demonstrated in this section,.
It is recommended that these are implemented before proceeding with the remainder of the
exercises in this user guide.

Toolbar menus

This section shows how the toolbars in the main window, the text window, and the graphics
window may be populated with icons/tools.

Main window

On first use of the program, bring up the full range of icons into the main window

toolbar:

On the left of the main window toolbar, click on the blue and red
window Setup Window/Toolbar icon.

In the drop-down menu which appears click on Optimization
Tools.

Repeat for all the other items in the menu (not all the toolbars
listed will be available in Light or EDU versions)

Click on Set Toolbars/Row... and, if it is not already 3, enter
3.

Text window

Click on the blue and red window Setup Window/Toolbar icon
on the left of the text window header.

In the drop-down menu which appears click on Lens Data
Tools.

Repeat for all the other items in the menu.

Click on Set Toolbars/Row... and enter 3 for Maximum
number of toolbars on first row.

Click on Switch text windows to open a second text window,
if desired. It will have the same toolbar choices as the first. Only
two text windows may be opened at a time.

Eile Lens Evaluate QOptimi
BéEET @0
Tile windows
Mew graphics window
Switch text windows
55 right-dlick actions...

Set Toolbars/Row. ..

v Standard Tools

v Optimization Tools
v Tolerancing

w Gaussian Beams

v Extended Sources
W Zoom

v Advanced Analysis

EH Len Spe Rin Ape Wav

Switch text windows
Tile windows

Set window title. ..
Right-dick actions...

Set Toolbars/Row...

v Standard Tools
v Lens Data Tools
v Aberrations

v Ray Trace

v Image Analysis
v Tolerancing Data

22
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Graphics window
Each graphics window supports only a single toolbar, but up to 31 additional
graphics windows may be opened, each with its own choice of toolbar. %

® TFrom the Window menu header select:
Graphics» New

® In the header of the graphics window which opens, click
on the Setup Window/Toolbar icon.

BT E S &8
CE R EY

® Select one of the toolbar options.

® Repeat twice more to open a total of four graphics
windows. The current one always has a dark blue bar at

. . = GW 4
the top and an asterisk after the title; the header bars of A
the others are light blue. B new graphics windon
Tile windows
Set window title..
The Status bar Invert background
Right-click actions. ..
The status bar extends across the bottom of the main window Standard Tools
. . . . . Lens Drawi
for its full width. The following is a suggestion - there are e
g eqe e ay Analysis
many other possibilities.
Spot Diagram
® (lick twice on the status bar, or from the Window menu :ﬁ;
header select Status Bar- . Energy Anaiysis
® [cave the parameters for the first three fields unchanged.
® Set the parameters for fields 4 to 8 as follows:
4. Focal length Configure status bar rg|
5. Working F-number ~| Feld 1 [None ~| Feds
6. Lateral magniﬁcation Page mode ~| Field2 None ~| Field 10
. . Graphics autoclear ~| Field 3 MNone ~ | Field 11
7. Angular magnification Focallonih ] Feld4  [Nom =| =ewiz
8. Gaussian image height Working Frumber = | Field5 | None o FEETE
F h field. click th Lateral magnification  +| Field & None ~ | Field 14
or cac le, » ClIC Ol’.l c Angular magrification | Field 7 MNone ~ | Field 15
tab on the right hand side — _
Gaussian image height ~| Field 8 MNone ~ | Field 16
of the field, and then select . .
the option from the drop- Ok | Coned | _Heb |

down menu. This facility is
especially useful for keeping an eye on paraxial quantities during optimization.

® (Click on OK to close the window.

It is not advisable to set more than eight entries as the status bar is limited to 127
characters.

The status bar
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Preferences

Preferences are parameters which control many of the functions of the program operation,
regardless of what lens is currently open. Status bar settings and preferences, once set, are
preserved after exiting the program. They are stored in a text file called 0S10. INT in the
directory /private. This may be read with a text editor, but it must not be altered.

Preferences may be displayed using the show_preference command - e.g.
shp dsgn
or incorporated into print statements - e.g.

printf("'Current lens directory is %s\n",str_pref(cdir)).

® Before starting to define preferences, ensure that the surface data spreadsheet is closed.

Designer name (dsgn)

Several of the graphics windows include a space where the designer’s name is listed. The
default for new lenses is OSLO. To change it:

® From the File menu header select Preferences» Set Preference...
e From the gray list, select Designer

® On the prompt Enter string preference type [your_name] (with a maximum of
10 characters, no spaces) into the command line

® (lick on the green tick. v
Alternatively, just type Stp dsgn “[your_name]” in the command line and click on

the green tick v/ Note that this will not affect the current lens in storage, but only new
lenses created after the change.

ISO10110 drawing settings (adr1, adr2, adr3, edcm)

On ISO 10110 drawings there is a space for three lines of standard information, which
normally consists of your company’s name and address:

® From the File menu header select Preferences» Set Preference...
Select Address1

® Type [your_company_name] (maximum of 36 characters) in the command line under
Enter string preference:

® Alternatively, in the command line type: stp adrl “your_company_name” .
® (Close with the green tick 4

® Similarly for Address2 and Address3
e.g. stp adr2 “your_street_address”
stp adr3 “your_town”

Commas may be specified instead of decimal points on ISO 10110 drawings:

® From the File menu header select Preferences» Set Preference...
® Sclect Element_drawing_commas
® Select On under Select Boolean preference:

Preferences
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Graphics (gems, gacl, gfwb, glab, grax, gfbw, drra, pens)

Many of the preferences control the appearance of graphics output. For example, when
cutting and pasting graphics into Windows, the scale is generally too big for convenience. A
better scale is given if the gems preference is set to On:

® From the File menu header select Preferences» Set Preference...
® Sclect Graphics_emf_sizing

® Seclect On under Select boolean preference:
Several other graphics preferences are collected together for easy access:

® From the File menu header select Preferences »

Preference groups... » Graphics Automatically clear graphics windows
@ on  Of
L4 MOdlfy the entries in the popup box shown in the (Qs%whd?ﬂb%cfl’(gmund in graphics windows
. . . 2. n
illustration as required. y .
s [abels on graphics
% on " Off

® (lick on OK.

Draw axes on plots

& On  Of
Graphics alternate mode (gfam) S A
If the aspect ratio of exported graphics is reversed (landscape <- | con cor
> portrait) then look to see if gfam on | 0500000 Ray amow length in lens units
(Graphics_alternate_mode On) has inadvertently been set. | |1000210 Minimun scalfor grghics
If S0: abcdefgh Pen sequence cortrol word

A Cancel Help

® Enter the command: stp gfam off
® (Close with the green tick v

No error boxes (noeb)

Whenever an error message box appears, it needs to be cleared
immediately by clicking on OK. This can be a problem on
occasions, such as during slider-wheel optimization. A rdiee

. . Unrecognized word ‘lem’
It is possible for the user to suppress these error boxes

permanently. If desired:

® TFrom the File menu header select Preferences» Set
Preference...

® Sclect No_error_boxes
® Under Select boolean preference: sclect On

Tangent check (tanc on)

® Enter the command tanc on in the command line. This
will turn on the facility which permits rays to be drawn to
highly aspheric surfaces, such as the one illustrated here.

® (Close with the green tick v

Tangent check (tanc on)
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Compile CCL

To avoid potential problems, it is a good idea to compile all CCL files before starting to use
the program for serious work. To do this:

® From the Tools menu header select Compile CCL ...
® Inresponse to Select compile access: choose Public.
® Inresponse to Select compile option: choose All.
® Inresponseto Enter ccl opts: leave the default entry unchanged - e.g.:
-D _OSLO_EDU_ -D _OSLO_LIGHT_ -D OPENGL_GRAPHICS
Close with the green tick v
Check that the public CCL directory has compiled without error.
B | =n Spe Rin Aoe Wav Pxc Abr Mra Chf Tra Sop Ref Fan Sod Auf Was (e E= Sly Pko Ape HE Pxt Chr Sei Fif
Ref bot chf too skw Sos Wf Mif Psf Sif T
*CCL COMPILATION MESSAGES:
I No errors detected
.

version) click on the icon to “Compile all private CCL”.

® Once again confirm that the No errors detected message has
appeared in the current text window.
If an error message is given, then it will be necessary to correct, suppress or delete the file
whose name is shown. For example, the error message:

Repeat for the Private directory, or (not for users of OSLO EDU %

B | en Spe Rin Ape Wav Pxc Abr Mra Chf Tra Soo Ref Fan Sod Auf

Ref bot chf top skw Sos Wyt Mif Psf Srf
*CCL COMPILATION MESSAGES:
eval_ctn_version2.ccl 9: Duplicate procedure definition

indicates the error occurs on line 9 of the file eval_ctn_Version2.ccl in the private/ccl
directory. Further details are given in chapter 8.

Compile CCL
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Arithmetic calculations

Simple arithmetic expressions can be evaluated with the result given in the message bar.
® [fthe surface data spreadsheet is open, close it by clicking on the green tick v,

® Type cos(30*dr) and close with Enter or the green tick v

Command:
cos (30%dr) ﬂ
?

Command:
|

< X & [

Result = 0.8660254037844

® Enter atan2(sqrt(3),1)/dr

« Command:

X | =]

? Result=60.0

The following table gives all the arithmetical functions available in OSLO EDU:

Mathematical: pow (power), exp, log, loglO, sqrt, jO,
J 1 (Bessel functions)

Trigonometry (all angles are in radians):

sin, cos, tan, asin, acos, atan2

Rounding and limits: fabs, rint, r2int, round, min, max,
floor, ceil

Random numbers: rand (uniform), grand (Gaussian with zero mean)

OSLO commands

The main purpose of the command line is to execute OSLO commands.

o Enter file_open and close with the green tick 4

e [fthe message Save changes to current lens file? appears, click on No.

27
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® In the Open lens file window which opens, under
Library directories at the bottom, click on Private.

® C(Clickon trip.len

® (Click on Open

® [fthe surface data spreadsheet opens, close it with the green tick v,

Multiple commands are stacked with semicolons. For example, if we require to calculate the
“sag” of the first surface of the triplet (that is, the distance measured along the axis from the
plane through the axial point to the plane through the edge of the clear aperture):

® FEnterrtg 1 1;sag 1 6.5

*LENS DATA “sag”
DEMO TRIPLET <>|
SRF RADIUS THICKNESS APERTURE RADIUS GLASS SPE NOTE
1 21.250000 V  2.000000 6.500000 K SK16 C
*SURFACE SAG AND SURFACE NORMAL
SURFACE 1
Y X Z (SAG) NVL NVK NVM | —
6.500000 - 1.018527 -0.305882 - 0.952069

Commands can also be issued in a way that initiates a dialog for
subsequent parameters:

—

® Entersag ? T
® In the command window, in reply to the prompt Enter surface

number: enter 1
® In reply to the prompt Entery: enter 6.5
® Inreply to Enter x: leave the default value O
® (Close with the green tick v
*SURFACE SAG AND SURFACE NORMAL
SURFACE 1

Y X Z (SAG) NVL NVK NVM

6.500000 - 1.018527 -0.305882 - 0.952069
Assigning values to predefined variables
Values can be allocated, using the command line, to predefined variables. Predefined
variablesarea ... h, o ... z(real) 1 ... nand §1 ... nn (integer). Also

pre-defined are seven real arrays with indices 0 - 1999, ua[] ... za [] and three
string arrays of 256 characters astr, bstr, cstr. There are also two predefined
constants, dr (degrees to radians conversion factor), on (=1), off(=0) and pi. All are
case-insensitive.

Allocations remain until OSLO is closed and restarted.

For example we can calculate the z (“sag”) value listed above:

® Enter r=21.25;y=6.5;z=r-r*cos(asin(y/r))

Assigning values to predefined variables
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® Enter Z.
Result = 1.0185269938148
Here the value of z which appears in the message area is the “sag” of the previous example.

Take care if youuse c, ¥, 0, r orV as they are also OSLO command words. pi is 7,
but it is also an OSLO command. So do not enter pi on its own, but rather include it in an
arithmetic expression.

® Enter: +pi

Result = 3.1415926535898

Take care when arithmetical calculations are carried out while any
spreadsheet is open. The results of calculations will, if valid, be used as the
contents of the cell which is currently highlighted.

Printing

Results of printing appear in the current text window:

® Enter: prt At height y sag is z
At height 6.500000 sag is 1.018527

For more formal presentation, printed output can be formatted. This command uses the
formatted print command printf to print the volume of the “cap” enclosed by surface 1.

e Enter: aprintf(*'Volume=% .3F cu.mm.\n",pi*z**2*(r-z/3))

Volume= 68.149 cu.mm.

The first argument is a format string. In it, % . 3T is a format specification for the double
precision numeric value; the space after the % reserves a space for a minus sign (if any), 3
gives 3 places after the decimal point and T is the conversion character for floating point
format. Other characters in a format string are printed unmodified, until the final \n which
outputs a new line.

The history button

Previous commands can be called up,
for repeating a command, or

. . 2 printf ("volume=% .3F cu,mm.\n", pT"z=*2"(r-z/3 =
correcting it. e A Ry a2 _

E=21.25;y=ﬁ.5;z=r7r*(u5(asw‘n(y/r))
® (Click on the history button at tg L1539 1 6.5 0
the end of the command line. cos 30+
;Egelilz-ﬁ;gol 6.5 0
® Alternatively, press Shift- atanaqre ), 1) /e
F4. This is known in the

documentation as a keyboard shortcut; some others are listed below.

of Command

® Enter: prh to list the last 40 entries in the history buffer.

Keyboard shortcuts
F1 Open the online help

Printing
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Ctrl+N Open a new lens
Ctrl+O Open an existing lens
Ctrl+S Save the lens in its current file

In the command line,

Ctrl+X Cut selected text

Ctrl+C Copy selected text

Ctrl+V Paste selected text

Shift+F4 Show the history buffer

Ctrl+PgUp Scroll through the history (Ctrl+PgDn to scroll back)
In the text editor,

Ctrl+E Execute the selected text

Ctrl+G Go to the indicated line number

Ctri+Z Undo the last edit

Alt+F3 Find text (F3 to find again)

Ctrl+R Replace text (Ctrl-T to replace again)

In a spreadsheet,

Shift-spacebar Insert a new line before the current line

The message area

The message area under the command line can be used for formatted output. For example to
display a string preference:

® [Enter:

message("'Private dir: %s",str_pref(prid))

Private dir: C:\Program Files\OSLO\Prm64\private
The message area is where error messages can be printed. The message command also
converts error numbers to strings:

. Error in set_object_point:
L Enter- Sop 9 0 0 ! Warning: reference ray trace failed.
Total internal reflect

® (Click on OK in the error box.

® Enter: errno
Result = -3152 g Warning: reference ray trace faled.%s

® Different versions of \OSLO have different error
numbers. To decode an error number, enter: message
errno Again, click on OK in the error box before proceeding.

The message area
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Executing CCL command sequences

Valid CCL command sequences which use the pre-defined variables listed above, can be
executed within the command line. The total length of the command string must not exceed
255 characters.

® Enter:

prt lid;for(i=0;i<=ims;i++)prt cv[i] th[i] rn[i][1]
with the result:

DEMO TRIPLET

- 1.0000e+20 1.000000
0.047059 2.000000 1.620410
-0.006303 6.000000 1.000000
-0.049383 1.000000 1.616592
0.051813 6.000000 1.000000
0.007080 2.000000 1.620410
-0.057854  42.950000 1.000000

- - 1.000000

Here the count variable, 1, is a pre-defined integer.

The system data variables 11d (the lens identifier), cv[1] (the surface curvature, that is,
the reciprocal of the radius), th[ 1] (the separation from surface i to surface i+1) and
rn[i][1] (the refractive index in the space after surface i at the first wavelength) are all
examples of system data variables which can either be printed, or used in arithmetic
expressions or CCL programs. A list of such variables is given in the next section.

A system data variable such as th cannot, however, be changed by a simple variable
assignment statement such as th[3]=2.0. An attempt to do this will give the error
message:

Input error
Protected variable “th” may not be changed

Rather, it must be changed using the dedicated command which has the same name as the
variable. For example:

® Enterth 3 1.05;rtg

A new image surface may also be defined temporarily in this way:

® Enter Iims 3;rtg
The remaining surfaces are unaffected, but they will be lost unless the lens is restored before
the lens is saved again:

® Enter Ims 7;rtg
Other commands can be used to change the lens - e.g. the 10th system note, used as a label

in the public lens database:

® Enter snol0 TRIPLET;opc sno

*CONDITIONS: SYSTEM NOTES
10: TRIPLET

A list of lens update commands is given in Appendix 1.

Executing CCL command sequences
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Alphabetic list of system data variables

The following is a partial list of the system data variables. To obtain a complete list of all
variables exported from OSLO:

® From the Help menu header select OSLO Help F1

® Under the Contents tab select Programming» Accessing Data
» CCL Global Data

aac
aan
ad

ae

af

afo

ag
agn
amo
ang
ap
apchk
appksn
apspec
aptyp
as0,asl..
asi
asp
ast
atp
avxl
avx2
avx3
avx4
avyl
avy?2
avy3
avy4
axl
ax2
ayl
ay2
ber
ben
caa
cab

cc

cca
cch
cct
cdx
cdy
cns
curwav
cv
cvdat
cvmult

special aperture action
special aperture angle
aspheric coefficient in r*
aspheric coefficient in r®
aspheric coefficient in r®
afocal flag

aspheric coefficient in r*°
special aperture group
aberration mode

field angle

apertures

aperture checking flag
aperture pickup surface
aperture spec: ebr, nao, etc.
aperture type

aspheric surf coefficients
alternate surf intersection flag
aspheric surf type

aperture stop surf

special aperture type
special ap. x vertex 1
special ap. x vertex 2
special ap. x vertex 3
special ap. x vertex 4
special ap. y vertex 1
special ap. y vertex 2
special ap. y vertex 3
special ap. y vertex 4
special ap. axl

special ap. ax2

special ap. ayl

special ap. ay2

use base coord. for coord
tilt and bend flag
component aper alpha tilt tol
component aper beta tilt tol
conic constant

component coc alpha tilt tol
component coc beta tilt tol
conic constant tol
component x-decenter tol
component y-decenter tol
cone slope

current wv number (base 1)
curvature

curvature solve/pickup datum
curvature pickup datum

cvpksn
cvtyp
CVX
dct
dcx
decy
dcz
des

df
dfcsn
doe
dor
drw

dt

dth
dwv
dxt
dzt
ebr
errno
evza
fcc

fcv
fldspec
fno

frn

gc

gcs
gdt
gih
glpksn
gltyp
gmz
gnz
gor
goz
gra
arb
grc
grd
grpcode
grptype
gsp
gwv
hor
hvl
hv2

curvature pickup surf
curvature type

toric curvature

decenter tol

x decentration (local)

y decentration (local)

z decentration

designer name

diffractive surf coefficients
diffractive surf pickup
diffractive surf type
diffraction order

surf drawing option
decenter-tilt order flag

grin step size

design wv (diffractive surf)
x-decenter tol

axial surf shift tol

entrance beam radius
message nbr for last error
image evaluation coord. system
Fresnel surf substrate conic
Fresnel surf substrate curvature
field spec: obh, ang, etc.
image space working f-number
Fresnel surf flag

global coord. ref. surf number
global coord. reference surf
gradient index medium type
Gaussian image height
glass pickup surf

glass type

gradium blank thickness
gradium coefficient

grating order

gradium offset into blank
gradium coefficient

gradium coefficient

gradium coefficient

gradium coefficient

group code

group type

grating spacing

gradium dispersion data ref.
hologram diffraction order
hologram obj. real/virtual
hologram ref. real/virtual

Alphabetic list of system data variables
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hwv
hx1
hx2
hyl
hy2
hzl
hz2
ims
ims_1
irt

Idp
lensym
lid
nao
nap
nrl
nr2
nr3
nr4
numsap
numw
nzl
nz2
nz3
nz4
obh
pfl
pfm
pre
puk
rco

rd

rdt
rdx
rfs

m

rnt
rod
rotsym
rtf
sasd
sh
ska
skb
skc
sla
slb

hologram construction wv
hologram object x coord.
hologram reference x coord.
hologram object y coord.
hologram reference y coord.
hologram object z coord.
hologram reference z coord.
image surf number

image surf number minus one
irregularity tol

pen for lens drawings

lens symmetry flag

lens identifier

object space numerical ap.
image space numerical ap.
grin coefficient in r?

grin coefficient in r*

grin coefficient in z°

grin coefficient in z°

number of special apertures
number of wavelengths

grin coefficient in z

grin coefficient in z°

grin coefficient in z°

grin coefficient in z*

object height

perfect lens focal length
perfect lens magnification
system pressure (atm)
image space axial ray slope
coord. return surf number
radius of curvature

radius tolerance

toric radius of curvature
reference surf

refractive indices

refractive index tol

extruded surf spec

rotational symmetry flag
radius from test glass file
source astigmatic distance
radial spline height

Sellmeier gradium coefficient
Sellmeier gradium coefficient
Sellmeier gradium coefficient
Sellmeier gradium coefficient
Sellmeier gradium coefficient

slc

spl
splpts
spt
srftyp
ss

tat

tht

tce

tct
tem

th
thdat
thmult
thpksnl
thpksn2
tht
thtyp
tir

tla

tlb

tlc

tit
toric
tox
toy
toz
trr_fbx
trr_fby
trr_fbz
trr_fds
trr_fpt
trr_fxrf
trr_fyrf
ttun
twl
txyc
uni
varnbr
vnt
wav
wv
ww

zr

zrt

Sellmeier gradium coefficient
no. of radial spline surf zone
number of spline points
spherical form tol

surf type

radial spline slope

tla tilt tol

tlb tilt tol

thermal coefft of expansion
tlc tilt tol

system temperature (deg C)
thickness

thickness solve/pickup datum
thickness pickup datum
thickness pickup surf
thickness pickup surf
thickness tol

thickness type

total internal reflection flag

tilt about (local) -x axis (degs)
tilt about (local) -y axis (degs)
tilt about (local) +z axis (degs)
tilt tolerance

toric type

offset of tilt vertex in x

offset of tilt vertex in y

offset of tilt vertex in z
fractional x object coord
fractional y object coord.
fractional z object coord.

field point data

field point number

reference surf x coord.
reference surf y coord.

tilt tolerance units

tol fringe wavelength

couple x to y tols

number of mm in current units
next variable number

Abbe V-number tol

current wavelength number
wavelengths

wavelength weights

Zernike phase surf coefficients
Zernike srf reference ray trace

® Also in the online Help facility, under the Contents tab select
Programming » Accessing Data » Other Data to find the definitions of

the follo
beg_selection
fptnbr
nbr_pens
srfssopen
varnbr

wing read-only variables:
cfg current_pen cursnbr end_selection
gfx_window glass_name lensym maxcfg
numw oprnbr raynbr sdsnbr
ssb surface_note system_note txt_window

wav

Alphabetic list of system data variables
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8 x 30 binoculars: Specification

The task which will be used to demonstrate lens data input is the problem of modeling the
binoculars shown in the photographs, -

with 8x magnification, a 30 mm .
diameter entrance pupil, and a field of 1"'\"“\.
view of 6°. Measurements give an
overall length from the front of the
objective to the back of the eyepiece
of 103 mm. The distance from the
front objective to the eyepiece
mounting plate is 73 mm, and the
offset between the optical axis of the objective and the optical axis of the eyepiece is 28
mm.

Calculations

First of all we will calculate the sizes of the Porro prisms. Since the
offset between the two optical axes is 28 mm, the path perpendicular A
to the axis of the binoculars must be 20mm in each prism. The total

glass pass in each prism must therefore be 40mm, and the total glass v

path in the two prisms (shown here in an opened-out-view) 80 mm.

The glass which is most commonly used for prisms in the better quality binoculars is Schott
BaK4, which has a refractive index of 1.57.
The prism path length of 80 mm will then
have an “air equivalent” path length of
80/1.57 = 51 mm. This needs to be added to
the physical length (103 mm) to give a total $

- - 80 mm ._G.

air equivalent optical path from back to front
of 154 mm. Now, making an allowance of 19
mm for the finite thicknesses of both
eyepiece and objective gives a path between the principal planes, or equivalent thin lenses,
of 135 mm. So, to obtain the desired magnification of x8, the focal lengths required are 120
mm for the objective and 15 mm for the eyepiece.

Choosing an eyepiece

The eyepiece in most common use in prismatic binoculars is the Kellner. This consists of a
plano-convex single element lens, with a cemented doublet near the eye. An eyepiece
suitable for this application can be found in the book “Optical Design For Visual Systems”
by Bruce H. Walker.

Users of OSLO Standard and OSLO Premium:

® (lose the surface data spreadsheet.
® From the File menu, select Lens database,
® Select Public.

34
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prescription |[ spot piagram |

In the window that opens, click on LENS ID and choose Sort Up.

3

osLo 11 0.50 0.5 SCANNER

] bhw,/wa

7 0.07 20.0 EVEPIECE

osL0

& 0.10 18.0 EYEPIECE
& 0.10 1B8.0 EVEPIECE

Field A dap

AT Lo T
ST SHEADL AZR. () FosL ST ()
e

FLad b4 cag

=

REiREaEERE

]

I e
Tt D07

o
WNELST, +0.590 40,510 0,610

L

RAY TRACE ANALYSIS |

°
® Using the scroll bar on the right Feuje==m
. 648
find the lens with LENS ID (529 ] KeTTmer Eveyece
“Kellner Eyepiece” As a ::
check, the designer is shown as %
bhw/WA, the image surface =
number is 7. <
® C(Click on this line to call up the = Flentnse
. Sos Wvf Mif A
lens. The aberration curves are s s s
drawn automatically, and the Rellner eyql om
listing is given in the text o
window when Prescription is :oam
selected. i
°
°
respectively for the three wavelengths.
® In the text window click on Wav
*WAVELENGTHS
CURRENT  WV1/WW1 WV2/Ww2 WV3/ww3
1 0.587562  0.486133  0.656273
1.000000 1.000000 1.000000

Users of OSLO Light and OSLO EDU:

® From the menu header, choose File > New lens.

Open the surface data spreadsheet, and click on the gray Wavelength button.

Right click to get the choice of pre-defined wavelengths, and select d, F and C

® [ ecave the file name as untitled, leave Custom lens as the option, and enter 6 as the

number of surfaces.

[Gen | [sSetup | [Wavelength | [Variables | [Draw Off | [ Group | [ Notes
Lens: Kellner Eyepiece EF1 28.010014
Ent beam radius 2.000000 Field angle 20.000000 Primary wavln 0.587562
I RADIUS THICKNESS APERTURE RADIUS GLASS SPECTAL
.000000 | 1.0000e+20 [ | 3.6397e+19 AR ] [
000000 |  5.100000 [ |  2.000000 AR ] [
.000000 |  2.000000 [ |  8.000000 [ | F4 L]
.900000 |  8.000000 [ |  8.000000 [ | BAK2 ]
.900000 | 22.300000 |  8.000000 [ | AR ] [
.500000 |  6.000000 [ | 14.000000 [ | BAK2 L]
.000000 |  7.710000 | 14.000000 [ | AR ] [
.000000 [_| [ ] 9.800000 | L]

that the data entries are correct.

All users:

Fill in the surface data spreadsheet entries as shown. Check the Efl value to confirm

Note that the eyepiece has an object at infinity and an image at a finite distance. In other
words, we are tracing the rays from the eye to the intermediate image, in the reverse
direction of travel of the light. Surface 1 is defined as the aperture stop.

Choosing an eyepiece
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Scaling the eyepiece
The eyepiece must now be scaled to give the required focal length of 15 mm:

® In the surface data spreadsheet, click on Draw Off to open the Autodraw window (at
which point Draw Off becomes Draw On).

® After Lens: assign a title: Kel Iner Eyepiece F=15 mm

® Right click on any of the surface buttons on the left, and choose Scale Lens» Scale To
New Focal Length ...

Kellner Eyepiece F=15 mm UNITS: MM
FOCAL LENGTH = 15 NA = 0.07143 DES: bhw/WA

® [nsert 15 (this lens is already specified
in the default units of mm).

® (lick on OK.

® List the lens by clicking on Len in the
text window.

*LENS DATA
Kellner Eyepiece F=15 mm
SRF RADIUS THICKNESS  APERTURE RADIUS GLASS SPE NOTE
OBJ - 5.3552e+19 1.9491e+19 AIR
AST -- 2.731166 1.071046 A AIR Ent Pupil
2 81.934981 1.071046 4.284182 F4 C
3 7.979289 4.284182 4.284182 BAK2 C
4 -10.656903 11.942157 4.284182 AIR
5 12.584785 3.213137 7.497319 BAK2 C
6 -- 4.128880 7.497319 AIR
IMS -- -- \Y 5.221347 *

e Save the eyepiece in the private/len/User_guide directory with the name
bino_ep.len.

Choosing a catalog objective

Rather than design an objective from scratch, the task will be to locate a suitable lens in the
lens manufacturers’ catalogs provided with the program. The focal length required is about
120 mm. While the entrance pupil diameter is 30 mm, allowance must be made for
mounting, say 3 mm on the radius (larger than on an internal lens because of the
need to provide a seal against moisture). {ul

® (Click on the third icon on the main window toolbar,

[ ]

which is the symbol for a new lens. pleree

& Cisemier 1~ Catniaglers 1~ Pedlect lorn

Humbae of tacas [ 1

® In the dialog box which opens, click on OK.

In the surface data spreadsheet which opens, after
Lens: assign a title (e.g. Objective) o | o |

® Change Ent beam radius to 15 mm.

® Change Field angle to 3 degrees.

Scaling the eyepiece
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® Left click on the gray surface button in the first column for surface 2 (IMS) to select the
surface.

® Right click.

® From the drop-down menu, choose the option Insert Catalog Lens...

In the window which appears, make the

following selections: Crlzisis laniess

® First, at the bottom of the screen, for
Catalog: sclect NEWPORT-LEN :

® To find a cemented doublet, click on Is Q)
the button for Lens types ® Cem
Dblts

® [.cave default Sort By @EFL Part:PrEU‘Smnn’;;gg.s}aﬁgigggls:t 38.100

EFL: 125.000 Thickness: 12.400
® Enter the Central EFL (focal length), |+ % %
ens es;: em Dblts hers

120 mm and +/- Range 5 mm o o, & b O v

® Enter the Central Dia, 36 mm and zi:i::: EE,: _ﬁ :;i EZ:EE _ﬁ
+l_ Range 5 mm. catalog: [ NEWPORT_LEN Part Name:

® Click on the only lens listed, with focal length 125 mm, part number NPAC074.

® (lick on the green tick, and the window will close.

® Click on the gray button Group at the top of the surface data spreadsheet to show the
individual surfaces.

® Delete the non-functional first surface: Left click on the gray Srf button to select the
line, right click on the gray button to create the pull-down menu, and select Delete. The
aperture stop indicator (AST) on the surface number button will move to the first
surface of the doublet.

® Set the image distance to the paraxial image distance by clicking on the gray button in
the cell for the thickness of surface number 3 (the back focal distance). Select Solve
(S) > Axial ray height, and after Enter solve value type O. The thickness value
becomes 118.249113. An S will appear on the gray button next to this, indicating the
presence of a paraxial “solve.” What this means is that as long as the lens is rotationally
symmetrical, and paraxial rays are valid (that is, rays which are traced using linear
formulae, corresponding to light close to the optical axis), then the distance to the next
surface (in this case the image surface) will be adjusted so that the height of the paraxial
marginal ray at the next surface is zero - in other words, the image will always be at the
paraxial focus.

. .
® In the text window, click on Slv to _ - - =
. . prgiiis. Jolloecs d] =l

COl’lﬁrm thls deﬁnltlon. T Savnd lens fle C\Frogram Files\OSLOVEDUR\privein\leriLisar_Guide_\Binoculees\bino_obj kon

*SOLVES [Gen| [Setup| [wavelength| [variables| [oram off | [surfs| [motes |

Lens: objective EFT 125028852
PY - €nt beam radius  15.000000 rield angle 3.000000 Primary wavln 0. 567560

Save the lens in the e s T inemm ] swie T
- . . 2 W00 3200000 F 19050000 [ F ] 10 F —
private/len/User_guide directory ;- E] oo F]  as(] [

=1 oi00000 = .= =
. - - IHE . 000000 0. 000000 | 6552484 5 1
with the name bino_obj . len

In the text window, click on Len to list the lens.

Choosing a catalog objective
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*LENS DATA
Objective
SRF RADIUS THICKNESS  APERTURE RADIUS GLASS SPE NOTE
OBJ -- 1.0000e+20 5.2408e+18 AIR
AST 87.780000 F 9.200000 F  19.050000 AF BAFN10 F *
2 -52.752000 F 3.200000 F  19.050000 F SF10 F
3  -484.254000 F 118.249113 S  19.050000 F AIR
IMS -- -- 6.552484 S

® Check the lens prescription against the manufacturer’s published catalog.

Combining the objective and the eyepiece

The first task is to combine objective and eyepiece without the prisms.
® Ensure the file with the objective, bino_obj is open.

® Open the surface data spreadsheet.

® [fnecessary, click on Draw Off to open the Autodraw window.

® (Change the title to

Ob‘le?tlve and Ob jective and eyeplece UNITS: MMV
eyepiece FOCAL LENGTH = 1677 NA = 0.008944 DES: 0SLO

8.6

® Left click on the surface
button for the image
surface (IMS). This will
select surface 4, indicated

by a bold surround. — a=—1S

® Right click on the gray
button IMS, under SRF, to
bring up the options
menu.

® Choose Insert Lens File

L4 In the Merge lens ﬁle Lens: Objective and eyepiece Ef1 1.6772e+03
WindOW find the Ent beam radius  15.000000 Field angle 3.000000 Primary wavin
5

. . RADIUS THICKNESS APERTURE RADIUS GLASS
€yepiece file b|n°_ep 0.000000 | 1.0000e+20[ | 5.2408e+1a ar ]
and click on Open.

87.780000 [F | 200000 F  19.050000 [AF | BAFNID F

-52.752000 F .zooooo F o 1s.0s0000 [ F | SF10 F

. 249113 19. 050000 arr [ ]

w

w

-4B84.254000 F 11

m

00RO

SRE
aBl
[asT]
2
3
L1
eyepiece is now the wrong 5| sz2.02s813 ]
&l
7]
=]
=]

At this Stage’ OfCOUI'SG, the 0.000000 | 2.7341%4 [ |  1.050164[ | ar ]
1.072233 |  4.z88931[ | F4
7.9g813s [ |  4.zsssma[_ |  a.zsesma[_ | BAK2
way round. -10.868717 ]| 11.955336 [ | 4.zssszi[ ] ar [ ]
12.598736 | 3.z216699[ | 7.sosez0 [ | BAKZ
o.o00000 |  4.132458[ |  7.sosezo [ | ar [ ]

® Select the seven NS 0.000000 [ | o0.o000000[ |  2.616880

surfaces of the eyepiece
and the exit pupil (numbered 4 to IMS)

® Right click anywhere in this group.

® Seclect Reverse

Combining the objective and the eyepiece
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® (Click on Gen at the top of the surface data spreadsheet, and change Evaluation mode
to Afocal. This means that ray aberrations will be angular rather than transverse linear.
® Change the exit pupil (surface 10) aperture radius to 15/8
® (Click on surface 10 Special gray button. Select Surface Note (N) and change the
note to EXit pupil. Also under the surface 10 Special button, select Surface
control(F) > General Change Surface appearance in lens drawing: to Drawn,
and change the Pen numberto 4 (i.e. red).
® Save the file with the name bino_obj_ep.len
® (Click on Len in the text window header.
*LENS DATA
Objective and eyepiece
SRF RADIUS THICKNESS ~ APERTURE RADIUS GLASS SPE NOTE
0OBJ - 1.0000e+20 5.2408e+18 AIR
AST ~ 87.780000 F  9.200000 F  19.050000 AF BAFN10 F *
2 -52.752000 F  3.200000 F  19.050000 F SF10 F
3 -484.254000 F 118.249113 S  19.050000 F AIR
4 - 4.133458 2.616880 AIR
5 - 3.216699 7.505630 BAK2 C
6  -12.598736 11.955396 7.505630 AIR
7 10.668717 4.288931 4.288931 BAK2 C
8 -7.988135 1.072233 4.288931 F4 C
9  -82.025813 2.734194 4.288931 AIR
IMS - - 1.875000 * Exit Pupil

e Open the surface data spreadsheet and find the Autodraw window.

Objective and eyeplece UNITS: MM
ANGULAR MAGNIFICATION = —8.321 DES: OSLO

18.6

Combining the objective and the eyepiece
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Surface decenters and tilts

Before modeling the prisms, we will look at how tilted and decentered surfaces are defined.

i
=
-y

L
=

TLB

The gray button under Special in the surface data spreadsheet includes the option
Coordinates where all this is found.

The default sequence is Decenter, then tilt in which case the sequence of displacements
is:

1. Decenter by DCX along X axis, by DCY along Y axis, and by DCZ along Z axis,
all in system units.

2. Tilt anticlockwise about the new X axis through an angle TLA (degrees)

3. Tilt anticlockwise about the new Y axis through an angle TLB (degrees)

4. Tilt clockwise about the new Z axis through an angle TLC (degrees).

The tilts are shown in the diagram above. If the Tilt, then decenter option is chosen, the
order is reversed.

The effect of decentering or tilting a surface is also to decenter or tilt not only the surface
and its local coordinate axes, but also all the subsequent surfaces in the system.

To tilt only a component or group of surfaces, on the first surface apply the tilt and select
the option Use base coordinate system for coordinate returns to this surface:
YES. On the last surface, select Coordinate return: YES and Return to surface: [first
surface number].

To tilt a single surface, apply the tilt, then select Coordinate return: YES, Return to
surface: [default value, the same surface number] and Use base coordinate system
for coordinate returns to this surface: YES.

Surface decenters and tilts
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Adding a right angle prism

The task is to model a simple 90° prism. The measurement of the external dimensions of the
binoculars, allowing 3 mm for the case, suggests that the apex of the first prism (20 mm
deep) will be 70 mm behind the front surface of the objective (thickness 12.4 mm), leaving
an air space of 70 - 12.4 - 20 = 37.6 mm between the rear of the objective and the prism.

® Open the surface data spreadsheet.
® Change the lens title to Objective prism eyepiece
® (Change the thickness for surface 3 to 37 .6. The solve flag (S) disappears.

® Now add an extra surface before surface 4: Left click on the gray surface button for
surface 4, and then either right click on the same button and select Insert before, or
use the shortcut Shift-space.

Users of OSLO EDU will not be able to add the extra surface to the straight-through
binocular, since it will cause the surface count limit (10) to be exceeded. However,
starting with the file consisting of the objective alone (bino_obj) the exercise of adding
the first prism can proceed as described here.

® Change the thickness for the new surface 4 to 10 mm.

® Under the gray button in the column labeled Aperture Radius for this surface (surface
4), select Special Aperture Data (X). Leave the Ap Id: as 0. Change the shape to
Rectangle, keep the Action as Transmit, leave the Group: as 0, and set the semi-
aperture dimensions to:

Xmin=-10 Xmax =10 Ymin=-10 Ymax=10 Angle=0.0

® Change the med%um for |4 g eessesonon =
surface 4 from air to ?
glass: Chck on the gray [ Gen |[ setup |[ wavelength |[ Field points |[ variables |[ braw on |[ Group |[ Notes |
Lens: Chjective prism eyepiece Zoom 1 of 1 efl 25.123308
GLASS buttony sele(:t Ent beam radius  15.000000 Field angle 3.000000 Primary wavln 0.587560
SRF RADIUS THICKNESS APERTURE RADIUS GLASS SPECTIAL
Catalog > Schott > 081 0.000000 | 1.0000e+20 [ | 5.2408e+18 arr[ ] [
N-BAK4. (For some ROL-A0C215 | 14.100000 F  17.500000 FoE0 F [
versions of OSLO the T R e o I T R
current Schott catalog = o [Covmm oo Em AIR [
. L . [ copy |PHEEN 7.505630 Bak2 [T
will be in the dlrectory — Losszes |  7.505630 ] am [ ] [
[ Insert Before b288931 [ |  4.288931 [ ] BAK2 1
be Schott 2004 rather [ Insert After L072233 [ | 4.288931[ | ] [
than Schott). 3 Dekte L73ar0a | 4.288931 [ | ATR —
Q Denrarca 1000000 [ | 1.875000 [ ] j |5 cll’::r
® Select the entire row of — E
surface 4. Then right click, selecting Copy. Otherwise right click on the
copy icon on the right of the spreadsheet, shown in the diagram.
py the right of the spreadsheet, sh the diag
=¥
® C(lick on the gray surface button for surface 5. Right click and select =] e
. . . . . 3zl
Paste. Otherwise right click the paste icon. The new surface is added [ﬁ

before the one highlighted.
® Once more, click on the gray surface button for surface 5, right click and select Paste.

® Change the Thickness for surface 5 to -10.

Adding a right angle prism
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® Under the Aperture Radius gray button for surface 5, select Special Aperture
Data and set:

Ymin=-14.14 Ymax=14.14

leaving everything else in this dialog box unchanged.

® From the gray button under Glass for surface 5, select Reflect (hatch).

Cojective ond ayepisce
FoCAL LENOTH = 2768 Nk = 0 5410

® Under Glass for surface 6, type AIR

® To change the thickness for surface 6 to an axial ray height
solve, click on the gray button next to thickness for surface 6,

and select Solve (S) > Axial ray height, and after Enter

solve value type O.

® Under Special for surface 5, select Coordinates (C). Set
TLA = -45, and Tilt and Bend: Yes. Leave everything

else as default.

In most cases, tilting a surface rotates the coordinate system of the
airspace after that surface, and all subsequent surfaces, through the
same angle. However if Tilt and Bend is specified, the rotation is
through twice this angle, corresponding to the law of reflection.

® In the text window, click on Ape to list the special aperture
data for the three surfaces of the prism.
*APERTURES
SRF  TYPE APERTURE RADIUS
4 oW 12.022663

Special Aperture Group O:
0 ATP Rectangle AAC Transmit AAN -
AX1  -10.000000 AX2 10.000000 AY1  -10.000000 AY2 10.000000

5 CMP 11.590322

Special Aperture Group O:
0 ATP Rectangle AAC Transmit AAN -
AX1  -10.000000 AX2 10.000000 AY1l  -14.140000 AY2 14 .140000

6 CMP 11.157981

Special Aperture Group O:
0 ATP Rectangle AAC Transmit AAN -
AX1 -10.000000 AX2 10.000000 AY1 -10.000000 AY2 10.000000

® C(Click on Len to list the lens data. Note that the three solved aperture radius values seen
on the top-level spreadsheet for surfaces 4, 5 and 6 remain unchanged by the definition
of special apertures (X); these values are ignored.

Adding a right angle prism
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*LENS DATA
Objective prism eyepiece
SRF RADIUS THICKNESS  APERTURE RADIUS GLASS SPE NOTE
0BJ -- 1.0000e+20 5.2408e+18 AIR
AST 87.780000 F 9.200000 F  19.050000 AF BAFN10 F *
2 -52.752000 F 3.200000 F  19.050000 F SF10 F
3 -484.254000 F  37.600000 19.050000 F AIR
4 -- 10.000000 12.022663 SX N-BAK4 C
5 -- -10.000000 11.590322 SX  REFL_HATCH *
6 -- -67.900739 S  11.157981 SX AIR
7 -- 4.133458 2.616880 AIR
8 -- 3.216699 7.505630 BAK2 C
9 -12.598736 11.955396 7.505630 AIR
10 10.668717 4.288931 4.288931 BAK2 C
11 -7.988135 1.072233 4.288931 F4 C
12 -82.025813 2.734194 4.288931 AIR
IMS -- -- 1.875000 * Exit Pupil

e Click on Spe to list the surface notes, the coordinate (tilt) data and the surface tag
(pen color etc.) data:

*SURFACE NOTES
13 Exit pupil

*TILT/DECENTER DATA

5 DT 1 DCX - DCY - DCz -
BEN TLA  -45.000000 TLB -- TLC -
*SURFACE TAG DATA
1 LMO ELE (3 surfaces)
13 DRW ON
LDP 4

The eyepiece is incorrectly modeled since the signs of all curvatures and thicknesses should
be inverted. For the time being, however, we will ignore this and proceed to the next stage.

Converting the prism to a Porro prism

The Porro prism has two reflecting surfaces at right angles to each other.

Objective and eyepicce INITS . W
OPTICAL SYSTEM LAYOUT DES: 0SLO

® Select the entire row of surface 5. Then right click,
selecting Copy.

® C(Click on the gray surface button for surface 5. Right click
and select Paste.

® Using the surface data spreadsheet, change the Gbjective prism eyepiece ‘ UNTS: W

. OPTICAL SYSTEM LAYOUT DES: OSLO
thickness for surface 5 to —20 mm, and the e
thickness for surface 6 to 10 mm.

® Save with the name bino_porro.len.

® In the text window click on Len and Spe.

Converting the prism to a Porro prism
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*LENS DATA
Objective prism eyepiece
SRF RADIUS THICKNESS  APERTURE RADIUS GLASS SPE NOTE
OBJ -- 1.0000e+20 5.2408e+18 AIR
AST 87.780000 F 9.200000 F  19.050000 AF BAFN10 F *
2 -52.752000 F 3.200000 F  19.050000 F SF10 F
3  -484.254000 F  37.600000 19.050000 F AIR
4 -- 10.000000 12.022663 SX N-BAK4 C
5 -- -20.000000 11.590322 SX  REFL_HATCH =
6 - 10.000000 10.725639 SX  REFL_HATCH *
7 -- 55.152366 S  10.293298 SX AIR
8 - 4.133458 2.616880 AIR
9 -- 3.216699 7.505630 BAK2 C
10 -12.598736 11.955396 7.505630 AIR
11 10.668717 4.288931 4.288931 BAK2 C
12 -7.988135 1.072233 4.288931 F4 C
13 -82.025813 2.734194 4.288931 AIR
IMS -- -— 1.875000 * Exit Pupil
*SURFACE NOTES
14 Exit Pupil
*TILT/DECENTER DATA
5 DT 1 DCX - DCY -- DCZ -
BEN TLA  -45.000000 TLB -- TLC -
6 DT 1 DCX - DCY -- DCZ -
BEN TLA -45.000000 TLB - TLC .
*SURFACE TAG DATA
1 LMO ELE (3 surfaces)
14 DRW ON
LDP 4

Adding a second Porro prism

We will now add the second Porro prism. Note that users of OSLO EDU will have reached
the 10-surface limit even without the eyepiece, and will have to delete the objective
(surfaces 1 to 3) to complete this section, modifying the surface numbering accordingly.

® [n the surface data spreadsheet, select surfaces 4-7.

® Right click, selecting Copy.

Qbjective prism eyeprece UNTTS: W
GPTICAL SYSTEM LAYOUT DES: 0SLO

® (Click on surface 8 to highlight the whole surface, right-
click, and select Paste.

® Under Thickness for surface 7, enter O. This
automatically deletes the thickness solve on that surface.

® The aperture of surface 12 is not sufficiently large. Convert
it to a solved aperture by just setting the Aperture Radius for surface 8 to 0. The
solved value (6.552484) replaces it immediately.

® Surface 18 is not at the true exit pupil. Click on the gray button under Thickness for
surface 17, and select Solves (S) > Chief ray height... and enter O.

Adding a second Porro prism
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Completing the design

The model does not include the 90° rotation about the optical axis of the second prism

relative to the first.

To rotate the second prism Z axis through an angle of 90°, under Special for

surface 8, select Coordinates (C), and set the tilt angle about the z-axis, TLC =

90 (degrees).

Binoculars complete
OPTICAL SYSTEM LAYOUT

UNITS: M
DES: 0SLO

Change the lens title to: Binoculars complete.
Save with the file name bino_complete.len

Enter the commands: drl ;drr O;drr 1 todrawin
2 dimensions.

o

5=

The full prescription is obtained by clicking on Len Spe and Ape in the text window.

*LENS DATA
Binoculars complete
SRF RADIUS THICKNESS  APERTURE RADIUS GLASS
0BJ -- 1.0000e+20 5.2408e+18 AIR
AST 87.780000 F 9.200000 F  19.050000 AF BAFN10
2 -52.752000 F 3.200000 F  19.050000 F SF10
3  -484.254000 F  37.600000 19.050000 F AIR
4 -- 10.000000 12.022663 SX N-BAK4
5 -- -20.000000 11.590322 SX  REFL_HATCH
6 -- 10.000000 10.725639 SX  REFL_HATCH
7 -- -— 10.293298 SX AIR
8 - 10.000000 10.293298 SX N-BAK4
9 -- -20.000000 9.860957 SX  REFL_HATCH
10 -- 10.000000 8.996274 SX  REFL_HATCH
11 -- 29.655619 S 8.563933 SX AIR
12 -- 4.133458 6.552484 S AIR
13 -- 3.216699 7.505630 BAK2
14 -12.598736 11.955396 7.505630 AIR
15 10.668717 4.288931 4.288931 BAK2
16 -7.988135 1.072233 4.288931 F4
17 -82.025813 5.649290 S 4.288931 AIR
IMS -- -- 1.875000
*SURFACE NOTES
18 Exit Pupil
*TILT/DECENTER DATA
5 DT 1 DCX - DCY -—
BEN TLA -45.000000 TLB -
6 DT 1 DCX - DCY --
BEN TLA  -45.000000 TLB -—
8 DT 1 DCX - DCY --
TLA -- TLB -
9 DT 1 DCX - DCY --
BEN TLA  -45.000000 TLB -—
10 DT 1 DCX - DCY --
BEN TLA  -45.000000 TLB --

SPE NOTE

*

DCzZ
TLC
DCz
TLC

TLC
DCz
TLC

TLC

Exit

90.

Pupil

Completing the design
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*SURFACE TAG DATA

1 LMO ELE (3 surfaces)
18 DRW ON
LDP 4
*APERTURES
SRF TYPE APERTURE RADIUS
0 SPC  5.2408e+18
1 FIX 19.050000
2 FIX 19.050000
3 FIX 19.050000
4 CMP 12.022663
Special Aperture Group O:
0 ATP Rectangle AAC
AX1  -10.000000 AX2
5 CMP 11.590322
Special Aperture Group O:
0 ATP Rectangle AAC
AX1  -10.000000 AX2
6 CMP 10.725639
Special Aperture Group O:
0 ATP Rectangle AAC
AX1  -10.000000 AX2
7 CMP 10.293298
Special Aperture Group O:
0 ATP Rectangle AAC
AX1  -10.000000 AX2
8 CMP 10.293298
Special Aperture Group O:
0 ATP Rectangle AAC
AX1  -10.000000 AX2
9 CMP 9.860957
Special Aperture Group O:
0 ATP Rectangle AAC
AX1  -10.000000 AX2
10 CMP 8.996274
Special Aperture Group O:
0 ATP Rectangle AAC
AX1  -10.000000 AX2
11 CMP 8.563933
Special Aperture Group O:
0 ATP Rectangle AAC
AX1  -10.000000 AX2
12 CMP 6.552484
13 SPC 7.505630
14 SPC 7.505630
15 SPC 4.288931
16 SPC 4.288931
17 SPC 4.288931
18 SPC 1.875000

Transmit
10.000000

Transmit
10.000000

Transmit
10.000000

Transmit
10.000000

Transmit
10.000000

Transmit
10.000000

Transmit
10.000000

Transmit
10.000000

AAN
AY1l

AAN
AY1

AAN
AY1

AAN
AY1l

AAN
AY1l

AAN
AY1l

AAN
AY1l

AAN
AY1

-10

-14.

-14

-10.

-10.

-14

-14.

-10

.000000

142136

.142136

000000

000000

.142136

142136

-000000

AY2

AY2

AY2

AY2

AY2

AY2

AY2

AY2

10.000000

14.142136

14.142136

10.000000

10.000000

14.142136

14.142136

10.000000

Completing the design
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Introduction

In general, the graphics facilities in OSLO are of the most frequently generated using the
icons in the toolbars of the individual graphic windows. Some facilities, however, can only
be accessed from the menu headers, and some only by calling up CCL commands from the
command line.

A comprehensive catalog of the graphics facilities will be found in the Graphics Reference
in the appendix at the end, together with instructions as to how each may be accessed. In
this chapter only lens drawing and ray intercept coordinate reports will be discussed in
detail.

Opening a new graphics window
This exercise shows how a new graphics window can be opened in the top left corner of the
main window, just under the command window.

® From the main window select the Window menu header.

® Choose Graphics > Open and type the following responses into the command
window:

Enter graphics window
number: O

Enter window width: 320
End to window height: 300

Enter window x: O

Enter window y: 120

L ey

Note that the new window has a dark blue title bar, containing the letters GW 2 *.
GW means that it is a graphics window with no updateable content. The * symbol
means that it is the current window for graphical output. The coordinate system
defines x =0, y = 0 as the top left corner, and the command window covers the area
x =0 to 600, y =0 to 100. The point x = 960 (1420 for wide screens), y = 710 is the
bottom right position which can be seen without scrolling.

Labeling a graphics window

® From the main window select the Window menu header.

® Choose Graphics > Title... and type the following response into the command
window:

o Enter window title: Colors.

The title appears in the blue bar at the top of the window. In practice graphics windows are
titled automatically by the graphics command associated with the relevant icon in the
graphics window.

47
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Generating a plot

® Seclect the Tools menu header.

® Choose Plotting toolkit > Colors — - '
ER UW 2 - Colors | ]
and Pens. - Eg|

This executes the CCL command
colors, which is stored in the file
graph_tools.ccl in the public/ccl
directory. It shows the pen numbering
used in graphics plots.

Notice that the letters in the title bar
have now changed to UW, meaning
that the graphics window is updateable.

Saving a plot
® Right click on the window and choose Save As ...

® Save the file in any format. The size of the file stored will differ according to the
format chosen. For comparison, the file sizes for the Colors and Pens graphic are

shown:

Windows bitmap BMP | 164 kB
Compressed bitmap RLE 29 kB
HP-GL format HGL 29 kB
Windows metafile WMF | 118 kB

Placeable Windows metafile WMF 118 kB
Enhanced Windows metafile EMF 182 kB

Update window using current data

Cutting and pasting a plot

® Right click on the window and choose Copy to Zoom In

Clipboard.
® Open a Word document or PowerPoint Set Zoom Center
presentation, right click, and choose Paste. Print
Copy to Clipboa
® [f there are problems with the size of the image Save As... %
pasted into the new application, look again at the |~
Graphics Preferences in Chapter 2. Remove Toolbar

Clear Window

Introduction
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Lens drawing

Drawing a lens in 2D

This exercise will demonstrate some of the 2D drawing options, using the standard triplet
lens as an example.

|
® Click on the Open Lens icon in the main window toolbar. E’
® Open the file in the Private directory, trip.len
® In the graphics window, click on the Setup Window/Toolbar icon. EE
® Select the Lens Drawing toolbar.
® (Click on the Draw system (2D) icon. E
This gives a lens drawing including rays as the default. B R s

The corresponding icon in the Standard Tools toolbar gives
the option of a 2D (plan) drawing without rays.

Various options to enhance this drawing will now be
shown.

® C(lick, in the main window toolbar on the icon p—
shown here for Edit Lens Drawing Conditions. =&

® On the fifth line, against Image space rays: sclect Draw rays to
image surface. The button then reads Image srf

® From the menu header Select File > Preferences > Preference groups >
Graphics... and choose from the menu Use labels on graphics. Select Off.

® Open the surface data spreadsheet. %

® Click on the gray button under Special for surface 7 (IMS).

DEND TRIPLET ‘ UNITS: MM

® Sclect Surface Control (F) > General e s

® On the second line, against Surface appearance
in lens drawings: select Drawn. Set the Pen
number for surface in lens drawings as 3
(blue).

® (lose both spreadsheets.

® Once again click on the Draw system (2D) icon to draw the lens. E
® Click again on the icon in the main window toolbar for Edit Lens =L =
Drawing Conditions. OPC]

In the ray drawing table at the foot of the spreadsheet, change the three values of the
Frac.Y Obj (FBY)t0 0.0, -1.0, +1.0 respectively. Also change the number
of rays in the second fan (Rays) from 0 to 3, Min pupil to -0.4, and Max
pupil to 0.4.

Lens drawing



50 Graphical analysis Chapter 5

In this spreadsheet, for each successive ray fan (where the number of rays plotted is
non-zero) the pen colors cycle through the sequence:

1 . Green &5 Lens Drawing Conditions (=1 ]
o
2. Blue x = =
?
3- Red Initial distance: [ ENINMNEY Final distance:
Horizontal view angle: [Z240 vertical view angle:
4_ Light-BIue First surface to draw: [ 0]  Last surface to draw: [ 0] Autodraw:
x shift: ¥ shift: DXF/IGES Vview:
5 o Apertures: Rings: [E] Spokes: Image space rays:
- range Draw aperture stop: @ OFf (3 on Hatch back of reflectors: () off @ on
- Shaded solid color - Red: Green: Blue:
6. Vlolet Number of ray fans in lens drawings: Points for aspheric profiles:
Frac ¥ obj Frac x obj Rays min Pupil  max Pupil offser  Fy Fx wwn cfg
7 Ye"ow [—=-000000 [0.00000d 5] [—=-oooood [<.co000d [o.00000d & & [Z][2]
" ® O [}
8 Black 1.000000] [ 0.000000][ = ][ -1.000000] [ 1.000000 [ _0.000000 & <[ L] 0]
.

® Close the Edit Lens Drawing Conditions spreadsheet.
® From the Lens menu header, select Show Operating Conditions .. > Lens

Drawing
*CONDITIONS: LENS DRAWING
Initial distance: -— Final distance: --
Horizontal view angle: 240 Vertical view angle: 30
First surface to draw: 0 Last surface to draw: 0
X shift of drawing: - Y shift of drawing: -
Drawn apertures (solid): Quadrant Image space rays: Image srf
Rings in aperture (solid): 3 Spokes in aperture (solid): 4
Number of field points (rays): 3 DXF/IGES file view: Unconverted
Draw aperture stop location: off Hatch back side of reflectors: On
Red value for shaded solid: 175 Green value for shaded solid: 185
Blue value for shaded solid: 250 Points for aspheric profile: 41
Autodraw Options: YZ Profile
Fpt Frac Y Obj Frac X Obj Rays Min Pupil Max Pupil Offset Fan Wvn Cfg
1 - - 5 -1.00000 1.00000 - Y 1 O
2 -1.00000 - 3 -0.40000 0.40000 - Y 1 O
3 1.00000 - 3 -0.40000 0.40000 - Y 1 0
® Draw the lens in two dimensions by clicking on the icon for Draw
system (2D). E
DEMO TRIPLET UNITS: MM
FOCAL LENGTH = 50 NA = 0.125 DES: OSLO
7.34 -

Lens drawing
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Drawing a lens in 3D

® Open the Edit Lens Drawing Conditions spreadsheet again. =
On the fifth line, for Apertures: change Quadrant to Full apertures.  [a[;]s
For Number of ray fans in lens drawings enter 6, then scroll down
to enter the three new fans with Frac X Obj=0.0, -1.0, 1.0 respectively.
For the three fans, specify 5, 3 and 3 rays and for the last two fans, change
Min pupil to -0.4, and Max pupil to 0.4.
Select the radio button for FX for the last three fans.
Close the Edit Lens Drawing Conditions spreadsheet.

® To list these values, from the Lens menu header, select Show Operating
Conditions > Lens Drawing.

*CONDITIONS: LENS DRAWING

Initial distance: -— Final distance: -
Horizontal view angle: 240 Vertical view angle: 30
First surface to draw: 0 Last surface to draw: 0
X shift of drawing: - Y shift of drawing: e
Drawn apertures (solid): Full Image space rays: Image srf
Rings in aperture (solid): 3 Spokes in aperture (solid): 4
Number of field points (rays): 6 DXF/IGES file view: Unconverted
Draw aperture stop location: Off Hatch back side of reflectors: On
Red value for shaded solid: 175 Green value for shaded solid: 185
Blue value for shaded solid: 250 Points for aspheric profile: 41
Autodraw Options: YZ Profile
Fpt Frac Y Obj Frac X Obj Rays Min Pupil Max Pupil Offset Fan Wvn Cfg
1 -- -- 5 -1.00000 1.00000 -- Y 1 O
2 -1.00000 -- 3  -0.40000 0.40000 -- Y 1 O
3 1.00000 - 3  -0.40000 0.40000 - Y 1 O
4 -- -- 5 -1.00000 1.00000 -- X 1 0
5 -- -1.00000 3 -0.40000 0.40000 -- X 1 0
6 - 1.00000 3 -0.40000 0.40000 - X 1 0
® (Click on the icon for Draw system (3D solid model). .-&_
DEMO TRIPLET UNITS: MM
FOCAL LENGTH = 50 NA = 0.125 DES: OSLO
7.29
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Drawing a lens in 3D with sliders
® Click on the icon for Draw system (3D w/slider) -ﬂa

® Sclect Shaded solid.

IR UW 1 - Rotating View *
ERGGC DHB(50E 5

CstderWindow _________________|l-ox

‘Vertical angle 3n __j

A i
Horizontal angle 240 ﬂ _J _)i ‘

® [t may be necessary to extend the slider bars to make the slider tracks visible.

® Adjust the sliders according to the following table:

_Vertical I-_|orizonta| Description Example
view angle | view angle
30° 240° Default
30° 330° Isometric
0° 270° Y - Z (2D plan view)
90° 270° X-z
0° 360° X - Y view from image @

Lens drawing
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If the lens is saved with a particular 3D view in force, the values of the view angles will be
stored with the lens and used in subsequent 3D drawings. The horizontal and vertical view
angles may also be set in the Edit Lens Drawing Conditions spreadsheet.

Ray intercept curves analysis

The importance of these curves for diagnosis of aberration problems cannot be overstated,
so a detailed description will be given here of this analysis. The lens used for the graphs in
this section is the objective of the binoculars modeled in chapter 3.
Ray analysis (RIC)

® In the graphics window, click on the Setup Window/Toolbar icon. E%

® Select the Ray Analysis toolbar.

® (Click on the icon for RIC Plot. This gives a set of curves representing the
transverse ray aberrations for the default field point, which is on axis (FBY
=0.0). The left hand graph gives the plot of transverse ray aberrations (DY) in the

meridional section DEMO TRIPLET FBY 0 FBX O

(the Y - Z section) at RAY-INTERCEPT CURVES W1-3 +ao
different heights DY 1 0.05 DX  0.05

(FY) in the pupil.
The right hand graph

gives the same ) I
information in the . )
— I —

orthogonal plane - S
that is, DX as a / —
function of FX. The /

three curves are
colored according to
the wavelengths,

which, in the visible
at least, are representative provided the order in which the wavelengths are defined
is middle-short-long corresponding to green-blue-red.

If the system is defined as afocal (see under the Gen button in the surface data
spreadsheet) the aberrations are angular values DY A and DXA, expressed as
direction tangents.

Ray intercept curves for 2D field points
Users of OSLO EDU and OSLO Light should skip this section

-1 -

e Click on the icon for RIC vs Field Points. —=[

This gives the graphs laid out in two dimensions according to the relative field

coordinates FBX, FBY. In this case, three graphs g

are given for the three field points defined for this | X\frb\d }

lens, which are (reading from the bottom) FBY = L

0.0 (on axis), FBY = 0.7 and FBY = 1.0 (edge of 1 \
| l
\ [

Fmo

» o
}?‘E :‘”3 DEMO TRIPLET

= oy ey
b9y s 4 0 4on .ff;l’,f""“‘ 2D RAY INTERCEPT CURVES B e )

Ray intercept curves analysis
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field). The left-hand column gives DY as a function of FY, the right-hand column
plots DX against FX.

Ray intercept curves report graphic

® (Click on the icon for RIC Report Graphic. This icon also appears on ?é
the Standard Tools toolbar. The analysis results are shown as 6 graphs

within the same window, plus a 2D lens drawing.

1. The left-hand group (unlabeled) gives the same ray

TR m S O | oy
=2 \ s
=
5

intercept curves for three field points as the ray
intercept curves for 2D field points.

e e 55 et som O TRIET =%
Wete © % 4 0 430« 0 65 um RAY TRACE ANALYSIS R

This set of curves gives the relationship Field 3 deg

between the ray aberrations and their . by 0.1m DX

radial position in the pupil. If more than g EY EX
three wavelengths are specified, up to 12 ; N DB 1
sets of curves will be drawn, with N =

FBY=1

different symbols as well as different
colors to distinguish them.

. . Field 2.1 deg
Most of the other information in the DY -0.1mm DX
report (apart from distortion) can be
deduced from these curves. TSe FY FX
A designer can use these curves as a ‘ = L
diagnostic tool to analyze the different FBY=.7
types of aberration. This analysis is
important, since different aberrations AXIS
require different measures for their
correction. However these graphs do have
limitations. For example, they do not
indicate the aberrations of rays in the four
quadrants between the two orthogonal
planes.

FY FX

ASTIGMATISM
S x T + (mm

2. The astigmatism curves give the variation of paraxial focus
across the field for the meridional section (the Y-Z section,
labeled T) and the sagittal section (the X-Z section, labeled S).
Results are only shown for the mean wavelength. This curve
can be plotted as a stand-alone, either monochromatically or in

3 colors, using the menu header: 1 DZ

e Evaluate > Ray fans > Single field point ... U R
e Atthe top, select Field sags. T ONGLTUDTNAL

e Choose either Monochromatic or Polychromatic. SPHERICAL ABER. (rm)
e Click on OK. ]

3. The three curves for longitudinal spherical aberration give the
movement of the focal point along the axis for different radii
in the pupil, for the axial image point only, corresponding to
the three wavelengths.

Ray intercept curves analysis
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The curves for chromatic focal shift represent the axial beam
paraxial longitudinal focal variation with wavelength over the
range 0.4 to 0.7 um - or over a different range if other
wavelengths are specified. Alternatively, for OSLO Standard
and OSLO Premium users, this curve can be plotted as a stand-
alone, in slightly different format, using the menu header:

e Evaluate > Ray fans > Other ray analysis ...

e From the menu select Chromatic focal shift...

e Enter a wavelength range (or zeros for default).

e C(Click on OK.

Longitudinal spherical aberration curves indicate the errors in
focus DZ of the axial beam as a function of the pupil height
DY. Curves are given for the three specified wavelengths. The
graph is plotted on its own via the menu header:

e Evaluate > Ray fans > Single field point ...

e At the top, choose Longitudinal spherical...

e Click on OK.

CHROMATIC
FOCAL SHIFT (mm)

0.7

s | DZ

LONGITUDINAL
SPHERICAL ABER. (rmm)

The curve for distortion shows the departure from

the paraxial magnification as a function of field 0 .DOLZS IORTLON (%)
height. The distortion graph can be plotted alone in

a different format using the menu header: {

o Evaluate > Ray fans > Single field point R
e At the top, choose Distortion %

e Choose either Monochromatic or 0.0

Polychromatic.

e Insert a value for the aberration scale (in %).
e Click on OK.

The plots obtained from OSLO EDU and OSLO LATERAL COLOR (mm)
Light are different from the one shown here. 0.0002 -
6. The curve for lateral color shows the difference {
between the heights of the red and green rays, and FBY *
between the blue and green rays, as a function of
field height. The graph is not available as a stand- 0.0002
alone.
To control all the aberration scales, the RIC report graphic 0.100000  User abemation scale

command may be called from the main menu header.

From the Evaluate menu header select Other
ray analysis>Report Graphic..:

1.000000
0.200000

Fill in the spreadsheet with the required values.
The value of the abscissa scale is omitted as it only

. . 0.020000
applies to graphs where curves are plotted against

IOINIY  Abscissa scale

Field sags scale

Longsa scale

0500000  Chromatic shift scale

Distortion scale

h-tan U rather than DY.
® (Click on OK.

0000200  Lateral color scale
15.300000 Lens drawing scale

Ray intercept curves analysis
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Introduction

This chapter deals with the text window and the spreadsheet buffer which lies under it. In
order to illustrate the methods of numerical analysis, a simple task concerning the
demonstration triplet lens supplied with the program will be carried out:

For the triplet lens supplied with the program, calculate the transverse ray aberration
of the outermost ray transmitted at the edge of the third component at the edge of the
field, at the central (green) wavelength.
Also estimate the transmittance at the extreme field, as a percentage of the axial
transmittance.
The transverse ray aberration of an off-axis ray in the meridional section is the distance
from the point where this ray intersects the image plane, to the intersection point of the pupil
ray. This is shown in the diagram.
DEMO TRIPLET UNITS: MM
FOCAL LENGTH = 50 NA = 0.125 DES: OSLO

Before we can begin the task we need to locate the edge ray concerned in terms of its
relative pupil height coordinate FY.

Finding the edge rays

® Open the lens in the private directory trip. len. Alternatively it will be found in the
public directory as /[public/demo/LT/demotrip.len.

® In the text window, click on Ape to list the apertures. The indication CHK for surfaces
1 and 6 means that in the ray analysis which follows the rays which lie outside these
checked apertures will be obstructed. (Checked clear apertures are indicated by a K in
the Clear Aperture Radii column of the surface data spreadsheet).
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*APERTURES
SRF  TYPE APERTURE RADIUS

0 SPC  3.6397e+19
1 SPC 6500000 CHK
2 PKP 6-500000
3 SPC 5.000000
4 SPC 5.000000
5 SPC 6.500000
6 SPC 6500000 CHK -
7 CMP  18.170326
® In the graphics window, click on the
Setup Window/Toolbar icon, and
select the Lens Drawing menu.
7

® (lick on the icon for View Ray /
Fans (2D) - Interactive. L

5

® To define the point in the field as the

= O

edge of the field, set the slider-wheel
for Frac Y Obj to 1.0, and leave the  funewi
slider-wheel for Frac X Obj at 0.0.

1.000000 | »| Stepln =
_ b Sepin =
b Swp00os =
DECLLE

0.000000
0430000
0610000

HAEHE

® Adjust the slider-wheels for Min pupil and Max pupil until the extreme rays of the
bundle just pass through the first and last surfaces respectively.

® Note the values of the fractional pupil height for these edge rays: -0.43 and+0.61. The

latter is the value of FY needed for this problem.

Instead of this procedure, users of OSLO Standard and OSLO Premium may use a
quicker method for carrying out vignetting analysis:

e From the Optimize menu header, select: Support routines>Vignetting >

Vignetting analysis.

e Check Copy vignetting data to field point set? No
e Leave the Maximum pupil position to test at 5.0

e (Click on OK.

*VIGNETTING FACTORS

FPT  CFG FBY FBX FY2 FXMAX
1 0 - - -1.040001 1.040001 1.040001
2 0 0.700000 - -0.637293 0.810585 0.990811
3 0 1.000000 -- -0.431105 0.612924 0.901827

Graphical estimates

® From the Evaluate menu header select: Ray fans > Single field point ...

and, leaving all the default values
unchanged, click on Set object point
at the foot of the spreadsheet.

® In the Set object point spreadsheet, set
Fractional coordinates of object point
toFBY=1_.00 FBX=0.00FBZ =
0.00.

® (lose both spreadsheets, and note from the
graph that the value of the transverse ray

DEMO TRIPLET FBY 1 FBX 0
RAY-INTERCEPT CURVES W1-3 +a=

DY[O.W DXLO.W

| DY at WV 1 for ray at FY = |

aberration required is about -0.015 mm. (To confirm the units, from the Lens menu
header, select: Show operating conditions > General)

Graphical estimates
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® (Click on the Plot report graphics
wavefront analysis icon on the standard =
toolbar to get the pupil maps, and note that o ) 1
the area of the edge-of-field map is about S 4
50% of the area of the on-axis map. s ! 0. a0 e =
So we can conclude that the transverslz: ray
aberration of the edge ray is about DY =-0.015 ; | RELATIVE PUPIL AREAS E}

mm; the transmission at this field point is about _
50%.

| DEWD TRIFLET L
| WAVEFFRONT ANALYSIS | St

Numerical calculation

From the text window
® [n the text window, trace the pupil ray (the ray through the centre of the aperture stop)
from the edge of the object, by clicking on Chf.

® Then to trace a fan of rays in the meridional (Y) section, click on Fan. Set the
Minimum coordinate to be -0.43, the Maximum coordinate to be 0.61,and

Number of rays to be 2, and leave all other options as default values.

® Note the value of DY (transverse ray aberration in lens units) for the edge ray

transmitted:
*TRACE FAN - FBY 1.00, FBX 0.00, FBZ 0.00
RAY FY FRAC RFS DYA DXA DY DX
1 0.610000 0.530358 -0.071477 -- -0.013268 -
2  -0.430000 -0.353777 0.052849 -- 0.055365 -

® Click on Spd in the text window.

® Note the value of the per cent weighted ray transmission:
*SPOT DIAGRAM - FBY 1.00, FBX 0.00, FBZ "0.00 - POLYCHROMATIC
APDIV  17.030000
WAV WEIGHTS:
ww1 ww2 ww3
1.000000  1.000000  1.000000
NUMBER OF RAYS TRACED:

wv1 w2 wv3
104 104 104
PER CENT WEIGHTED RAY TRANSMISSION: 44.827586

*SPOT SIZES
GEO RMS 'Y  GEO RMS X GEO RMS R DIFFR LIMIT CENTY CENTX
0.021401 0.007555 0.022696 0.003426 -0.002879 -

*WAVEFRONT RS

WAVELENGTH 1
PKVAL OPD RMS OPD STREHL RATIO RSY RSX RSZ
2.224692 0.485250 0.091087 -0.004210 -- --

The conclusion then is that the transverse ray aberration of the edge ray is:
DY = -0.013268 mm,
and the transmission at this field point is:
44.8%
of the on-axis value, excluding the transmittances of optical materials and coatings.

From the menu headers

® From the Evaluate menu header select: Ray fans > Single field point ...
and choose the Command: Print Y ray-fan.

Numerical calculation
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e Set Minimum fractional y-component of pupil coordinate (FY) = -.43,
and Maximum fractional y-component of pupil coordinate (FY) = +.61.
Set the Number of rays in fan to the minimum value of 3.

® [ecaving all the other default values unchanged, do not close the dialog box, but click on
Set object point at the foot of the spreadsheet.

® In the Set object point spreadsheet, leave the specification as Direct entry Set
Fractional coordinates of object pointto FBY =1 .00 FBX=0.00 FBZ =
0.00.

® (Close the Set object point spreadsheet with the green tick, and click on OK in the Trace
fans of rays through lens dialog box:

*TRACE FAN - FBY 1.00, FBX 0.00, FBZ 0.00

RAY FY FRAC RFS DYA DXA DY DX Dz
1 0.610000 0.530358 -0.071477 -- -0.013268 - -
2 0.090000 0.075914  -0.010854 -- -0.009257 -- -
3 -0.430000 -0.353777 0.052849 -- 0.055365 -- --

® From the Evaluate menu header select: Spot diagram > Single spot diagram...

® Seclect Spot diagram Data and click on OK (the earlier Set Object Point command is
still valid).

*SPOT DIAGRAM - FBY 1.00, FBX 0.00, FBZ 0.00 - POLYCHROMATIC
APDIV 17.030000
WAV WEIGHTS:
wwi ww2 ww3
1.000000 1.000000 1.000000
NUMBER OF RAYS TRACED:
w1 wv2 w3
104.000000 104.000000 104.000000
PER CENT WEIGHTED RAY TRANSMISSION: 44.827586
SPOT DIAGRAM SYMMETRY: 1.000000

From the command line (abbreviated)

® In the command line, type the following:
sop 1 0 O;trfy 2 -.43 .61;spd 200

and click on the green tick, or press Enter on the keyboard.

Numerical calculation
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*SET OBJECT POINT

FBY FBX FBZ
1.000000 - --
FYRF FXRF FY FX
YC XC YFS XFS OPL REF SPH RAD
18.264293 - -0.911383 -0.096417 65.421390 61.550663
*TRACE FAN - FBY 1.00, FBX 0.00, FBZ 0.00
RAY FY FRAC RFS DYA DXA DY DX
1 0.610000 0.530358 -0.071477 - -0.013268 -
2 -0.430000 -0.353777 0.052849 - 0.055365 -

*SPOT DIAGRAM - FBY 1.00, FBX 0.00, FBZ 0.00 - POLYCHROMATIC
APDIV ~ 200.000000
WAV WEIGHTS:
Ww1 ww2 ww3
1.000000 1.000000 1.000000
NUMBER OF RAYS TRACED:

wv1 w2 Wwv3
13820 13712 13868
PER CENT WEIGHTED RAY TRANSMISSION: 43.909889

*SPOT SIZES
GEO RMS 'Y GEO RMS X GEO RMS R DIFFR LIMIT CENTY CENTX
0.020881 0.006382 0.021835 0.003276 -0.003196 -

*WAVEFRONT RS

WAVELENGTH 1
PKVAL OPD RMS OPD STREHL RATIO RSY RSX RSZ
2.711822 0.447068 0.060859 -0.005045 -- --

The new value for the transmission (43.9%) is more accurate than the earlier result since a
finer grid of rays (200 rings, not 17.03, in the pupil) was defined by the Spd command.

By executing in the Edit window @

® From the Window menu header select: Editor > Open or click the icon.

® Use the history button to call up the last line executed:
sop 1 0 O0;trfy 2 -.43 .61;spd 200

® (Copy and paste it into the Text editor window.
® Highlight it with the cursor (or press Ctrl-A), and press Ctrl-E. Results are the same.

From the command line (in full)

® [n the command line, one might perhaps type the following:
set_object_point(1.0,0.0,0.0,0.0,0.0,1)
trace_fan(y,2,-0.43,0.61)
spot_diagram(chr,none, 200)

These forms of the commands are used to make programs self-documenting. The short
forms are more useful for command line entry.

The spreadsheet buffer

The spreadsheet buffer is an array of numerical storage cells, with 1999 rows numbered as
in Microsoft Excel, which underlies each text window. The spreadsheet buffer is used for
conveying the results of numerical OSLO calculations to variables in CCL commands, so it
is important to understand how it works.

Clearing the text window and spreadsheet buffer

There are three ways to do this:

The spreadsheet buffer
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® EITHER right click anywhere in the text window and select Clear window and SS
buffer

® OR, from the Window menu header, select: Text > Reset.

® OR, in the command line, Enter twr (or textwin_reset)
To clear the spreadsheet buffer without affecting the printed output in the text window:

® In the command line, enter sbr (or ssbuf_reset)

Reading from the spreadsheet buffer

e In the text editor window, change the first entry so the whole line looks like this:
sbr;sop 1 0 O;trfy 2 -.43 .61;spd 200

® Highlight the line with the cursor, and press Ctrl-E.

® Watching the message area under the command line, click on the text window output to
confirm the following spreadsheet cell allocations:

*SET OBJECT POINT

FBY FBX FBZ
[ al ] [ bl ] [Lcl 1]
FYRF FXRF FY FX
[ a2 1] [ b2 ] [ c2 1] [ d2 1]
YC XC YFS XFS OPL  REF SPH RAD
[_a3 1] [_Db3 1] [_c3 1 [Ld3 1 [_e3 1 [_f3 1]
*TRACE FAN - FBY 1.00, FBX 0.00, FBZ 0.00
RAY FY FRAC RFS DYA DXA DY DX
1 [ a4 1] [ b4 1] [ c4 1 [ d4 1] e4 [ 4 1]
2  [a5 1 [ b5 1] [ 5 ] [ d5 1] [ e5 [ 1]
*SPOT DIAGRAM - FBY 1.00, FBX 0.00, FBZ 0.00 - POLYCHROMATI
APDIV a6
WAV WEIGHTS:
ww1 ww2 ww3
a7 1] [ b7 ] [ c7 1
NUMBER OF RAYS TRACED:
wv1i w2 wv3
13820 13712 13868
PER CENT WEIGHTED RAY TRANSMISSION: asN\. 1
*SPOT SIZES [%
GEO RMS Y GEO RMS X GEO RMS R DIFFR LIMIT CENTY CENTX

[La9 1 [_b9 1 [Lco 1 [do 1] [e9 1 [fo 1]

*WAVEFRONT RS
WAVELENGTH 1
PKVAL OPD RMS OPD STREHL RATIO  RSY RSX RSZ
[ al0 ] [ blo ] [ clo ] [ dio ] [ el0 ] [ f10 ]

Note that integers and headers are not included in the spreadsheet buffer.

® (Click on the two numerical results indicated, and note the cell coordinates and values
given in the message area as follows:
e4 = -0.0132683238458
a8 = 43.909889270714
Note also that these results are full precision (to 14 digits).

Writing to the spreadsheet buffer

® In the text editor window, add the command for formatted printing:
aprintf("'DY = % 6.6F Trans = %4.1f %%\n",e4,a8)

giving the following output:

The spreadsheet buffer
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DY = -0.013268 Trans = 43.9 %

Note that the contents of cells of the spreadsheet buffer can also be accessed using the real
array ssb(row, column). For example, e4 becomes Ssb(4,5) and a8 becomes
ssb(8,1).

The command aprintf places the two values in the spreadsheet buffer, still at full
precision, even though they are printed with fewer places (6 and 1 respectively) after the
decimal point. Note in particular that the cells are filled even if printing is turned off.

® (Click on these results to confirm this:
a11 =-0.0132683238458
b11 =43.909889270714

Scrolling the spreadsheet buffer

This section should be omitted at the first reading, as it describes a feature used only in
advanced programming.
® Type in the command line: sbrow and press Enter

Result =12
This is the row number of the next row to be written to in the spreadsheet buffer. The
command sbr (ssbuf_reset) remaps the spreadsheet row whose number is the first
argument, with the row number of the second argument. So to renumber the lines so that
any new output is written to row 1 rather than row 12:

® In the text editor window, change the first entry so the whole line looks like this: sbr
12 1;s0p 1 0 O;trfy 2 -.43 .61;spd 200

® Highlight it with the cursor, and press Ctrl-E.

Note that the row numbers are the same as before, but this time the rows which had been
previously written are

preserved, and numbered up to Initial row a-column After After
1999 numbering Values sbr 12 1 sbr -12 0
1 1.000 1989 1
We can restore the line 2 0.000 1990 2
numbering by using the sbr 2 13 - 2(154 13:; 2
command with a negative index: 5 ~0.43 1993 5
® [n the command line type: 6 200.0 1994 6
sbr -12 0 7 1.000 1995 7
8 43.9 1996 8
The effect of this is illustrated 9 2959 1997 9
in the table. The next row to be 1(1) 0 0-1731268 :ggg 12
written to (in other words, the 1o 1= 1o~
value of the read-only variable 13 2 13

sbrow) is marked with an
asterisk in each case.

The spreadsheet buffer
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1:1 wide angle relay

Introduction

The slider-wheel facility is a powerful tool, which allows the user to control any system
variable while watching its effect on any numeric parameter or graphic display. In this
chapter there will be an illustration of how slider-wheels alone can be used to complete a
design task.

The requirement is for a four-element unity magnification relay. The object has a diagonal
of 600 mm. The object to image distance is 451 mm. The distortion must be less than 0.1%
and the design criterion is that the lowest value over the field of the modulation transfer
function at 1.0 cycles/mm must be greater than 0.4. The wavelengths to be used for the MTF
calculation are the usual three (0.58756 um, 0.48613 pm and 0.65627 um), weighted
equally.

Defining the starting point

Clearly a symmetrical design is called for. In the public ROOgSTNDY S60ECHFOV /8.3 US> R

FOCAL LENGTH = 100 NA = 0.05997 DES: OSLO
lens database (OSLO Standard and Premium only)
there is an objective lens designed by Roossinov which
will be used as the basis for the design of a relay lens.
This has the title ROOSSINOV 56DEGHFOV F/8.3
USP2,516,724. 1t is nearly symmetrical and it has 13
surfaces. The design below has been adapted and

simplified from this for use with all versions of OSLO.

Setting up the starting lens

® From the menu select File>New lens and choose a custom lens with 5 surfaces.
® In the surface data spreadsheet, change the lens title to X1 relay.

® (Click on the gray button under Aperture Radius for surface 5, and select Aperture
Stop (A) to move the aperture stop to surface 5.

UNITS: MM
DES: 0SLO

. . . . x1 rela
® Fill in the lens parameters as shown in the diagram Fock. P = 245.5" = 0.00154

below. The values for Aperture Radius may be
omitted, as these will be adjusted using aperture
radius solves - that is to say, the aperture will be set
at the value equal to the arithmetical sum of the
paraxial marginal and pupil ray heights. This is such
an extreme field angle lens that the results look

unrealistic at first, but this can be corrected later.
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- —
x| -l
?
[Gen]| [ sSetup] [wavelength | [Variables | [Draw On | [ Group | [ Notes
Lens: x1 relay EFf1 245.905902
object num aper 0.030000 object height 300.000000 Primary wavlin 0.587560
SRF RADIUS THICKNESS APERTURE RADIUS GLASS SPECIAL
0B3J 0.000000 __| 155.000000 [__] 300.000000 AR | [_]
55.000000 |  3.000000 ] 55.000000 F1 ]
33.000000 | 50.000000 ] 33.000000 AR | ]

3] 63.000000 | 17.000000[ | 20.735891 Sk4 L]
444.000000 [ |  0.500000 [ |  8.295530 AR [ | [
0.000000 |  0.000000[ | 7.711171 AR | [
[IMS| 0.000000 [ | 0.000000[ | 7.711171[ S| ]

e In the Setup spreadsheet, enter the Object NA as 0.03 and the Object height as

300 mm. Close the Setup spreadsheet.

® Select surfaces 1 to 4, right click and choose Copy.

® Select surface 6 (IMS), right click and select Paste

® Select surfaces 6 to 9, right click and choose Reverse.

® Change the thickness for surface 5 to 0.5 and for surface 9 to 155.

® In the Aperture radius column some are already Solves. Change the remaining
apertures (surfaces 6 to 9) to Solve (S) by setting them to zero.

® Under Radius, click on the gray button for surface 9, choose Minus curvature
pickup, and on the prompt Enter pickup source surface, enter 1. Press Enter
twice more. Define a similar minus curvature pickup for surface 8 from surface 2, for
surface 7 from surface 3 and for surface 6 from surface 4.

® Enter the command ctg to list the lens with curvatures:

X*LENS DATA

x1 relay
SRF CURVATURE THICKNESS  APERTURE RADIUS GLASS SPE NOTE
0BJ -— 155.000000 300.000000 AIR
1 0.018182 3.000000 55_.000000 S F1 C
2 0.030303 50.000000 33.000000 S AIR
3 0.015873 17.000000 20.735891 S SK4 C
4 0.002252 0.500000 8.295530 S AIR
AST - 0.500000 7.775659 AS AIR
6 -0.002252 P 17.000000 8.294476 S SK4 C
7 -0.015873 P 50.000000 20.712585 S AIR
8 -0.030303 P 3.000000 33.000000 S F1 C
9 -0.018182 P 155.000000 55.000000 S AIR
IMS - - 300.541968 S
® Click on Gen in the Surface data spreadsheet to open the General conditions

spreadsheet.

1
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® Under Ray aiming mode, sclect Wide angle mode.

1re

x1 reloy UNITS: MV
FOCAL LENGTH = 96.44 NA = 0.03269

® (Close the General conditions spreadsheet. DES: 0SLO

® (Change the Lens drawing conditions to
draw 3 rays for each of the field points
FBY =0, FBY =-1, FBY = +1. SN

The lens drawing should now appear as
shown in the diagram.

Slider-wheel design with ray intercept curves

® Open the Slider-wheel Setup spreadsheet by clicking on the icon in the main
window toolbar.

B Slider-wheel Setup

0.015873
0.002252

® Sclect Ray-intercept, All
. 7
SlldeI'S = 4, and deﬁl’le 2 No Internal evaluation
Sliders on Surfaces Graphics scale: 000000 o 1 Field point at @ All points
Number of sliders: [ 4 | ® Use drag processing
(CV) Curvature [EV] | 0. 018182
. [Curvature (V) ] 0.030303
[ Curvature (O]
& Enable sw_callback CCL function

H v =, CETR 2
points, Number of ELARE LI =i
o Draw only & Ray-intercept o OPD o Field sag o Spot diagram & Long. SA
1,2,3,4 for the curvature |05 *cp i Vatue
1]
—
31 Curvature (CvJ
. 4
® (lose the Slider-wheel Setup
spreadsheet. (et rane: | '

At this point the four sliders and two graphics windows, GW31 and GW 32 should become
visible. If not, try using the Tile command, or open and close the Slider-wheel spreadsheet
again.

® The default step size is too large. Click on the lower scroll button at the right-hand end
of each slider-wheel to bring the Step to 1e-05.

®  Adjust the sliders to improve
the performance as far as oW
possible.

® Once the aberrations are too
small to discern at the default F
aberration plotting scale, o p e o ne
reopen the Slider-wheel Setup g
spreadsheet and close it again :
immediately. The aberrations T g B s p W
will be redrawn with a new ———— e ———
scale, and the slider-wheels :

A

re-centered in their tracks. s
. . . (] 0.018182 LJ J j Steple-0s

The step size will still need to e = - W
be changed, however. v 0015173 < Bl | eprets =
v 4 0.002252 L] J j Stepleds

If a slider reaches the end-

stop, change the step to re-center it. Note that the graphics zoom feature works on both
windows, and the zoom settings are preserved during slider operation.

Slider-wheel design with ray intercept curves
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One possible solution, for example, is

LNITS: MM
DES: 0SLO

CV 1 =0.018822 (RD 1= 53.130 mm)
CV 2 =0.030683 (RD 2 = 32.591mm)
CV 3 =.015523 (RD 3 = 64.420 mm)
- | €V 4=.002462 (RD 4 = 406.13 mm)

x1 reloy
FOCAL LENGTH = 106.2° NA = 0.02705

Plotting the MTF across the field

® From the Evaluate menu header select Transfer Function > MTF vs field

® Enter three frequencies in units of cycles per

mm: 1.0, 2.0, and 3.0. e )
This plots the modulation transfer function at all ol Py
points in the field for the three spatial frequencies. | _ /S ) h
In the example shown here, the upper (green) = P>
curve, which shhows the MTF at 1 cycle per mm, omf

still falls well below the desired 0.4 level over
part of the field of view.

—— L .
.00 0.25 050 075 .00
Froctional Object Height

Frequencies (cycles/mm): 1.00 T+ ox @
200 7aSv  3.00 Te So o

x1 relay P
Gouss Img Hgt: -332.763 nm | (4'ss oy

Editing the slider-wheel callback command

In order to use the slider-wheels to optimize the MTF across the whole field, it will be
necessary first to make a small modification to one of the CCL commands in the
/private/ccl directory. Some users may prefer to skip this exercise and return to it once the
next chapter on programming has been covered.

® Open the text editor either by clicking on the icon, from the menu header
Window > Editor > Open or typing the command ewo .

® In the Text editor window, [F = T - [5]x]|
click on File > Open.
P Open Text File 2IX
® At the bottom of the Lok [S . of E-
window which opens, e e
after Library gl
Directories: click on flmy_s
N optim_ic_EDU.ccl
Private.
< >
° Ofthe ﬁles Wh]Ch haVe a File pame: ‘my_swca\lhack cal
green icon (*.CC] ﬁles) Fiesoftype:  [CCLfles ("l conh) | Cancel
Hel
select _ #
my_swca"back_ccl and Library Directories. Frivate Public:
click on Open.

Slider-wheel design with ray intercept curves
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This file contains a single command

cmd Sw_callback(int cblevel,

int item, int srf)

® (o to line 36 of the file (Ctrl-G or Edit > Goto Line, and enter 36).

® After the last break; and
before the line default:
add the lines:

case 14:

uda; // User guide
break;

When typing this entry you
must take care that the first
line ends with a colon (2),
and the second and the third
with a semicolon (;). On the
second line anything
following the // is treated as
a comment.

® In the text editor window

F#4 Text Editor - my_swecallback.ccl E@B‘

Fle Edit
sprintf(strl, "ocml8%+f\n", -cc[01); ~
o 4 strl;
ite 2;
break;

case SW_EBRSLIDER:
stp outp off;

ebr ccl[0];

stp outp on;
break;

case 14:

uda; //User guide
break;

default:
if (chlevel > 0 && chlevel < SW_MAXITERS)

ite chlevel;
uda;

}

else
{

heep;
msg("Callback not implemented.");

< bd

(not the main window)
click on File > Save. Compilation should be automatic, and the message in the text
window should be:

*CCL COMPILATION MESSAGES: No errors detected

To explain, if the slider-wheel callback CCL is enabled by the user, then the command
Sw_callback is called whenever a slider-wheel is moved. When this happens, the value of
the integer argument called Level is passed to the CCL command, where it appears as the
integer cblevel. This determines which action to be taken by the callback command.

If the sw_callback CCL function is invoked with a value of Level between 1 and 9, that
number of cycles of optimization (iterations) is performed. If Level is 11, then the slider-
wheel controls field angle, and if Level is 13 it controls entrance beam radius. The option
Level = 13 is used in one of the tutorials.

As a result of the change, if the sw_callback CCL function is invoked with a value of
Level equal to 14, then a single command uda will be executed. This command
(update_all in long form) has the effect of updating the graphics in all open updateable
windows (i.e. those marked UW).

All this occurs within the switch statement, with different outcomes according to the value
of cblevel, the switch parameter.

The listing of the modified CCL command is given below.

Slider-wheel design with ray intercept curves
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Listing of the modified slider-wheel callback CCL

/
* This file contains some simple callbacks that are used in the documentation examples *
* with slider-wheel windows. It is meant to be extended by users as needs arise. The *
* callback uses the *“cblevel™ parameter to designate a particular action. The user then *
* enters the appropriate number in the Slider-wheel Setup window in the cell marked *
* "Level”. The value of "Level™ is passed to this command as '‘cblevel™ and determines *
* the task to be performed. *
/ /
#define SW_MAXITERS 10
#define SW_ANGSLIDER 11
#define SW_DIFFRACTDBLT 12
#define SW_EBRSLIDER 13
cmd Sw_callback(int cblevel, int item, int srf)
{
switch (cblevel)
{
case SW_ANGSLIDER:
stp outp off;
ang cc[0];
stp outp on;
break;
case SW_DIFFRACTDBLT:
sprintf(strl,”ocm18%+f\n",-cc[0]);
0 4 strl;
ite 2;
break;
case SW_EBRSLIDER:
stp outp off;
ebr cc[0];
stp outp on;
break;
case 14:
uda;//User guide
break;
default:
if (cblevel > 0 && cblevel < SW_MAXITERS)
ite cblevel;
uda;
}
else
{
beep;
msg(*'Callback not implemented.™);
}
}
3.

Slider-wheel design with ray intercept curves
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Slider-wheel design using MTF at one frequency

® Plot the MTF curves at the spatial frequencies of 1, 2, and 3 cycles/mm as before.

® Open the slider-wheel spreadsheet. ﬂ;;
® Set up the slider-wheels as before, but this time click on Enable
sw_callback CCL function.
® Enter Level as 14.
® Enter the Setup name x1_relay and click on the Save setup button.
EE slider-wheel Setup E“E”g|
of
x| =l
? Saved slider-wheel setup: x1relay.osw.
< No Internal evaluation
< Draw only @& Ray-intercept & OPD & Field sag ¢ Spot diagram & Long. SA
Graphics scale: 0.000000] = 1 Field point at & All points
Number of sliders: ® Use drag processing
surf Cfg Item value
[Curvature (CV) | 0.018822
[Curvature (CV) | 0.030683
[Curvature (CV) | 0.015523
[Curvature (V) | 0.002462
& Enable sw_callback CCL function Level 14
Ssetup name: x1relay.osw Save setup

This slider-wheel setup (the slider wheel definitions and the other data) is now saved in a
file x1_relay.osw, which is stored in the directory .../private/bin/osw/

® (lose the slider-wheel setup spreadsheet.

® On each slider-wheel change the step size to 1e-05 as before (these values are not stored
in the slider-wheel data).

® Adjust the curvatures to maximize the MTF at 1 cycle/mm over the whole field.

One possible solution, illustrated here, is:

CV 1 = 0.01778 (RD 1= 56.237 mm) S
CV 2 =0.03090 (RD 2 = 32.359 mm) -
CV 3 =.01585 (RD 3 = 63.079 mm)
CV 4 =.002312 (RD 4 = 432.48 mm)

The smallest MTF value for this design is 0.42. e DF(IQO;:( H:M .

osio
16 Mar 07
06:21 P

This completes the design ask. o L R e " ™ | s mg et .28

This example illustrates in microcosm how even a problem with clearly defined objectives
and only 4 variables can have a large number of solutions, all meeting the requirements but
differing in subtle ways.

Slider-wheel design using MTF at one frequency
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Setting clear apertures

The apertures at present are based on paraxial ray “solves.” To complete the design, the
clear aperture values must be set in accord with real ray, not paraxial ray, requirements.

x1 relay

FOCAL LENGTH = 105 NA = 0.02725

UNITS: MM
DES: OSLO

22.7

® From the Optimize menu header select Support routines > Vignetting > Set

apertures.

® Ieaving all the choices as defaults, click on OK.

*APERTURES
SRF  TYPE APERTURE RADIUS
0 SPC  300.000000
1 SPC 44200000
2 SPC 32.000000
3 SPC 15.800000
4 SPC 8.360000
5 SPC 7.950000 CHK
6 SPC 8.360000
7 SPC 15.800000
8 SPC 32.000000
9 SPC 44 .300000
10 CMP  300.550935

® [fthe slider-wheel spreadsheet is re-opened after the
lens is saved, the previous setup will have been
deleted from it. It can be retrieved by clicking in the
Setup name window and right-clicking on
x1_relay.osw from the list presented.

® Finally, enter the command pld mon to confirm
that the level of distortion in the design is indeed

very low.

Option
@ Setallaperures ( Setsolved apertures only

-1.000000  Targetvalue for lower aperture vignetiing
1.000000 Target value for upper aperture vigneting

3 Number of digits to round to
Reportray error
® Yes ( No
| fal'd Tad | ‘ Hel ‘

1lrela [ FT TunTTs: MW
FOCAL LE%TH =_105 M = 002725 ‘ DES._OSLO

x1 relay
PER CENT DISTORTION - W1

—le-08 1e-08

Slider-wheel design using MTF at one frequency
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Introduction

This chapter will include the basics of how to create a new command producing textual
output, and how to include that command as one of the options in the text window header
menu. Next there will be how to create a new graphics command, and how to create an icon
for this in one of the graphics window headers. Finally there will be a brief review of the
SCP and CMD languages.

To illustrate these, it is helpful to have a standard lens in storage. ol |

e Click on the icon for Open an existing lens. If the warning message E
appears ... Save changes to current lens file? Click on No.

e At the bottom of the window which opens, after Library Directories: click on
Public.

e Seclect demo > edu and then click on demotrip.len.

e Click on Open.
Defining a new command: sno

In the surface data spreadsheet, the button labeled Notes gives access to the first 5 lines of
the user-defined commentary which is stored with each lens. This consists of up to 10 lines,
but the 6th is reserved for some optimization parameters, and the 10th for the public
database lens class.

The standard OSLO command for listing the system notes is Opc sno. There is no
facility for calling this from the text window toolbar. This section shows how a new
command, SNO, which lists the system notes, can be written. Then the procedure for adding
a label Sno to the text window (Standard Tools) toolbar will be given, so that the system
notes (up to 10 lines of documentation stored with each lens) can be listed with a single
click.

e First, try out the command from the keyboard. Type the command opc sSnho

*CONDITIONS: SYSTEM NOTES

: This Cooke triplet is used throughout the OSLO documentation as an example.

: It is a minor variation on a lens designed by hand by R. Kingslake (see "Lens

: Design Fundamentals™, pp286-295, Academic Press 1978, ISBN 0-12-408650-1), who
: used nothing more than a hand calculator! The Cooke triplet was invented by

: Dennis Taylor in 1893, and is still very widely used as a low-cost objective.

0: COOKE TRIPLET

1
2
3
4
5
1
CCL commands are stored in ASCII, and may be created either using the OSLO standard
text editor, or using UltraEdit-32® from IDM Computer Solution Inc, or (the least

convenient) with Microsoft’s Notepad®. Only the use of the first will be described in this
chapter.

To create the new command:

e Ifthe icon for Open the standard text editor appears on the main
window taskbar, click on it. Otherwise from the Window menu header
select Editor > Open. Alternatively type the command ewo in the

71
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command line,

o In the editor window, select File > New and type:
cmd sno(void)

{

operating_conds(sno);

}
Note that there is no punctuation Te“‘"‘" eval zno.ccl
after (VO i d), and there iS a cmd sno(void)

semicolon ( ;) after the single
J
line command.

e Highlight the last three lines with the cursor and press Ctrl-E to check that the
program has been entered correctly.

e There are only two menu options in the editor window header. Choose File > Save
as... , click on the gray button labeled Private at the bottom, and choose File
type: CCL files (*.ccl,*.ccx,*.h).

e Enter File name eval _sno and click on Save.

e Compilation takes place automatically:

*CCL COMPILATION MESSAGES:
No errors detected

should be the message which appears in the text window.
e Enter the new command in the command line: SNoO
o In the text editor window, add the documentation as
//
// Written by [your name] [date]
//

cmd sno(void)

// hlp: <P>SNO</P>
// hlp: <P> Prints the system notes.</P>

{

operating_conds(sno);
}

e In the editor window header, (not the main window) click on File > Save. The
compilation message will appear again:
*CCL COMPILATION MESSAGES:
No errors detected
Each command definition in the private/ccl directory must be unique, so do not attempt to

save the command sno again in a *.ccl file of another name. The error message will be:
*CCL COMPILATION MESSAGES:
eval_sno2.ccl 2: Duplicate procedure definition

and this error will persist until the duplicate procedure definition is removed.

Defining a new command: sno
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Structure of a CCL command

CCL commands can be created by the user to automate sequences of actions, and to carry
out calculations and plots specific to a user’s requirements. They are stored as ASCII text in
the directory .../private/ccl (not a sub-directory) and must be compiled before use.

The simplest CCL command can have the structure:
cmd command_namel()
{
OSLO_commandl;
OSLO_command2;
...etc...

}
This is stored in a file demo_anyfilename.ccl. (Prefixes of user-written command files
should ideally be restricted to demo_, eval_, graph_ and optim_). It is compiled using
the icon (or, in the case of OSLO EDU where the icon is not displayed) the menu sequence
Tools > Compile CCL >Private, or the command ccl.

It is executed using the call:

command_name
For example, the CCL file containing the program;

cmd hallo(void)

{
printf(““Hallo world\n™);
}

may be stored as my_first.ccl, compiled, and then called using the command:

hallo
This is described in detail in Help > OSLO Help > Contents > Programming > CCL
Programming > Using CCL.

With formal parameters, or arguments, the structure of a CCL command might become:

real argument_namel;
int argument_name2;

cmd command_name(real argument_namel, int argument_name2)

{

OSLO_commandl(argument_namel,argument_name2);
OSLO_command2(argument_namel,argument _name2);

}

This is compiled and then executed using (for example) either free format:
command_name 1.0 1

or the more formal version, often used within CCL code:
command_name(1.0,1);

In this case the two global variables argument_namel and argument_name2 might be
used by another CCL command.

Structure of a CCL command
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Local variables may also be declared. Take, for example, the CCL command:

real argument_namel;
int argument_name2;

cmd command_name(real argument_namel, int argument_name2)

real local variablel;
int local variable2;

local_variablel=3.0;
local variable2=4;

print(argument_namel,argument_name2, local_variablel, loca
1 variable2);

}

If this is called using the command
command_name 1.0 2

the output is:
1.000000 2  3.000000 4

Search CCL library: scanccl

Assume that eval_sno.ccl has been added to the private\ccl directory, as described
above.

e From the menu header select Tools > Search CCL library ...

e Under Directory to browse sclect the option Private

e Seclect the default option Sort functions by filename and click on OK.
xx 8 functions are defined in the private directory:**
** C:\Program Files\OSLO\EDU64\private/ccl/

TYPE FCTN NAME  ARGUMENTS LINE DEFINITION FILE
cmd sno 5 eval_sno.ccl
cmd sw_cal lback 15 my_swcallback.ccl
int chlevel
int item
int srf
cmd tlex_1 18 dbtutorial.ccl

real tl__radiusl
real tl__radius2
real tl__refractive_index

The new command sno appears as the first entry in the list of function names; also given
are the number of lines in the command, and the name of the file in which it was defined.

Defining a new command: ctn

The next new CCL command is an extension of one which appeared in chapter 3.
Initial version of command

command ewo in the command line, or click on the main window toolbar

® From the Window menu header select: Editor > Open, or type the g
icon.

Search CCL library: scanccl
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® Type in the following line:

for(i=0;i<=ims;i++)aprt cv[i] th[i] rn[i][1];

==1ES

B=)E3

® Split it into two lines and surround 3 Toxt Ed Untitled
with curly brackets. e itor - [Untitled text]
File Edit
® Highlight the whole window (Ctrl-A)
N For(i=0; 1<=1ms;i++)
and execute (Ctrl-E). . . aprt oviil thid] ralil[Ll:
The following appears in the active }
text window:
- 1.0000e+20 1.000000
0.047059  2.000000  1.620410 ; ]
-0.006303 6.000000 1.000000 EX Text Editor - eval_ctn.ccl
-0.049383  1.000000  1.616592 Fle  Edit
0.051813  6.000000  1.000000 “end ctnO
0.007080  2.000000  1.620410
-0.057854 42 .950000 1.000000 for(1=0;1<=1ms;1++)
- - 1.000000 ?prt cv[1] th[1] rn[1]1[1];
® Add a line at the beginning:
cmd ctn()
® In the Text Editor window click on File > Save as...(F12).
® Ensure first that the bottom window reads Save as type: CCL files.
® (lick on Library Directories Private.
® For File name type eval_ctn
® C(Click on Save.
® [ ook in the text window. There should be a message

*CCL COMPILATION MESSAGES:
No errors detected

If the message appears:
*CCL_COMPILATION MESSAGES:

eval_ctn.ccl 2: Duplicate procedure definition
then there is already a file with extension .ccl in the private/ccl directory containing the line
cmd ctn()Locate it and delete it, or change its extension to .ccx. It may be impossible
to do this if file extensions are hidden. If so, it is necessary to change the Windows file
viewing settings. Under My Computer > Tools > Folder options > View tab > Advanced
Settings > Hide extensions for known file types: Uncheck.

If there is another compilation error, check the listing carefully, especially the one
semicolon and the three different types of bracket:

cmd ctn(Q)
{

for(i=0;i<=ims;i++)
aprt cv[i] th[i] rn[i][1];
}

Extra lines and spaces are not a problem.

°
as before.

Version with formatted output

® (Change the aprt print statement to:

Once compilation is successful, in the command line enter ctn. The output should be

Defining a new command: ctn
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aprintf('%3i %12.8F %9.4g %.6F\n",i,cv[i],.th[i],rn[i]1[1D);
Here, each format specification begins with a % sign:

The format specifier %3i requires that the integer i is to be printed with a field width of 3,
right justified within this width.

The format %12.8f gives a minimum field width for cv[i] of 12 characters, with 8 digits
printed after the decimal point.

The format %9.4¢g prints th[i] in decimal notation with 4 significant figures, but in
exponential form if it is 10000 or more, or less than 0.00001.

The format %.6f requires n[i] to be printed with 6 digits after the decimal point, and no
minimum field width.

® Save and execute, giving:

0 0.00000000 le+20 1.000000
1 0.04705882 2 1.620410
2 -0.00630318 6 1.000000
3 -0.04938272 1 1.616592
4  0.05181347 6 1.000000
5 0.00707965 2 1.620410
6 -0.05785363 42.95 1.000000

Adding the glass name string

Glass name strings are not directly accessible. However, the command
get_glass_name (i) copies the name of the glass for the ith surface into a read-only
string glass_name (See under Help > OSLO Help > Contents > Programming >
Accessing Data > Other Data > Data Functions).

® Add an extra pair of curly brackets after the For statement, and insert:

get _glass name(i);

® (Change the print statement to (on a single line):

aprintf('%3i1 %12.8F %9.4g %.8s %.6F\n"
,i,cv[i],th[i],glass_name,rn[i][1]):

The format %.8s requires the glass_name string to be printed with a maximum of 8

characters.

® List the complete command:

cmd ctn()
{
print("" SRF cv TH GLASS RN™);
for(i=0;i<=ims;i++)
{

get_glass_name(i);
aprintf("%3i1 %12.8F %9.4g %.8s %.6F\n",i,cv[i],th[i]l,glass_name,rn[i][1]1);

}

Adding headers and documentation

The following conventions have been established by previous writers of OSLO macros, and
they are worth observing:

Defining a new command: ctn
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1. Each CCL file opens with a set of three or more comment lines giving the author,
date, and any update information. e.g.

//

// Written by [Your initials] [Date]

//

2. All documentation for a CCL command is given in HTML format between the

header and the body, commented out and preceded by hlp. For example:

// hlp: <P>Lists curvature, thickness, glass type and refractive index.</P>
3. No default system variables are ever used, so that, for example, the command
sequence
i=92;ctn;prt i
must always give the same result. So declare all variables as local variables within the
command: e.g.
int 1;
Of course these can have any name chosen arbitrarily, but by keeping to the default variable

names, the Ctrl-E execution of selections of code within the text editor window can still
proceed, provided the declaration int 1 ; itselfis not highlighted.

4. Commands which give just printed output are echoed, preceded by a star, in upper
case. e.g.
print(**CTN");

Making these changes, the final version of the command becomes:

E¥8 Text Editor - eval_ctn.ccl
File Edit

22 written by [your initials] [date]

cmd ctn()

// hlp: <P= Lists curvatures thickness glass and refractive index</p>

int 1i;
primc("*CTN");

print(" sRF cv TH GLASS RN");
for(i=0;i<ims; i++)

get_glass_name(i);
?printf(“%si %12.8f %9.49g %. 85 %.6F\n",i,cv[i],th[i], glass_name,rn[i][1]);

The output from a call of the command ctn is:

*CTN

SRF cv TH GLASS RN
0  0.00000000 le+20 AIR 1.000000
1 0.04705882 2 SK16 1.620410
2 -0.00630318 6 AIR 1.000000
3 -0.04938272 1 F4 1.616592
4 0.05181347 6 AIR 1.000000
5 0.00707965 2 SK16 1.620410
6 -0.05785363 42.95 AIR 1.000000
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The text window toolbar

Commands which generate only printed output are by convention placed in the text window

toolbar. The format for a text window toolbar is:
menu toolbar_number

“Label,tooltip_label” = “command”,
“Label2,tooltip_label2” = “command2”,

}
where the first Label (by convention having only 3 or 4 letters) is what appears on the

toolbar, the second, tooltip_label, is more detailed, and only appears in a cream-
colored box when the cursor hovers over the first label. The command may be either CCL
or OSLO command(s). The toolbar_number is toolbar50 for the Standard Tools
text window toolbar.

Adding the command sno to the toolbar

® Still in the Text Editor window, select File > Open and look in the Private CCL
directory. Open the file a_menu.ccl.

® (Ifthere is no file private/ccl/a_menu.ccl, open the file /public/ccl/a_menu.ccl,
and save it as private/ccl/a_menu.ccl)

® Go to line 1339 of this file (Ctrl-G and enter 1339 in the dialog box). This should give
the entries for:

menu toolbar50

® After the line:
“Len,Lens data” = “prt_len”,

add the line (note the comma before the comment):

“Sno,System note” = *“sno”,//[your initials][date]

® Compile again by saving the file:

*CCL COMPILATION MESSAGES:
No errors detected

B8 Text Editor - a_menu.ccl

File Edit
S/ Tewt window toolbars L

FEEEEEFEEEE IR frirds

menu toolbars0 // Standard textout toolbar
{

"Len, Lens data”
5no, System note

5pe, 5pecial data = ‘spe
"Rin, Refractive index data” = "rin
"Ape, Aperture data” = "ape

The text window toolbar
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Calling sno from the toolbar

® C(Click on Sno in the text window toolbar. If it is not visible, ensure that the Standard

Tools menu has been selected.

Once again the output is:

*CONDITIONS: SYSTEM NOTES

1: This Cooke triplet is used
throughout the OSLO documentation as
an example.

2
3
4
5
1

0: COOKE TRIPLET

B Len Sno Spe Rin Ape Wav Pxc fbr Mrg Chf Tra Sop
Pxs Pt Chr Sei Fif Zpes Zspa Zsen Zchr Zsei Zif Ref bo
Sps Wi M Psf S Cmp Grp

Mat Lay Stk St ¥mt Gho
FCONDITIONS: SYSTEM NOTES

: It is a minor variation on a lens designed by hand by R. Kingslake (see "Lens
: Design Fundamentals', pp286-295, Academic Press 1978,

ISBN 0-12-408650-1), who

used nothing more than a hand calculator! The Cooke triplet was invented by
Dennis Taylor in 1893, and is still very widely used as a low-cost objective.

Defining a new command: xmt

In this exercise a command xmt will be created which plots a graph showing the
transmission fall-off across the field arising from vignetting. (The effect of coatings and of

the internal transmission of optical
materials, available in OSLO
Premium, is not included in this
analysis).

The command will be modified to
prevent errors occurring when no rays
are transmitted, or when the chief ray
fails. This will demonstrate the use of
an error handler.

Then a new icon will be created, and
placed in the Spot Diagram menu of
the graphics window toolbar to enable
the new command to be called with a
single click.

Writing a command xmt
to print transmittance
values

o Bk
-Q‘/,’ Command: A‘
x| I=|
P ald = 43.3246073298429

Fw e EEn
B8 Len Sno Sps Rin Aps Wav Pxc Abr Mg Cif Trs Sop Ref Fan Spd Af Stv Pkp Ape Pxs Pt Chr

1. 000000 1.000000 1.000000 A
NUMBER OF RAYS TRACED:
Wyl w2 wv3
1528 1528 1528
PER CENT WEIGHTED RAY TRANSMISSION: 100. 00000
“SPOT_SIZES
GEQ RMS Y GEO RMS X GEO RMS R DIFFR L CENTY CENTX
0.004577 0.004577 0.008472 0.00286! - -
*WAVEFRONT RS
WAVELENGTH 1
PKVAL OPD RM5 OPD STREHL RATIO RSY RSX RSZ
0.593598 0.118018 0.583906 - - -
=SET_OBJECT POINT
FBY FBX FBZ
1.000000 - -
FYRF FXRF FY FX
YC XC YFS XFS5 0oPL REF 5PH RAD
18.264293 - -0.911383 -0.096417 65.421390 61.550663

SPOT DIAGRAM - FEY 1.00, FBX 0.00, FBZ 0.00 -
APDIV 44. 000000
WAV WEIGHTS:

POLYCHROMATIC 1

Wi, Ww'2 Ww3
1. 000000 1.000000 1.000000 |
NUMBER OF RAYS TRACED:
Wv1 i Wwv3

662 658 666
PER CENT WEIGHTED RAY TRANSMISSION: 43.324% 3

Open the lens file /public/demo/EDU/ demotrip.len

In the Text Editor window, open a new file and type the following in a single line:

sbr;sop 0 0 O;spd 44;sop 1 O O;spd 44

® Highlight with the cursor, press Ctrl-E and click on the two values of PERCENT
WEIGHTED RAY TRANSMISSION (100.00 and 43.324607) which appear in the text
window. Note the coordinates of the two spreadsheet cells (a6, a14).

® In the text editor, add a second line containing a print command.

prt a6,al4;

® Highlight both lines and press Ctrl-E to confirm the correct values have been printed.
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® The transmission curve is to be plotted at 50 points over a range of value of FBY from
0.0 to 1.0. Introducing the pre-defined integer i as a variable to count through these
points, and we can generate all the results using a for loop:

sbr;
for(i=0;i<51;i++)
{
sop 1*.02 0 O;
spd 44;
s

To extract the relevant values from the spreadsheet, and print them as a neat table, we
must switch off printed output with stp(outp, off) and extract the transmission
values from the spreadsheet. The spreadsheet cell number of the transmission value of
the (i+1)th field point is a(6+8i) or, as a CCL formula, ssb(6+8*1,1) . Introducing
the double precision predefined variables x (the value of FBY) and y (the %
transmission), we can use these in a print statement to create the necessary table: prt
X,¥Y; This statement will produce visible output despite the fact that the preference
stp(outp,off); has been called, provided prt and notaprt isused for
printing.
Predefined variables are used at this stage because the Ctrl-E compilation method is
incompatible with either local or global variables.

® So change the program to:

stp(outp,off);

sbr;
Ffor(i=0;i<51;i++)
{

Xx=1*0.02;
sop(x,0,0);
spd(44);
y=ssb(6+8*i,1);
prex,y);

}

stp(outp,on);

® Highlight it all and execute with Ctrl-E to generate the entire list of 51 values giving

the percentage transmission across the field:
- 100.000000

0.020000 100.000000

0.040000 100.000000

..etc

0.960000  47.120419

0.980000  45.811518

1.000000  43.324607

Converting xmt printed output to graphics

The text window spreadsheet is used as the vehicle = AER

for transferring the printed data into plot commands. \CELEELL

® At the beginning, add the command gwr ; /
(graphic window reset) to clear the window and
define the dimensions of the plot area to be in the
range x=0 ... 1,y=0 ... I.

® Also before the first calculation, add the plot
command, moveto(0, 1) - most lenses will x=0,y=0

have 100% transmission on axis. /
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Add pen(3) to plot in dark blue.

Delete the print statement.

® [Insert the main plot command, 1 ineto(x,y/100) ; where the /100 scales the y-
values to keep them within the range 0 ... 1.

® At the end, add gshow; to ensure that the plot output is drawn immediately and not

held in a buffer. It may still be necessary to click on the window to have the graph
drawn in full.

stp(outp,off); oW1

sbr; CETEEL- T
gwr; TT——
moveto(0,1); T

pen(3);
for(i=0;i<51;i++) T

{

Xx=1*0.02;
sop(x,0,0);
spd(44);
y=ssh(6+8*i,1);
lineto(x,y/100);

stp(outp,on);
gshow;

Preserving the text window contents

® In the second line, replace the Sbr command by the two lines:

k=sbrow;
sbr(k,1);

® On the third last line, insert the line:

sbr(-k,0);
Here k, a predefined integer variable, has been used to keep the value of sbrow, the index
of the first unwritten row of the spreadsheet.

Scaling and drawing the axes

® After the gwr command, add the following commands to re-scale the window as
illustrated in the diagram, and to draw the axes around the graph: .

window(-0.2,1.2,-35,110);
moveto(0,0);
lineto(1,0); (-0.2, 110)
lineto(1,100); ——
lineto(0,100); '
lineto(0,0);

® Also change the lineto
command to
lineto(X,y) tocover
the new range of y from 0
to 100.

® Finally surround the whole
procedure with curly brackets, add the line cmd xmt() at the top, and save in file
private/ccl/graph_xmt.ccl.

(1.2, 110)

(0.0, 100.0)

(0.0, 0.0)

(-0.2, -35) (1.2, -35)
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® Note that up to this point only predefined variables have been used (integers i , Kk
double precision real X, Y). Thus it is possible to highlight and execute part of, or the

whole command (excluding the cmd xmt() header itself) using Ctrl-E. This is helpful

for locating errors.

The listing of the command is as follows:
cmd xmt()

{
stp(outp,off);
k=sbrow;
sbr(k,1);

gwr;

window(-0.2,1.2,-35,110);
moveto(0,0);

lineto(1,0);
lineto(1,100);
lineto(0,100);
lineto(0,0);

moveto(0,100);

pen(3);
Tfor(i=0;i<51;i++)

x=1*0.02;
sop(x,0,0);
spd(44);
y=ssb(6+8*i,1);
lineto(X,y);

hs
sbr(-k,0);
stp(outp,on);
gshow;
}

Adding standard plot commands to xmt

® Add the pre-processor command at the top of the file:
#include "../.._./public/ccl/inc/gendefs.h"

® This makes it possible to call the two commonly used graphics commands:
SAVE_DISPLAY_PREFS;

and
RESTORE_DISPLAY_PREFS;

® Following the convention already established, the captions will drawn using the

command sequence:
if (char_pref(glab)) draw_title_block(strl,str2,str3);

where the code for draw_title_block(strl,str2,str3); can be found in the CCL file
public/CCL/graph_tools.ccl
Error handling

e Open the surface data spreadsheet and change the field angle to 30 degrees.
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e (all the xmt procedure. The command will fail when the
transmission falls to zero with an error message as
ShOWn. A Error in gpot_diagram:
. . o No rays in spot diagram.

The remedy is to add an error handling procedure to reset the s ]

error flag to zero. This will be called from xmt whenever an error

occurs. If a procedure invokes a second procedure, then either

the second must precede the first, or it needs to be declared:

® Add the line at the top, the prototype declaration (note that this one is followed by a

semicolon):
cmd xmt_error_handler();

® Declare an integer global variable xmt_err to carry the error status between the
prcedures.
® Add the error handler command xmt_error_handler at the end.

® The error handler can now be called. Before the window command, add the line:
install_error_handler("'xmt_error_handler™); and at the end add the
command to restore the original (default) error handler:
install_error_handler('prefs™);

By adding the error handling precautions to the plotting routine, it is possible to prevent the

execution of the spot diagram command if the chief ray has not been traced successfully

and to continue execution of the command with the transmission value set to zero if no rays

have been transmitted in the spot diagram. .

Listing of complete command xmt

® (Convert the predefined variables to locally defined variables, i becomes iplt, X
becomes xplt, y becomes yplt, and k becomes ssb_row_sav.

® Add comments, documentation, ticks and captions etc as shown below.

® Save and compile. The whole procedure now looks like this:

//
// Written by [your name] [date]
//

#include "../../public/ccl/inc/gendefs.h™
int xmt_err;//global variable

cmd xmt(void);
cmd xmt_error_handler(void);

cmd xmt(void)

// hlp: <P>XMT</P>

// hlp: <P>Plots the fall in transmission as a function of field

// hlp: arising from central obstructions and vignetting. It does not
// hlp: include the effects of coatings or Fresnel reflections.</P>
// hlp: <P>This CCL command also illustrates how a custom error

// hlp: handler prevents reference ray failures terminating execution
// hlp: of a CCL command; by setting errno=0 within the error handler
// hlp: it permits continued execution of the CCL command even after
// hlp: what would otherwise be a fatal error. </P>
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{

static int ssb_row_sav,iplt;

static real xplt,yplt;

static char stri1[80],str2[80],str3[80];

SAVE_DISPLAY_PREFS;//as defined in gendefs.h
set_preference(output_text, off);//switches off text output
ssb_row_sav = sbrow;//saves row after last row written to in SSB
ssbuf_reset(ssb_row_sav, 1);//initialises spreadsheet buffer
graphwin_reset;//clears graphics window

install_error_handler("xmt_error_handler');// see below
window(-0.2, 1.2, -35, 110);//xmin xmax ymin ymax
moveto(0, 0);// draw x-axis (range 0...1)
lineto(l, 0);
for (iplt = 1; iplt <11; iplt++)
{moveto(iplt*0.1, 0);//draw x-axis ticks
linerel (0, -2);}
moverel (-0.2,-10);
label ("'Rel .Obj .Ht."™);//1abel x-axis
moveto(0, 0);// draw y-axis (range 0...100)
lineto(0, 100);
for (iplt = 1; iplt <11; iplt++)
{
moveto(O, iplt*10);//draw y-axis ticks
linerel(-0.02,0.0);

3
moverel(-0.1,0);
label (""%s",""100%"") ; //label y-axis
moveto(0,100);// plot transmission curve
pen(2);//green
for (iplt = 0; iplt <51; iplt++)

{

xplt=iplt*0.02;// xplt=Relative object height (FBY)
yplt=0;

xmt_err=0;

set_object_point(xplt,0.0,0.0);

it (xmt_err==0)// i.e. If sop succeeded ...

spot_diagram(44);

if(xmt_err==0)// .. and spd succeeded ...

yplt=ssb(6+8*iplt,1);//..set yplt ...

Y// ... else yplt remains zero.
lineto(xplt,yplt);

message(*'"");// clears message area

install_error_handler("prefs'™);// default - see asyst ccl.ccl

ssbuf_reset(-ssb_row_sav, 0);//restores ss buffer row numbering
set_preference(output_text, on);//switches text output back on

pen(1);// black
if (char_pref(glab))// only if preference graphics_labels ON ...

{

sprintf(strl,"Field angle %.4f",180*ang/pi);
sprintf(str2,"Object height %.6g",obh);

sprintf(str3, "TRANSMITTANCE VS FIELD™);
draw_title_block(strl,str2,str3);//see public/graph_tools.ccl

gshow;//clears graphics buffer, forces display of graphics
RESTORE_DISPLAY_PREFS;

}

cmd xmt_error_handler(void)

{
Xmt_err=errno;
errno = 0;//clears error to permit CCL execution to continue

}
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The graphics window toolbar

Commands which generate graphical output are generally called from icons on one of the

graphics window toolbars. The format for a graphics window toolbar is:
menu toolbar_number

“bitmap_Ffile, tooltip_label” = “gwt \”window_title\”; gwe \”command\”;”,

where bitmap_file_bmp is the name of a bitmap file containing the icon, and stored in

the folder /Prm64/bin/bma. Once again, tooltip_label appears in a cream-colored
box when the cursor hovers over the icon. The window_title (up to 48 characters) will
appear in the blue title bar of the updatable graphics window.

Creating a new icon for xmt

® Using the computer file listing facility, locate the redundant blank icon blank1.bmp,
which is the first file in the directory /[Prm64]/bin/bma This is a file 16 x 15 pixels
(all gray) with a palette of 16 colors, plotted at a resolution of 96 pixels per inch.

® Copy it to the same directory, and rename it an_xmt.bmp

® [ftime permits, modify the image pixel by pixel as shown, using a program such as
Microsoft Paint®, and store it with the same name.

blank1.bmp an_xmt.bmp

Adding the xmt icon to the graphics window toolbar
In a_menu.ccl, the toolbar number is 34 for the Spot Diagram Analysis graphics window.

® Open the Text Editor window, select File > Open and look in the Private CCL
directory. Open the file a_menu.ccl.

® Locate toolbar 34. Go to line 1241 of this file (Ctrl-G and enter 1241 in the dialog
box). On this line (or one nearby) should be the entries for the toolbar menu:

menu toolbar34 // Spot Diagram Analysis

menu toolbar34 // Spot Diagram Analysis

=pd, Plot report graphics spot diagram analysis"” = "gwe “rpt_spd:rpt_spdy";"

#1fndef OSLO LIGHT_

"plt_spd2d, Spot Diagram ws. A1l field points™
#endif

"plt_spd, Plot Spot Diagram”

"plt_spd_rcp, Plot Recipolar Spot Diagram™

"plt_spd_f1d, Plot RMS Spot 5ize/OPD vs. Field”

an_xmt, Plot transmittance vs. Field

separate2,

"an_footprint, Plot Beam Footprint”

After the line:

"plt_spd_fld,Plot RMS Spot Size/OPD vs. Field"” = "gwt \"RMS Spot Size vs.
Field\";gwe \"spsopd:spsopd\"**

"gwt % "Spot Diagram vs. field points\";gwe “"spd2D 0.0 0.0:spd2DY"

"gwt \"SDDt Diagram Analys'is\"-g\ne \"pls cen spt 0.0 0.0:calc_spof
"gwt “"Recipolar Spot Diagram’\”;gwe % 'recipolar spt 10 r"ec'ipo'lar-\‘
"gwt %"RMS Spot Size vs. Field\";gwe \"spsopd: spsupd\

gwt % Transmittance vs. Fieldy ;gwe %\ xmt)\ ;

"gw‘t “"Beam Footprinty";gwe “"footprt 1.0 0 1 sdad 1:footprti""
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add the following, all on one line (note the comma before the comment):

"an_xmt,Plot transmittance vs. Field" = "gwt \"Transmittance
vs. Field\";gwe \"xmt\";", // [your name] [date]

® Save a_menu.ccl.

® (Check that compilation is successful:
*CCL_COMPILATION MESSAGES:
No errors detected

Calling xmt from the toolbar icon D

® Ensure that the lens IR UW 1 - Transmittance vs. Field *
. . BE% LN&AE @
in store is the - =

Plot transmittance vs. Field
standard triplet with 1007 -
30 degrees as the .
semi-field angle. -

® Open a new graphics a
window. -
® (lick on the Setup
Window/Toolbar 7
icon, and select the B
Spot Diagram menu. N

® (Click on the xmt icon
shown above.

Rel.0bj.Ht.
Field angle 30.0000 DEMO TRIPLET osLe
Object height -5.7735e+139 TRAMSMITTANCE %S FIELD 21 Mar 07

SCP programming: *triplet

SCP (“star command program”) is the old macro language of OSLO, still supported but
largely replaced by CCL. An SCP command consists of a text file whose name is the same
as the command name, and whose first line is *[cmd_name] without a semicolon. All the
other lines are commands ending with semicolons, and the file named cmd_name.scp
must be stored in the directory /private/scp. The command is not compiled, so errors are
not detected until the commands are executed.

To call an SCP command, type *[[cmd_name] into the command line.
® Open the text editor window.
® (Click on File > New

® Type the following lines:

SCP programming: *triplet
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*triplet

open len pri len trip.len n;

gwo 2 320 300 O 100;

rpt_ric ray 0.1 0 1 0.2 0.1 1 .005;

gwo 3 320 300 320 100;

rpt_tfr 100.0;

gwo 4 320 300 640 100;

rpt spd 50 0.0 3 0.2 n;

gwo 5 320 300 O 400;

rpt_psf “128” 64 chr .25 aut .12 .06;

The first line must begin with a * and have no semicolon after it. The first gwo command
opens a new graphics window, GW2, which is 320 units wide and 300 high in the top left
corner of the window, just under the command window. Three more windows are defined
in the same way.

® Except for the very first line, the entries may be tested during entry by highlighting
them with the cursor and pressing Ctrl-E.

® In the text editor window, click on File > Save as ...
® Change File type to SCP.
® Click on PRIVATE to store the command in /private/scp/

® Enter file name as triplet.scp. The file name must be the same as the command
name, and only one command is permitted per file. Note that no compilation takes
place, so there is no checking for errors before execution.

® This command opens the
triplet stored in the private
lens directory on
installation, and plots the - —— e -
ray intersection coordinates, Sssxsemss ___ lmssniemus TN T
the MTF, the spot diagram ' A E S
and the point spread
function at three field point.
Parameters for each of these
commands are chosen to
suit the lens.

Ao I R B R |

:.’,‘":I| L -

® To call this SCP command,
type:
*triplet

Test ot O Page s O Grmphocs mcticew: O Foc g

including the initial asterisk.

Some examples of SCP commands are given in the directory /public/scp.

SCP programming: *triplet
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Load command file programming
This is available only in OSLO Standard and Premium versions.

The command Icmd opens a text file and executes the OSLO commands in
sequence. Unlike CCL and SCP files, the location of the file is quite arbitrary, so
this programming language has the advantage that the files can be stored with the
lenses. Semicolons at the end of each line are optional, but including them makes it
easier to check the command file while it is being developed, using Ctrl-E in the
text editor window.

e Open the text editor and type:

//triplet [your name] [date]

open len pri len trip.len n;

gwo 2 320 300 O 100;

rpt_ric ray 0.1 0 1 0.2 0.1 1 .005;
gwo 3 320 300 320 100;

rpt_tfr 100.0;

gwo 4 320 300 640 100;

rpt spd 50 0.0 3 0.2 n;

gwo 5 320 300 O 400;

rpt_psf “128” 64 chr .25 aut .12 .06;

® In the text editor window, click on File > Save as ...

e Store it as a text file in the private/len directory with type .txt and with the
name triplet.cmd.

e To execute, type in the command line lcmd, search in the private/len
directory for the command file triplet.cmd, and click on Open to execute.

Load command file programming
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Optimizing using Seidel aberrations

According to Seidel aberration theory, a thin cemented doublet of a specified pair of glass
types (one crown, one flint) may in general be corrected exactly for only two of the three
coefficients for primary axial chromatic aberration (PAC), spherical aberration (SA3), and
coma (CMA3). Using one real and one fictitious glass, however, an exact solution can
always be found.

This exercise will show how to find, using Seidel aberrations alone, the nearest glass in the
Schott catalog to combine with Schott N-BAK4 making a cemented doublet of a focal
length 150 mm, and aperture ratio {/6.3.

Setting up the starting design

® Open a new lens surface spreadsheet.

® Select the image surface. Click on the gray SRF button, right click, and choose Insert
catalog lens.

® Seclect the EDMUND catalog, and Catalog Lens Database
look fora @ cemented doublet
focal length 150 mm diameter 25
mm. E
® [f+/-1 mm ranges are chosen there is
only one result. The Edmund catalog
number for this lens is EACH32494. "~ edwnd scientitic
The glass types used in this lens are S “iSo.000  Thickness: 7.300

Schott BK7 for the crown and Schott IX7

Lens Types: (3 Singlets (& Cem Dblts (O Others

SFS fOI' the ﬂlnt Sort By: ® EFL ) Diameter » Part
central EF1: +/- Range:
® Set the entrance beam radius to be cencral oiz: EEMUEER /- Range:

catalog: EDMUND Part Name: EACH32494

150/2/6.3 mm.
®  Set the semi field angle to 1°.
® Set wavelength weights 1.0 (0.58756pum) 0.4 (0.48613 um), 0.6 (0.65627 pm).

® Delete the extra surface, by clicking on the gray SRF button for surface AST, right
click, and choose Delete.

® We need to be able to alter surfaces 1 2 and 3. Click on the gray SRF button for surface
1 (AST), right click, and choose Ungroup.

® Set the image distance at the paraxial back focal point (under thickness for surface 3,
select Solves (S) > Axial ray height > Solve value =0.0).

® Listing the lens at this stage gives:

89
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*LENS DATA
Doublet /6.3 150 mm
SRF RADIUS THICKNESS  APERTURE RADIUS GLASS SPE NOTE
0BJ - 1.0000e+20 1.7455e+18 AIR
AST 91.370000 5.700000 12.500000 A BK7 C
2 -66.210000 2.200000 12.500000 SF5 C
3 -197.710000 146.149598 S 12.500000 AIR
IMS - - 2.618244 S

Defining the error function

® First, close all open spreadsheets (this is important).

® (alculate the angle for the marginal axial ray angle at the image for an /6.3 beam: Type
into the command window 0.5/6.3 and record the result:

Result = 0.0793650793651
® From the Optimize menu header, select Generate error function> Aberration
operands

® Then, in the operands data editor which opens, set non-zero weights for just the four
operands listed below:

OPEDRAN MODE WEIGHT  NAME DEFINITION
2 MIN 1.0 PU __ OCM2+0.07937
5 MIN 1.0 PAC  OCM5
9 MIN 1.0 SA3  OCM9
10 MIN 9.0 CMA3 OCM10

For each operand, the MODE is MIN (minimization) rather than CON (constraint) which is
equivalent to an infinite weight. (The latter is rarely of value). The WEIGHT gives the
relative importance of each operand, and here coma has (arbitrarily) been given higher
weight than the other two aberrations. The NAME is for information only, and has no effect
on the optimization process. The DEFINITION is a string ocm followed by the element
number of the optimization common matrix, Ocm[], that contains the value of the relevant
operand calculated by the optimization CCL callback procedure opcb_abs. This string
may include one arithmetical operand and one constant.

For example, operand 2, sets the non-zero target value for PU (the axial ray angle in image
space) to be equal to -0.07937. The entrance beam radius is fixed, so that, by controlling
the value of PU in the image space, the focal length of the lens will be controlled to be at or
near 150 mm since the optimization will seek to reduce the operand PU-0.07937 to zero. Of
course defining operand 21 (EFL) as OCM21-150.0, and assigning it a non-zero weight,
would have had the same effect.

Optimizing using Seidel aberrations
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EH Operands Data Editor |
o ]
w |FE [
?
OF MODE WGT NAME DEFINITION ~
0.000000 PY ocM1
1.000000 PU OCM2+0. 07337
0.000000 PYC acM3
0.000000 PUC acM4
| 1.000000 PAC QCMs
[ 4 0.000000 PLC aCME
0.000000 SAC acm7
0.000000 SLC OCME
) 1.000000 SA3 acMa
CMAZ QCM10 v

® (Close the operands data editor spreadsheet. If it needs to be opened again
press the Edit optimization operands icon.

® (Click on the icon to open the optimization conditions spreadsheet. .‘!.I'-‘-

® Note the entry for the optimization callback, Command for CCL/SCP
operands: opcb_abs

® On the bottom line, under Error function value, sclect ® Weighted sum of
squares.
Hence the formula for this error function becomes:

Min error fn = 1 * (PU + 0.07973)? + 1 * (PAC)® + 1 * (SA3)? + 9 * (CMA3)?
e Close the optimization conditions spreadsheet.

To list the starting value of the error function and its component operands:

® In the text window, click on Ope

*OPERANDS

OP MODE WGT NAME VALUE %CNTRB DEFINITION
02 M 1.000000 PU 4.4317e-06 0.00 OCM2+0.07937
05 M 1.000000 PAC -0.003508 34.19 OCM5

09 M 1.000000 SA3 -0.004828 64.76 OCM9

010 M 9.000000 CMA3 0.000205 1.05 OCM10

MIN ERROR FUNCTION:  3.5988e-05

® To print the minimization error function alone, type the command:

ope erf
MIN ERROR FUNCTION:  3.5988e-05

Description of the Aberration Operands error function

The aberration operands error function consists of a set of predefined operands, including
paraxial ray heights and angles, and Seidel and Buchdahl aberration coefficients. All the
default weights are zero, so that at least one non-zero weight must be specified before it be
used.

The menu header sequence which generates the error function calls the CCL command
opabs_template in file /public/CCL/optim_erfs.ccl. This includes a command:

Optimizing using Seidel aberrations
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opt_oprdccl(""opcb_abs™);

which sets the CCL command opcb_abs (in file /public/CCL/optim_callbaks.ccl) as
the optimization callback. This in turn contains CCL code which is called every time the
error function is evaluated. This callback command, opcb_abs, outputs the values of
Gaussian and Seidel quantities to the text window spreadsheet, and then copies selected
values into the Ocm[] matrix. The key lines of the code from the command opcb_abs are
listed here:

paraxial_trace();

Ocm[2] = ssb(1, 2); // pu

chromatic_abers();

Ocm[5] = ssb(2, 1); // pac

seidel_abers();

Ocm[9] = ssb(3, 1); // sa3

Ocm[10] = ssb(3, 2); // cma3

The relevant lines of CCL in the opabs_template command, which sets up the operands,
are:

operands(new) ;
opnbr = 0;

opnbr++;o0(opnbr, ins, "OCM1 ", 0.0, "PY"™); /* Axial ray height */
opnbr++;o0(opnbr, ins, "OCM2 ™, 0.0, "PU"™); /* Axial ray slope */
opnbr++;0(opnbr, ins, "OCM3 *, 0.0, "PYC™); /* Chief ray height */
opnbr++;o0(opnbr, ins, "OCM4 ', 0.0, "PUC"); /* Chief ray slope */
opnbr++;o0(opnbr, ins, "OCM5 ", 0.0, "PAC"™); /* Primary axial color */
opnbr++;0(opnbr, ins, "OCM6 *, 0.0, "PLC"); /* Primary lateral color */
opnbr++;o0(opnbr, ins, "OCM7 ", 0.0, "SAC"); /* Secondary axial color */
opnbr++;o0(opnbr, ins, "OCM8 ", 0.0, "SLC"); /* Secondary lateral color */
opnbr++;o0(opnbr, ins, "OCM9 ", 0.0, "SA3"); /* 3rd-order spherical */
opnbr++;0(opnbr, ins, "OCM10"™, 0.0, "CMA3"); /* 3rd-order coma*/

endQ);
Users of OSLO Standard and OSLO Premium do have the facility to define the error
function as here described. However they do have a more direct way to define the error
function, using predefined operands with self-explanatory names. This obviates the need for
a CCL callback. The procedure for this is:

® Delete any pre-existing operands using the command sequence:
ope new;end
Open the operand spreadsheet.

Add three blank lines and then fill in the entries as shown in the diagram:

&2 Operands Data Editor

y o .
7
OF MODE WGT NAME DEFINITION
1.000000 pu PU+0. 07337
1.000000 pac PAC
1.000000 sa3 sa3

® Close the operands data editor spreadsheet and click on Ope to list the operands.

Creating a model glass

Before a glass type can be made variable, it needs to be converted to a “model” glass.
Open the lens data spreadsheet. Change the glass at surface 1 from BK7 to N-BAK4

Optimizing using Seidel aberrations
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Under GLASS for the second surface, click on the gray button next to SF5 and select
Model... (M).

Press Enter three times to accept the default name (GLASS2), refractive index, and
Abbe V-value.

Click on Rin to list the refractive indices. Although the model glass is specified only by
its refractive index at the d wavelength and Abbe number, the refractive index data for F
and C wavelengths remain almost unchanged.

Defining the optimization variables

® In the surface data spreadsheet, define the variables: Under GLASS for the second
surface GLASS?2, click on the gray button, and select Variable RN/DN. (The Special
Variable RN/DN option is exactly equivalent). Note that although the Abbe number is
used to define the dispersion for the model glass it is the OSLO “DN” which is used as a
variable. This is a normalized parameter, best visualized in the index-dispersion plot.
DN takes a value of 0.0 along the line joining N-FK5 and N-SK16, and a value of 1.0
along the line joining N-FKS5 and SF11. Nearly all catalog glasses sit between these two
lines, but most of the “normal” glasses tend to cluster about DN = 1.0.
® C(Click on the variables button at the top of the oo e e T e | BN
spreadsheet, and put an upper limit of 1.0 for the |~
value of DN, the dispersion parameter for surface
2. Leave the lower limit as O.
® Also set the minimum value of RN surface 2 as
1.48, the index of FK51, and the maximum
value 1 .85, the index of N-LaSF9, the highest
index glass which can be regarded as having reasonable cost and acceptable
environmental properties.
® (Click on “Vary all curvatures”.
® (Close the variables spreadsheet and the surface data spreadsheet.
® Save the lens. The listing is given here:
*LENS DATA
Doublet /6.3 150 mm
SRF RADIUS THICKNESS ~ APERTURE RADIUS GLASS SPE NOTE
0BJ - 1.0000e+20  1.7455e+18 AIR
AST ~ 91.370000 V.  5.700000 12.500000 A N-BAK4 C
2 -66.210000 V  2.200000 12.500000 GLASS2 V
3 -197.710000 V 121.451048 S  12.500000 AIR
IMS - - 2.182779 S
Optimization
® Using the header of the Text window, list the operands (Ope) and the variables (Var).

Optimizing using Seidel aberrations
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*OPERANDS
OP MODE  WGT NAME VALUE %CNTRB DEFINITION
01 M - PY 1.7764e-15 -- ocM1
0 M 1.000000 PU -0.015829  2.24 OCM2+0.07937
03 M - PYC 2.182779 --  0CcM3
04 M - PUC 0.017260 - 0oCM4
05 M 1.000000 PAC -0.081694 59.77 OCM5
06 M -- PLC -0.000343 -- 0oCMe
07 M - SAC -0.053498 -- ocM7
08 M - SLC -0.000226 -- ocM8
09 M 1.000000 SA3 -0.063974 36.65 OCM9
010 M 9.000000 CMA3 0.004069  1.33 OCM10
MIN ERROR FUNCTION: 0.011166
*VARIABLES
VB SN CF TYP MIN MAX DAMPING INCR VALUE
V1 2 - cv - -- 1.000000 0.000100 0.010945
V2 3 - ¢V - -- 1.000000 0.000100 -0.015103
vV 3 4 - v - - 1.000000 0.000100 -0.005058
V4 3 - RN 1.480000 1.850000 1.000000 0.001000 1.672698
V5 3 - DN -- 1.000000 1.000000 0.001000 0.929017
® Optimize for 10 cycles (Ite).
*ITERATE FULL 10
NBR DAMPING  MIN ERROR  CON ERROR PERCENT CHG.
0 1.0000e-08 0.011166 -
1 3.792096 0.002771 - 75.179931
2 0.002633 6.6051e-06 -- 99.761674
3 0.000615 2.4247e-07 - 96.329101
4 7.8298e-06 1.0315e-12 - 99.999575
5 1.2696e-09 2.426le-19 - 99.999976
6 1.2696e-09 1.0128e-25 - 99.999958
7 1.2696e-09 1.0075e-31 - 99.999901
8 1.269595 8.3919e-32 - 16.703389
Choosing a real glass type
® Find the DN value of the new glass:
var 5
*VARIABLES
VB SN CF TYP MIN MAX DAMPING INCR VALUE
V5 2 - DN - 1.000000 1.000000 0.001000 0.998766
® List its refractive indices and Abbe V-value
rin 2 2
*REFRACTIVE INDICES
SRF  GLASS/CATALOG RN1 RN2 RN3 VNBR TCE
2 GLASS2 1.694707 1.711261 1.687937 29.785506  82.000000
® Open the surface data spreadsheet.
® (lick on the gray button for surface 2 glass.
® Select FIX and choose the latest Schott catalog (either Schott, or Schott 2004,
depending on the edition of OSLO). In any event the glass chosen should be SF-15.
® Enterrin 2 2:
*REFRACTIVE INDICES
SRF  GLASS/CATALOG RN1 RN2 RN3 VNBR TCE
2 SF15 1.698952 1.715461 1.692215 30.067619  79.000000
SCHOTT

Optimizing using Seidel aberrations
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® Open the glass catalog database.

® From the menu header select File >Open database > PUBLIC >
glass_schott.cdb (it may be glass_schott2004.cdb in some versions of OSLO)

[Easrzemns
SF15. '
Note that the glass is highlighted in yellow
on the n-V diagram. The atmospheric and =L
chemical properties are found in the — = - S war.. WS
column labeled ChemCode (10112). T '
These are not bad, but a better glass, the S| srs7 _
lead- and cadmium-free equivalent is N- e L e
SF15 with a ChemCode of 10111. S I il —

® In the GLASSNAME column, click on g
z

sHLASF4T sH-LASE4D

® Change the glass for surface 2 to N-SF15: under the gray button for GLASS, select
Catalog > Schott and click on N-SF15 - it is not possible to just type in the name to
replace a model glass.

Final optimization steps
Reoptimize with the remaining parameters (the three surface curvatures).

® (Click on lte:
*ITERATE FULL 10

NBR DAMPING MIN ERROR CON ERROR PERCENT CHG.
0 1.0000e-08 2.7751e-05 -
1 1.0000e-12 2.7540e-05 - 0.759895
2 1.0000e-12 2.7520e-05 - 0.073851
3 1.0000e-12 2.7519e-05 - 0.003876
4 10.000000 2.7519e-05 - 1.0937e-06
Autofocus

Refocus to minimize the root mean square axial wave aberration, averaged over the three
wavelengths:

® Open the surface data spreadsheet.

® Under the gray THICKNESS button for surface 4 select Autofocus - minimum RMS
OPD > On axis (polychromatic).

® Right click on the text window, and choose Clear window and SS buffer.

® (lickon Len

Optimizing using Seidel aberrations
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*LENS DATA
Doublet /6.3 150 mm
SRF RADIUS THICKNESS  APERTURE RADIUS GLASS SPE NOTE
0BJ - 1.0000e+20 1.7455e+18 AIR
AST 94.166056 V 5.700000 12.500000 A N-BAK4 C
2 -67.121889 V 2.200000 12.500000 N-SF15 C
3 -273.328281 V 146.658952 S 12.500000 AIR
IMS - 0.080939 2.639626 S

® [t is worth combining the distances for surfaces 3 and 4 to avoid confusion: Click on the
defocus value.

b5 = 0.0809387292198
® In the surface data spreadsheet, set the defocus value (thickness surface 4) to O.

® Also click on the thickness for surface 3, and in the command line add +b5.
146.6589521609103+b5

® Finally, list the lens again:

*LENS DATA
Doublet /6.3 150 mm
SRF RADIUS THICKNESS  APERTURE RADIUS GLASS SPE NOTE
0BJ - 1.0000e+20 1.7455e+18 AIR
AST 94.166056 V 5.700000 12.500000 A N-BAK4 C
2 -67.121889 V 2.200000 12.500000 N-SF15 C
3 -273.328281 V 146.739891 12.500000 AIR
IMS - - 2.639626 S
Doublet /6.3 150 mm UNITS: MM
FOCAL LENGTH = 150.8 NA = 0.07896 DES: OSLO
5.05

Optimizing using Seidel aberrations
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Optimization using finite rays

The optimization exercise described in this section will be carried on into the tolerance
calculations of the next chapter. Because the starting design is well optimized, the initial
choice of error function and weights is not critical. The GENII error function, which is
given in all versions of OSLO, will be used for the initial design stages.

50 mm f/5.6 objective: specification

Design a triplet objective with a focal length of 50 mm, and a 15° semi-field of view, with
aperture f/5.6. Vignetting is not permitted - that is to say, the full diameter beam must pass
at all field angles. The final detector will be a photographic film with resolution out to 30
cycles/mm, and an MTF of at least 0.1 is required at this spatial frequency. Distortion is not
critical. Only current Schott glass types can be used, and manufacture is to be at
Rodenstock, by traditional methods, with dimensions marked on the final drawing in mm.

Finding a starting design

The most obvious starting point is the standard triplet supplied with the program. o |
The first task is to set it up with the correct field, aperture and wavelength E-
weights and to allow the aperture stop (drawn with a red pen) to move separately,

rather than being assigned to an air-glass surface:

e Click on the icon for Open an existing lens.

e At the bottom of the window which opens, after Library Directories: click on
Public.

e Seclect demo > edu and then click on demotrip.len.
® (lick on Open.

® Open the surface data spreadsheet.
® Change the lens identifier to 50 mm /5.6 +/-15deg

® (Click on Wavelength. Define the wavelength weights as 1.0 (.58756) 0.4 (.48613),
0.6 (.65627) and close the wavelength editor.

® (Click on Notes, delete all 5 lines of notes and replace with your own annotations.

® (Change the entrance beam radius to 4 .5 mm. That is, 50/5.6/2, rounded up.

® (Change the field angle to 15°

® (lick on the gray button for Aperture radius for surface 1, select Not checked.
Repeat for surface 6.

® (Click on surface 5.

Right click and select Insert before

® (Change thickness for surface 4 from 6 to 0.0, and thickness for surface 5 frm 0 to
6.0.

® (lick on the button for Aperture radius for surface 5, and select Aperture stop.
® (Click on the gray button under Special for surface 5 (AST).

Optimization using finite rays
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® Seclect Surface Control (F) > General

® On the second line, against Surface appearance in lens drawings: sclect Drawn.
Set the Pen number for surface in lens drawings as 4 (red).

® Set all the lens aperture radii to Solve. The aperture pickup on surface 2 vanishes.

Checking for vignetting in the starting design

In the triplet provided, the ray drawing conditions have been changed to allow for the
vignetting. The first need is to restore the off-axis beams drawn to their full

diameter. ==
® (lick on the Edit Lens Drawing initial distance: RNEEE  Final distance:

Horizontal view angle: [Z20 vertical view angle:

Conditions icon. First surface to draw [ 5]  Last surface to draw [ 5] Autodraw:
x shift: v shift: [ 5.000800] oxF/TGES view:
Apertures: Rings: spokes: Image space rays:

® [n the section which governs Draw aperture stop: @ OFF (3 on Hatch back of reflectors: () OFf @ an
Shaded solid color - Red: Green: Blue:
I'ayS dI‘aWn at the fOOt Ofthe Number of ray fans in lens drawings: Points for aspheric profiles:
Frac Y obj Frac X Obj Rays Min Pupil Max Pupil offset FY FX wvn
spreadsheet, change the number =1 ® oI

[ o0.7o0000 [ o.ooo0o00d [-1-oooood] [ 1.o00000 [ 0.o000000 ® O

Of I'ays for fan NO- 2 from 0 tO 3 [ 1000000 [_o.000000] [-1.000000] [_1.000000 [ 0.000000 @& O
Set the Min Pupil to -1 .0 and

the Max Pupil to +1 .0 for fan No. 3.

50 mm /5.6 +/-15deq UNITS: MM
FOCAL LENGTH = 50 NA = 0.09 DES: OSLO

® (Close the Lens Drawing Conditions spreadsheet.

® Draw the lens.

® C(Click on Len Wav and Pxc to list the lens.

*LENS DATA
50 mm /5.6 +/-15deg
SRF RADIUS THICKNESS  APERTURE RADIUS GLASS SPE NOTE
OBJ -- 1.0000e+20 2.6795e+19 AIR
1 21.250000 2.000000 7.304439 S SK16 C
2 -158.650000 6.000000 6.710505 S AIR
3 -20.250000 1.000000 3.665807 S F4 C
4 19.300000 -- 3.420953 S AIR
AST - 6.000000 3.420953 AS AIR *
6 141.250000 2.000000 5.931324 S SK16 C
7 -17.285000 42.950000 6.415576 S AIR
IMS -- -- 13.376446 S
*WAVELENGTHS
CURRENT  WV1/Ww1 Wwv2/7ww2 WV3/Ww3

1 0.587560 0.486130 0.656270
1.000000 0.400000 0.600000

*PARAXIAL CONSTANTS
Effective focal length: 50.000541 Lateral magnification: -5.0001e-19

Numerical aperture: 0.089999 Gaussian image height: 13.397605
Working F-number: 5.555616 Petzval radius: -149.381547
Lagrange invariant: -1.205771

Optimization using finite rays
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Assessing the starting design

The diagram above indicates the edge thicknesses of the positive components are far too
small for economic manufacture. The center thickness of the negative lens needs increasing
as well. And the stop needs to move away from the second surface of the negative lens to

allow a plane diaphragm plate to be used. I I I I
® In the Standard Tools graphics menu, click on the Through-Frequency MTF I I I I
icon.
® Right click in the graphics window, and select meipom
Recalculate with new parameters... dOT=
WAVELENGTHS 08
# 0 A(um) Weight| Z “a
. 1 588 1 2o N
e Enter Maximum frequency 30 cycles/mm. 2 oo o) &
§ 0.4 Ny
The resolution, especially in the off-axis points, needs 02
improvement, but otherwise the performance is good. S .
® Click on the icon for ray intercept curves. 1P FRec o v B erts Frctrows |2y
® Right click in the graphics window, and select Vi T | T
Recalculate with new parameters... 7 = \#\f I\ l’
Fiold 0 Sty / \‘. S o5
® Enter a value of 0.03333 mm (the reciprocal //f ‘ L |

of the customer-defined spatial frequency) for
the User aberration scale.
The transverse aberrations at all wavelengths in the
meridional (Y) section off axis particularly need to be
reduced.

s
50 v (/5.6 +/-15deg L0
s o’ o7
0 485 00 6% m RAY TRACE ANALYSTS e

Defining and validating the error function

® From the Optimize menu header, select Generate error function > GENII Ray
Aberration...

® Fill in the entries for a Design frequency of 30 cycles/mm.

® Fill in the pupil coordinates on the basis of no vignetting: F1 (on axis)

[1o00000 P fymax

fymaX =1. O F2 (0.7 ﬁeld) fymin =-1. O fymax =1. O fX =1. O [T000006 F2tymin
F3 (edge of field) fymin=-1_0 fymax=1.0fx=1.0. : e
[F003000  Fatymin

® The tolerance on distortion at both F2 and F3 is distol = 10% (in other |[ & msra

words, distortion will not be tightly controlled). :m o
|!J F3 distol
® Finally click on OK to close the Geniierf spreadsheet. ERE

® Type in the command line ope all to list the operands that have been defined by this
command. (Operands which begin with an underscore are not listed by clicking on the
Ope icon in the text window.)

Only the first 13 are listed below.

Optimization using finite rays
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*OPERANDS

OP MODE WGT NAME VALUE %CNTRB DEFINITION

01 M - _Dy tol 0.005556 -- 0.0055555555556
02 M - _2.1 Dby 0.011667 -- 0.0116666666667
03 M -- _2.8 Dy 0.015556 -- 0.0155555555556
04 M - _3 Dby 0.016667 -- 0.0166666666667
05 M - _4 Dy 0.022222 -- 0.0222222222222
06 M - _up Dy/3 0.283656 -- 0.283655904077
07 M -- _3.2 up Dy 2.723097 -- 2.72309667914
08 M - _uprime -3.5749%e-14 -- PU+0.0899990260196
09 M 1.000000 Fnb diff -3.5749e-10 0.00 08/0.0001

010 ™ 1.000000 Focus diff 0.704983 0.26 DYY(1,1)/04
011 M 1.000000 Axial DY 0.035247 0.00 DY(1,2)/01

012 M 1.000000 Axial OPD -1.189682 0.75 OPD(1,2)/06
013 M 1.000000 Axial DMD 1.828939 1.78 DMD(1,2)/06

The first weighted operand controls the focal length rather tightly. In the initial stages of
design it is preferable that this be relaxed. So:

e Click on the icon for Edit optimization operands. ===
e Change the weight for operand 9 from 1.0 to O. 1. =
e List the operands, noting in particular any that have contributions above 10%. They
are:

021 M  1.000000 0.7 OPD U  -5.224602 15.30 OCM21/0CM6

022 M 1.000000 0.7 DMD U 4.600139 11.86 OCM22/0CM6

024 M  1.000000 0.7 OPD L -4.782094 12.82 OCM24/0CM6

036 M  1.000000 1.0 OPD U  -5.267896 15.55 OCM36/0CM6

037 M  1.000000 1.0 DMD U 6.020660 20.31 OCM37/0CM6

These are respectively, for the 0.7 field point, wave aberration and color for the upper Y-
section ray, and wave aberration for the lower ray; also for the full field, wave aberration
and color for the upper Y-section ray. These are the same aberrations as the plot above
indicates will be causing the greatest reduction in MTF, so the error function has been
validated.

Note that the initial value for the error function is given on the last line of the operand

listing as the root mean square of the weighted contributions:
MIN RMS ERROR: 2.434848

Description of the GENII error function

The GENII error function provided with all versions of the program is remarkably sparse yet
effective. It makes maximum use of the results of ray-tracing from a single marginal ray on
axis, and a chief ray and three rays in the pupil for each of two other field angles. The
aberrations of these rays constitute the error function.

The error function has two weighted operands controlling the Gaussian properties, three to
control the axial image formation (transverse ray aberration DY, wave aberration OPD and
Conrady chromatic variation in wave aberration DMD for color control), and 13 to control
the four rays at each of the off-axis points at FBY = 0.7 and 1.0. This makes a total of 31,
leaving the remaining 19 for necessary data storage.

Because the dimensions of transverse ray aberrations, wavefront aberrations, longitudinal
errors and color are so different, the error function uses scaling factors on each to enable the
default value of unity weighting as the starting value for each operand. For example, the
basic scaling factor on transverse errors is (6 N)" where N is the design spatial frequency.

Defining the error function invokes a call to geniierf() (or, for users of OSLO-EDU,
geniierf_It) which is in public/ccl/optim_erfs.ccl. The OSLO EDU version specifies
geniiops as a callback, which will be found in public/ccl/optim_callbaks.ccl. More
information is available in OSLO Help.

Optimization using finite rays
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Defining the optimization variables

Open the surface data spreadsheet.
Click on the gray button for thickness 2, and select Variable.
Repeat for thicknesses 4, 5, 7.

Click on the Variables button to open the variables spreadsheet.
Click on the Vary all curvatures button.

For variable 2 (thickness 4) set a MIN value of 0.5 mm, leaving all other limits as

Close the variables spreadsheet.

Close the surface data spreadsheet

List the optimization variables by clicking on Var:

°
°

°

°

°

°

default.

°

°

°

*VARIABLES

VB SN CF TYP
V1 2 - TH
V2 4 - TH
vV 3 5 - TH
V 4 7 - TH
V5 1 - cv
V 6 2 - Cv
vV 7 3 - ¢V
vV 8 4 - v
V9 6 - CV
V1 7 - ¢V

ocooo
=
o
ls)
S
S
s}

MAX
1.0000e+04
1.0000e+04
1.0000e+04
1.0000e+04

DAMP ING
1.000000
1.000000

1.000000

INCR
0.000450
0.000450
0.000450
0.000450

2.2222e-05
2.2222e-05
2.2222e-05
2.2222e-05
2.2222e-05
2.2222e-05

VALUE
6.000000

—_ *
6.000000
42.950000
0.047059
-0.006303
-0.049383
0.051813
0.007080
-0.057854

There is an asterisk against thickness 4 indicating that the current value of the variable (=0)
violates the permitted range. As a result, the error function has increased.

® (Click on the Ope in the text window.
MIN RMS ERROR:

Optimization

3.772815

Two clicks on the Ite button gives the output shown below for this error function.

*ITERATE FULL 10

NBR DAMPING
CHG.
0 1.0000e-08
1 1.0000e-05
2 1.0000e-05
3 1.0000e-05
4 6.1580e-06
5 2.3352e-06
6 2.3352e-06
7 0.000144
*ITERATE FULL 10
NBR DAMPING
CHG.
0 1.0000e-08
1 1.0000e-08
2 1.0000e-08

MIN ERROR

3.772815
2.061430
1.548952
1.326489
1.295507
1.292165
1.292093
1.292093

MIN ERROR

1.292093

1.292093
1.292093

CON ERROR PERCENT

.360945
.860311
.362182
-335646
.257970
.005549

-- 2.4329e-05

CON ERROR PERCENT

If warning messages about clear aperture checking

appear with OSLO EDU they will not affect the result
significantly, although the final error function may differ slightly from the values given
here..

50 mm /5.6 +/-15 deg
FOCAL LENGTH = 50.05 NA = 0.08992

UNITS: MM
DES: 0SLO

WAVELENGTHS 08

FIELD POINTS
ON-AXIS T+ Sx
10.62deg T4 Sv

Ideal

6 2 [ 27 30
SPATIAL FREQUENCY (CYCLES/MM)

MTF TYPE eq.
DIFFRACTION MODULATION TRANSFER FUNCTIONS

50 mm /5.6 +/-15 d .
2 Al
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The performance has improved considerably - the lowest MTF at 30 cycles/mm is 0.6 (for T
section at .7 field). The prescription is:

*LENS DATA
50 mm /5.6 +/-15 deg
SRF RADIUS THICKNESS  APERTURE RADIUS GLASS SPE NOTE
OBJ - 1.0000e+20 2.6795e+19 AIR
1 25.838240 V 2.000000 7.591942 S SK16 C
2  -103.139037 V 6.389728 V 7.036229 S AIR
3 -14.888983 V 1.000000 3.888863 S F4 C
4 22.497814 V 0.499055 V 3.683790 S AIR
AST -- 3.457640 V 3.568729 AS AIR  *
6 161.514578 V 2.000000 5.108018 S SK16 C
7 -13.810731 V  44.869598 V 5.633273 S AIR
IMS -- -- 13.373470 S

The focal length is 50.05 mm, an error of less than 0.1% so there is no need to increase the
weight on operand 9.

Engineering aspects: edge thicknesses

As this lens is to be made by traditional means, a blank needs to be procured with sufficient
extra diameter to allow each component to be centered by edging. The thicknesses of all the
lenses need to be increased to improve manufacturing yield. Making an allowance of 3 mm
on diameter beyond the largest clear aperture diameter for the mounting (with an extra 1 mm
on the front lens to allow for weather-proofing), and a further 2 mm for the blank, the edge
thickness of each blank should be about 1.5 mm minimum.

To calculate the edge thicknesses of the blanks for the two positive lenses:
e From the Lens menu header select Show Auxiliary Data > Edge Thickness.

e For component 1, enter surface A =1, surface B = 2. Enter the clear semi-diameter
7.6 mm plus 3 mm = 10 .6 mm for the y-height at both surfaces:
*DISTANCE FROM SRFA 1 TO SRFB 2

AT YHTA YHTB XHTA XHTB ZSAGA ZSAGB
10.600000 10.600000 -- -- 2.274242 -0.546529
IS XDIS YDIS ZDIS GLOBAL DISTANCE

- -- -0.820771  0.820771
The edge thickness given (ZDIS) is -0.82 mm, so the centre thickness for surface 1
needs to be increased by about 2.8 mm to reach the target of 1.5 mm.

e Repeating for surface A =6, B = 7, enter 5.6+2.5 = 8.1 mm for the y-height at
both surfaces. otherwise type the command:
eth 6 78.18.100

For this lens, the edge thickness of the blank (ZDIS) is -0.83 mm, so the centre
thickness for surface 6 also needs to be increased by about 2.8 mm.

The centre thickness of the negative lens (surface 3) is too thin, and should also be
increased to 1.5 mm.

Rather than making these directly in the spreadsheet, they will be used to illustrate the
process whereby adjustments can be made with simultaneous optimisation.

Optimization using finite rays
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Slider-wheels with concurrent optimization on MTF

Adjusting lens thicknesses

The facility provided by OSLO to carry out slider-wheel optimization on one or more
parameters, with a simultaneous callback to optimization on other variables, is a powerful
design tool. In this context, note that no parameter adjusted with the slider-wheel bars
should be an optimization variable. In the example given here, the slider-wheels will be used
to adjust the lens thicknesses 1 for surfaces 1, 3 and 6, while the optimization on the lens
curvatures, air spaces and image distance will continue to correct performance during each
adjustment.

Close the surface data spreadsheet.
Open the slider-wheel spreadsheet. $-';
Select ® Ray-intercept curves at ® All points in the field.

Define three sliders for Thickness (TH) 1 Thickness (TH) 3 and Thickness (TH)
6.

e Sclect ® Enable sw_callback CCL function with Level = 9 (This must be in the
range from 1 to 9 to trigger the Iter function in the callback command.).

Close the slider-wheel setup spreadsheet.
_ |O[X]| mxow 31

- O]
2000000 4] »| Step01 2
1.000000 LJ _>| Step 0.1 2
2.000000 <_| _>| Step 0.1

B | en Soe Rin Ape Wav Pxc Abr Mra Chf Tra Sop Ref Fan Sod Auf Var Ope lte Siv Pko Ape
B pyt chr Sei Fif
*TTERATE FULL 9
NBR DAMPING MIN ERROR CON ERROR PERCENT CHG.
APERTURE_CHECK Oon

0 1.0000e-08 1.292092 i

=

The text window, the slider-wheel bar and the two temporary slider-wheel windows, GW31
and GW32, should all be visible. The starting value of the error function is 1.292.

Slider-wheels with concurrent optimization on MTF
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® [ncrease thickness 1 in steps of 0.1 until it reaches 4.0 giving an error function of 1.309.
Increase thickness 3 in steps of 0.1 until it reaches 1.5. The error function will be 1.372

Increase thickness 6 until it reaches 3.0; the error function becomes 1.408.

Increase thickness 1 to 4.7 and thickness 6 to 4.7, the optimized error function will be
1.480.

® (Close the slider wheels and list the lens.

*LENS DATA
50 mm /5.6 +/-15 deg

SRF RADIUS THICKNESS ~ APERTURE RADIUS GLASS SPE NOTE

0BJ - 1.0000e+20  2.6795e+19 AIR

1 29.485222 V. 4.700000 8.263805 S SK16 C

2  -86.537346 V  6.170610 V  6.982274 S AIR

3 -15.359048 V.  1.500000 3.947019 S F4 C

4 21.674799 V. 0.498922 V. 3.637632 S AIR

AST - 2.252805 V. 3.522903 AS AIR  *

6 77.234402 V. 4.700000 4.546980 S SK16 C

7 -14.489037 V  44.432412 V  5.759546 S AIR
IMS - - 13.376786 S

e Now to check the edge thicknesses, calculate the edge thickness of the front lens
blank ata radius Of 83+30 = 113 mm: FOCAL LENGT:S"%.SOJ;ESNA = 0.08988 ‘ Egg%ﬁm
eth 1 211.3 11.3 00 EEN
giving a value of 1.7 mm.
e Also find the edge thickness of the third lens
blank at a radius of 5.8+2.5 = 8.3 mm:

eth 6 7 8.3 8.3 00
which gives 1.6 mm.

These are both above the 1.5 mm which is required. For the diagram which shows the blank
sizes, the barrel semi-diameters have been rounded upwards to 10 mm, 5.5 mm and 7.5 mm
respectively.

Engineering aspects: ambiguity avoidance

It is extremely hard to tell which of the two surfaces of a nearly equi-concave lens is the
steepest. To avoid assembly errors, we will investigate the effect of making the second lens
truly equi-concave.

® Make the second element equi-concave. Click on the surface 4 gray RADIUS button
and select Minus curvature pickup (P)... with Pickup source surface =3
Pickup constant = 0, Pickup multiplir = 1.0.

® Reoptimise. The error function is 1.640. This increase is acceptable.

Slider-wheels with concurrent optimization on MTF
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*LENS DATA
50mm /5.6 +/-15 deg
SRF RADIUS THICKNESS ~ APERTURE RADIUS GLASS SPE NOTE
0BJ - 1.0000e+20 2.6795e+19 AIR
1 26.647695 V 4.700000 8.681421 S SK16 C
2  -361.254520 V 7.067320 V 7.317984 S AIR
3 -18.435016 V 1.500000 3.907032 S F4 C
4 18.435016 P 0.499751 V 3.580456 S AIR
AST - 2.398524 V 3.464412 AS AIR *
6 42.567801 V 4._.700000 4.577052 S SK16 C
7 -16.089048 V. 43.427580 V 5.729062 S AIR
IMS -- - 13.383518 S

Engineering aspects: testplate fitting

® Select the Rodenstock test glass file: Under the File menu header, select Preferences
> Set preference > Test_glass_file and in the command line enter
rodenstock.tgl.

of Command:

% stp tglf "rodenstock.tgl” -
? Current test glazs file; rodenstock. gl

Mumber of test glaszes: 1446
This refers to an ASCII file rodenstock.tgl in the directory OSLO/Prm64/bin/Imo/
which contains 1446 test glass values. Test glass files for other manufacturers are also
available, and the user may create others in the same format if desired.

® Open the surface data spreadsheet.

® For surface 7 (the shortest radius at 16.09 mm) remove the variable curvature (change to
Direct specification).

® Hold down the shift key and left-click the mouse twice on the radius. A value -
16.0766 will appear as the nearest test glass, with a black box around it.

® (Click on the green tick to accept this (or shift-left-click to restore the nominal radius).
The letter T appears next to the fitted radius.

® Press Ite to optimize the remaining variables.

e Repeat this sequence for surface 3 - remove the variable, fit the closest test glass,
and optimise remaining variables.

e Repeat this sequence for surface 6 and then again for surface 2.

e Click on Len to list the design. Note the T which appears against each radius which
has bees fitted to a test glass.

Slider-wheels with concurrent optimization on MTF
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*LENS DATA
50 mm /5.6 +/-15 deg

SRF RADIUS THICKNESS ~ APERTURE RADIUS GLASS SPE NOTE
0BJ - 1.0000e+20  2.6795e+19 AIR

1 26.699200 T 4.700000 8.692011 S SK16 C

2 -375.820000 T  7.098400 V  7.328991 S AIR

3 -18.438800 T  1.500000 3.907388 S F4 C

4 18.438800 P 0.499794 V.  3.581367 S AIR

AST - 2.384983 V  3.465615 AS AIR  =*

6 42.322100 T 4.700000 4.572836 S SK16 C

7 -16.076600 T  43.429946 V  5.724953 S AIR

IMS - - 13.380875 S

® (Click on Ope in the text window.

MIN RMS ERROR:

1.641164

The error function has risen slightly.

Rounding air spaces

Round the air spaces to avoid giving the impression that they are subject to tight tolerances:

Change thickness 2 to 7.1, delete the variable and re-optimize.

Change thickness 4 to 0.5, delete the variable and re-optimize.

Change thickness 5 to 2.4, delete the variable and re-optimize on the one remaining

variable, the focus.

Enter the command: ope erf

The error function has risen slightly:

MIN RMS ERROR:

1.645251

Adjusting clear apertures

® (lose the variables spreadsheet and the lens data spreadsheet.

® Under the Optimize menu header, select Support routines > Vignetting > Set

apertures and in the dialog box change the
number of digits to 2.

® (Click on OK.

*APERTURES

SRF  TYPE APERTURE RADIUS
0 SPC  2.6795e+19
1 SPC 8.500000 CHK
2 SPC 8.500000
3 SPC 4.000000
4 SPC 3.600000
5 SPC 3.500000 CHK
6 SPC 5.500000
7 SPC 5.500000 CHK
8 CMP 13.380786

Apset

Option

+ Setallapertures Set solved apertures only

-1.000000  Target value for lower aperture vignetting
1.000000  Target value for upper aperture vignetting
2 Mumber of digits to round to

Report ray emor
* Yes " No

o]

Cancel Help

® Remove the Checked aperture (K) indications from surfaces 1, 5 and 7.

® Change the clear aperture surface 4 to 4.0 mm (as this lens is reversible).

Slider-wheels with concurrent optimization on MTF
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® Remove the Pickup (P) from the radius on surface 4, change all the other radii to
Direct specification, but leave the variable on the back focal distance (thickness 7).

® List the lens:
50 mm /5.6 +/-15 deg.

SRF RADIUS THICKNESS = APERTURE RADIUS GLASS SPE NOTE
0OBJ - 1.0000e+20 2.6795e+19 AIR
1 26.699200 4.700000 8.500000 SK16 C
2 -375.820000 7.100000 8.500000 AIR
3 -18.438800 1.500000 4.000000 F4 C
4 18.438800 0.500000 4.000000 AIR
AST - 2.400000 3.500000 A AIR  *
6 42.322100 4.700000 5.500000 SK16 C
7 -16.076600 43.397798 V 5.500000 AIR
IMS -- -- 13.366656 S *
50 mm /5.6 +/-15 deg. UNITS: MM
FOCAL LENGTH = 50.02 NA = 0.08996 DES: OsSLO
/.62

This completes the design of this lens. The next chapter will start from this point as the basis
of the tolerance calculation exercise.

Slider-wheels with concurrent optimization on MTF
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50 mm f/5.6 objective: specification

For the lens which is the final design of the triplet describes in the previous section, the task
is to define the surface and component tolerances which, based on root-sum-of-squares
statistics, give an MTF which does not fall below 0.1 at 30 cycles/mm at any of the three
field points. The assumption will be made that in production there will be a uniform
distribution of errors within the tolerance band, and that a focus adjustment will be carried
out on assembly.

This will be accomplished using a CCL command which assesses the MTF at 30 cycles/mm
in both azimuths at 5 field points across the field - with values of FBY of 0.0, + 0.7 and +
1.0.

Defining the tolerance error function:”opcb_dmtf”

The CCL routine below will calculate the MTF in 2 azimuths at 5 field points, 10 values in
all. It will then identify the worst (i.e. lowest) of these, and subtract it from the diffraction
limited MTF at the same frequency. The error function consists of a single operand, having
this value.

Subtracting the lowest MTF from the ideal ensures that, as in all optimization operands, the
system with the lowest value of the error function is the best one.

The routine here is a “callback” - that is to say, it is evaluated whenever the error function
is calculated. It places a single value into the real array ocm[1]. This value is then called
using the string OCM1 as the definition of the operand.

® Open the text editor and create a new file:
//

// Written by [your name] [Date]

//

cmd opcb_dmtf(void)

// hlp: <P>Callback for DMTF (degradation in MTF) optimization.
// hlp: OCM1 is max reduction in MTF below ideal MTF at 5 field
// hlp: points for one spatial frequency. Both X & Y are included
// hlp: on axis, as well as field height FBY both +ve and -ve.</P>

{
static double mtfs[10],diff_lim,mtf _min;
static double sf=30.0; //spatial frequency

stp outp off;
k=sbrow;
sbr k 1;//scrolls spread sheet buffer to preserve contents

sop(0,0,0);
mtf(tfr,chr,y,sf,sf,0);
mtf(tfr,chr,x,sf,sf,0);

sop(0.7,0,0);
mtf(tfr,chr,y,sf,sf,0);
mtf(tfr,chr,x,sf,sf,0);

sop(-0.7,0,0);
mtf(tfr,chr,y,sf,sf,0);
mtf(tfr,chr,x,sf,sf,0);
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sop(1,0,0);
mtf(tfr,chr,y,sf,sf,0);
mtf(tfr,chr,x,sf,sf,0);

sop(-1,0,0);
mtf(tfr,chr,y,sf,sf,0);
mtf(tfr,chr,x,sf,sf,0);

diff_lim=d5;
if(diff_lim==0) cclabort("Diff limited MTF zero","opcb_dmtf");

mtfs[0]=b5;// Ax
mtfs[1]=b8;// AX
mtfs[2]=b14;// +7
mtfs[3]=b17;// +7
mtfs[4]=b23;// -7
mtfs[5]=b26;// -7
mtfs[6]=b32;// +1
mtfs[7]=b35;// +1
mtfs[8]=b41;// -1
mtfs[9]=b44;// -1

n-Hn—4n-4n-44un-d

mtf_min=1.0;
Ffor(i=0;i<10;i++) if(mtfs[i]l<mtf_min)mtf min=mtfs[i];

ocm[1]=diff_lim-mtf_min;// DMTF: MAX FALL BELOW DIFFRACTION LIMIT

sbr -k 0;
stp outp on;

® Save the command in /private/ccl/ with the name optim_dmtf.ccl, and check correct

compilation.
*CCL COMPILATION MESSAGES:

No errors detected
® Open the optimization conditions spreadsheet.

® Change the entry for the optimization callback, Command for CCL/SCP
operands: opcb_dmtf

® On the bottom line, under Error function value, select ® Root-mean-square
(RMS).

® (Close the optimization conditions spreadsheet.
® Enter the command line ope new;end to delete the existing operand list.

® Open the operands data editor spreadsheet.

® Fill in the name and definition as in the following table:

oP MODE WGT NAME DEFINITION
1 MIN 1.000000 DMTFat30 OCM1

® (Close the operands spreadsheet and list the operands with Ope

*OPERANDS

OP MODE  WGT NAME VALUE %CNTRB DEFINITION

01 M  1.000000 DMTF at 30  0.408358 100.00 OCM1

MIN RMS ERROR: 0.408358

Since there is only one operand in the error function, the value of the RMS minimization
error is the actual value of DMTF, the degradation in MTF.

Defining the tolerance error function:”opcb_dmtf”
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Defining the compensator

To enable the widest possible tolerances to be assigned to the lens, one or more
“compensators” can be defined. These represent the adjustments made during assembly
which can partly compensate the errors in the individual components. The most common
compensator is, of course, the focus, and that is the only compensator used in this example.

To define a compensator, the parameter concerned must be defined as an optimization
variable.

® In the text window click on Var.

® Confirm that thickness 7 is variable, and is the only variable.

Before commencing the calculation of tolerances, the compensator must be set to the
optimum position for the nominal design.

Optimizing on the compensator

® To find the best focus, just optimize with Ite and click on Var

*ITERATE FULL 10

NBR DAMPING MIN ERROR  CON ERROR PERCENT CHG.
0 1.0000e-08 0.408358 --
1 6.158000 0.367641 -- 9.970860
2 61.580000 0.361620 -- 1.637656
3 379.209640 0.360640 -- 0.271130
4 379.209640 0.360640 -- -
5 379.209640 0.360640 -- --
*VARIABLES
VB SN CF TYP MIN MAX DAMPING INCR VALUE
Vi 7 - TH 0.100000 1.0000e+04 1.000000 0.000450 43.385935

To confirm the choice of focal plane, plot the through-focus MTF at 30 cycles/mm:
u

-

®  (Click on the icon and accepting all defaults.

® Right click in the graphics window, and select Recalculate with new
parameters...

® Enter Frequency 30 cycles/mm.

The curves show that the

ideal focal plane has been FIELD POINTS
Chosen ON-AXIS T+ Sx

10. 5deg Ta Sv
The diagram also illustrates Tdeol . 1
the significance of the WAVELENGTHS
quantity DMTF. It is the £ () weignt| Z

1 0.588 1 =
largest drop below the 2 048 04| T
diffraction limit at any of 306 06 5
the five field points, with =

assessment in both sagittal
and tangential directions

(including on axis). This 0.4 0.2 0 02 04
. FOCUS (rrm)
error function has been
h h . MTF TYPE 50 mm /5.6 +/-15 deg oo
chosen so that asymmetric DIFFRACTION POLYCHR. MTF AT 30 CYCLES/MM 0537 A

tolerances can be included in

Optimizing on the compensator
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the calculation.

® Under the Evaluate menu header, select Transfer function > Print/Plot OTF and
in the dialog box select: Monochromatic, Print function, with Maximum
frequency = 30 line pairs per mm.

In this case the diffraction limit MTF at 30 cycles/mm is 0.86. At the best focus, the
nominal value of the worst MTF at 30 cycles/mm is 0.49, giving a value of DMTF for the
nominal system of 0.36. If the MTF must remain everywhere above 0.1, the value of
DMTF must not increase to more than 0.76.

Calculating decenter tolerances

As an example we will calculate the effect of decentering the second lens by the minimum
amount one can expect from traditional mounting methods:

® Open the surface data spread sheet.
® Under Special for surface 3, select Coordinates (C).

® Enter .075 mm for DCY, and under Use base coordinates for returns to this surface:
select Yes.

® Under Special for surface 4, select Coordinates (C).
® Under Coordinate return: select Yes and under Return to surface: enter 3

® (lick on Ope and find the new DMTF value:

MIN RMS ERROR: 0.612975

So DMTF has increased from 0.36 to 0.61, an increase of 0.25. This has used
more than half the entire tolerance budget of 0.40 on one error, so clearly a specialized
mounting method (such as laser centering in the mount) will need to be used to meet the
performance target. That being the case, we will assume that all the component decenter
tolerances can be regarded as zero, and calculate the budget for the remaining errors.

P

Checking tolerance entries
The default tolerance values assigned to each parameter are the ISO10110 values. Because
there are two successive air spaces (4 and 5), the tolerance on the first one can be removed.

® (lick on the Edit Surface Tolerances icon, or select from the menu header I t
Tolerance > Update tolerance data > Surface.

® Click on Display all surfaces tolerances: ®© Yes.
® For surface 4, set TH TOL (thickness tolerance) to 0.0

® (lose the surface tolerances data editor.

Symmetrical tolerances surface calculation

® From the menu header select Tolerance >
User-defined Tolerancing and select oo o
Sensitivity and Symmetric perturbations. | & senstvty © inverse sensiiviy
Tolerance item =
—
'Tl Cancel | Help |

User-defined tolerancing

Calculating decenter tolerances
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® A warning message comes up. The error function does not assume rotational symmetry,
so click on OK.

The sensitivity analysis (which may take one or two 0SLO Premium Edition B|
minutes) lists 6 power errors, 3 element thicknesses,

. . . ! i . i
2 air spaces, 3 indices and 3 V-values, 17 o e

may assume rotational symmetry,

symmetrical contributions in all. The summary is: Press OK to confinue or Cancel to stop.
UNCOMPENSATED ~ COMPENSATED
WORST CASE CHANGE 6.019989 3.022531 e O] Cancel
STANDARD DEVIATION
RSS 1.659396 1.056369
UNIFORM 0.958053 0.609895
GAUSSIAN 0.729824 0.464604

The change in the error function, with focus compensation, for a uniform distribution of
errors within the tolerance band is 0.61 is an indication that the standard tolerances are not
acceptable.

If we allocate 0.33 of the budget of 0.40 to the symmetrical tolerances, then each tolerance
will be allowed 0.33/\17 = 0.08 MTF degradation.

® From the menu header select Tolerance > User-defined Tolerancing and select
Inverse sensitivity and Symmetric perturbations, enter 0. 08 for Change in
error function.

*INVERSE SENSITIVITY ANALYSIS
ERROR FUNCTION FOR NOMINAL SYSTEM: 0.360640
ALLOWED CHANGE IN ERROR FUNCTION: 0.080000

POWER ERROR TOLERANCE
ALLOWED TOLERANCE

SRF UNCOMPENSATED COMPENSATED
1 4.204420 109.362285
2 4.416476 72.560814
3 1.941512 1.807345
4 1.910946 1.747543
6 3.571230 3.882230
7 3.599738 27.941716

These tolerances must be tightened from the ISO10110 values of 10, 10, 5, 5, 10 and 10
fringes to 5 fringes throughout.

ELEMENT THICKNESS TOLERANCE
ALLOWED TOLERANCE

SRF UNCOMPENSATED COMPENSATED
1 0.074299 0.096090
3 0.079866 0.246151
6 0.109412 0.337794

The first one needs to be changed to from the ISO10110 value of 0.2 to 0.1 mm.

AIR SPACE TOLERANCE
ALLOWED TOLERANCE

SRF UNCOMPENSATED COMPENSATED
2 0.079453 0.053990
5 0.035223 0.036388

These must be tightened to 0.05 mm.

INDEX OF REFRACTION TOLERANCE
ALLOWED TOLERANCE

SRF UNCOMPENSATED COMPENSATED
1 0.000460 0.006810
3 0.000381 0.000346
6 0.000376 0.000342

These must all be tightened from .001 to 0.0006 (note that the glass type for lens 1 and for
lens 3 are the same, so only one standard of glass need be procured).

Symmetrical tolerances surface calculation
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ABBE V-NUMBER ERROR (IN %) TOLERANCE
ALLOWED TOLERANCE

SRF UNCOMPENSATED COMPENSATED
1 5.230509 20.247082
3 3.291042 12.443420
6 4.223386 14.964191

These can stay at 0.8%.

Updating symmetrical surface tolerances

® (Click on the Edit Surface Tolerances icon, or select from the menu header I I
Tolerance > Update tolerance data > Surface.

® (Change the tolerances on symmetric form error (PWR FR) at all surfaces to 5
® Change the tolerances on thickness (TH TOL) at surfaces 2 and 5 to 0.05.

® Change the tolerance on thickness (TH TOL) at surfaces 1 to 0.1

® (Change the tolerances on index (RN TOL) at surfaces 1 3 and 6 to 0.0006.
® (Close the surface tolerances data editor.

® Repeat the sensitivity calculation for symmetrical tolerances:

STATISTICAL SUMMARY
UNCOMPENSATED COMPENSATED

WORST CASE CHANGE 4.548071 0.744409
STANDARD DEVIATION

RSS 1.271472 0.472209

UNITFORM 0.734085 0.272630

GAUSSIAN 0.559210 0.207684
COMPENSATOR STATISTICS
COMP MEAN STD DEV MAX RSS
TH 7 -0.011420 0.099581 0.356100 0.483578

® The degradation of 0.27 (less than the 0.33 allowed for) leaves a balance of 0.13 for the
asymmetric tolerances.

Asymmetric tolerances surface calculation

Since the full asymmetrical sensitivity analysis cannot be undertaken with OSLO EDU, the
relevant elements of the sensitivity analysis will be calculated separately.

There are only two surface errors to be considered. These consist of 6 surface irregularity
errors, and 6 surface tilt errors (TLA only), 12 in all. If we allocate the remaining 0.13 of
MTF degradation (that is, the budget of 0.4 minus the 0.27 taken up by symmetrical
tolerances) to these 12 tolerances, then each contribution is 0.13/12 = 0.038.

® Remove the variable from thickness 7 — focus cannot compensate for asymmetrical
errors.

® Remove the variable from thickness 7, since focus cannot compensate for asymmetrical
errors.

® From the menu header select Tolerance > User-defined Tolerancing and select
Inverse sensitivity and Irregularity fringes, enter 0.038 for Change in error
function.

Asymmetric tolerances surface calculation
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*INVERSE SENSITIVITY ANALYSIS
ERROR FUNCTION FOR NOMINAL SYSTEM: 0.360640
ALLOWED CHANGE IN ERROR FUNCTION: 0.038000

IRREGULARITY ERROR TOLERANCE
ALLOWED TOLERANCE
F UNCOMPENSATED
2.097225
2.261429
0.816355
0.818204
1.263006
1.188189

The tolerance on both surfaces of the last lens needs to be changed to from the ISO10110
value of 2 fringes to 1 fringe.

S

~NoOA~AWNRE D

® From the menu header select Tolerance > User-defined Tolerancing and select
Inverse sensitivity and Surface tilt tolerance (TLA), and again enter O .038 for
the Change in error function.

*INVERSE SENSITIVITY ANALYSIS
ERROR FUNCTION FOR NOMINAL SYSTEM: 0.360640
ALLOWED CHANGE IN ERROR FUNCTION: 0.038000

SURFACE TILT TOLERANCE (TLA)
ALLOWED TOLERANCE
UNCOMPENSATED

0.139481
0.108784
0.145052
0.161710
0.153277
0.110764

these tilt tolerances must be changed to 0.08 degrees (5 minutes).

%2}

~N~NoOh~AWNRE D
B

Al

—_

Updating asymmetric surface tolerances

® C(Click on the Edit Surface Tolerances icon, or select from the menu header I I
Tolerance > Update tolerance data > Surface.

® Change the tolerances on irregularity — i.e. asymmetric form error IRR FR - at surfaces
6and7to 1.0

® Change the tolerances on tilt (TA TOL) for all refracting surfaces to 0.1

® (Close the surface tolerances data editor.

Updating asymmetric component tolerances

The decision has already been made to center the components precisely.
® Select from the menu header Tolerance > Update tolerance data > Component.

® Change the tolerances on centration (DCY) and tilt (ALPHA) to 0.0

Asymmetric tolerances calculation

® From the menu header select Tolerance > User-defined Tolerancing and select
Sensitivity and Asymmetric perturbations, or type the command: tsn asy.
Only the summary data is given here.

Asymmetric tolerances surface calculation
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STATISTICAL SUMMARY

UNCOMPENSATED
WORST CASE CHANGE 0.946050
STANDARD DEVIATION
RSS 0.308895
UNITFORM 0.178341
GAUSSIAN 0.135856

® The degradation of 0.18 is a little larger than the 0.13 budget for the asymmetric
tolerances, but note that all tolerance calculations subject to the approximations of
statistics.

Tolerance data listing

® From the Lens menu header select Show tolerance data > Surface.

*SURFACE TOLERANCES
50 mm /5.6 +/-15 deg

RADIUS RD TOL  FRINGES THICKNESS TH TOL RN TOL DECEN TILT
SRF CON CNST CC TOL PWR IRR TLC TOL DZ TOL GLASS V TOL Y/X  A/B
1 26.6992 -- 5.00 2.00 4.7000 0.1000 SK16 0.0006 -- 0.0800
- - - - 0.8000 -- 0.0800
2 -375.8200 --  5.00 2.00 7.1000 0.0500 AIR - --  0.0800
- - - - - -- 0.0800
3 -18.4388 --  5.00 1.00 1.5000 0.1000 F4 0.0006 --  0.0800
- - - - 0.8000 -- 0.0800
4 18.4388 -- 5.00 1.00 0.5000 -- AIR - -- 0.0800
- - - - - --  0.0800
5 - - - ——  2.4000 0.0500 AIR - - -
6 42.3221 -- 5.00 1.00 4.7000 0.2000 SK16 0.0006 --  0.0800
- - - - 0.8000 -- 0.0800
7 -16.0766 -- 5.00 1.00 43.3859 -- AIR - --  0.0800
- - - - - -- 0.0800
8 _ _ _ _ - _ - _
FRINGE WAVELENGTH:  0.546070

Fringes measured over clear aperture of surface unless indicated.
Tilt tolerances are specified in degrees.

® From the Lens menu header select Show tolerance data > Component.

® All values in this table should be zero.

Asymmetric tolerances surface calculation
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ISO 10110 component drawing

The middle element of the triplet objective will be used to demonstrate this facility.

Setting element drawing defaults

e From the menu header select Lens > Lens Drawing > Element drawing
conditions or type the command: edd

e Sect RMS surface roughness for ground edges R, = 2 (microns) medium.
e Sect RMS surface roughness R, =2nm (medium)

® Set Surface polishing grade to P3.

® Sect Coating blemishes to 1 Grade 0.4. (MIL 80-50 equivalent)

® SectLong scratches to 1 Width 0.008 mm (MIL 80-50 equivalent)

® Sect Edge chips: Maximum extent from edge to 1 mm.

® Define Coating specification as Single layer MgF2 550 nm.

EE8 Element Drawing Conditions

o
x [Single Tayer MgF2 at 550 nm =]

Rms Surface Roughness for Ground Edges (microns)

sampling Length for Edge Roughness (mm): Low Limit [ 0 High Limit [ 0
surface Polishing Grade Rms surface Roughness - Rq (nm)
sampling Length for Rq (microns): Low Limit [ 0 High Limit [ 0

RMS Residual surface Deviations (3/):
RMSt = Total rms deviation, RMSi = Rms irregularity, RMSa = Rms asymmetry

RUST < RMST < RUSa <
surface Imperfection Tolerances (5/):
Coating Blemishes Number Grade
Long Scratches Number Max width (mm)
Edge Chips Maximum Extent From Ecge (mm)
surface Treatment/Coating Specification [STngTe Tayer MgrF2 at 550 nm_ |

Laser Irradiation Damage Threshold (6/) [ |

® (Close the spreadsheet.

Setting element material properties

® From the menu header select Lens > Lens Drawing > Element
® For Left surface of element select 3
® Fillin:

e PartLens 2 [date]

e Drawing title 50 mm /5.6

e Diameter 11 mm +0.2/-0.2

ISO 10110 component drawing
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e Stress birefringence (0/): 20
e Bubbles and inclusions (1/) Number 1 Grade 0.4

e Striae Class 4.

EE Element Drawing Data

o

| =]

?

Element Surfaces 3 - 4 Thickness (mm) 1.500000 +/- 0.100000
Material is Schott F4 n d 1.616592 +/- 0.000000 Part [Lens 2

Drawing Title 50 _mm 7/5.6 | Datum Axis
Diameter (mm) [ 11.000000] + [ 0.2000000 - [ 0.200000

Rms Surface Roughness for Ground Edges (microns)

sampling Length for Edge Roughness (mm): Low Limit[ 0 High Limit [ 0
Stress Birefringence (nm per cm of opt. path) (0/):

Bubbles and Inclusions (1/): Number Grade
Inhomogeneity and Striae (2/): Inhomogeneity Class Striae Class

Setting element surface properties
® C(Click on Edit left surface.

® [ eave most entries unchanged but fill in:
e Surface imperfections Number 1 Grade 0.4
® C(Click on the green tick to close the spreadsheet.
® (Click on Edit right surface.
® Again fill in:
e Surface imperfections Number 1 Grade 0.4

Click on the green tick twice and the drawing appears.

EE Element Surface Data < Element Drawing Data

of

x [ =~
7

surface 4 Element dimensions are in mm.
Radius 18.438800 cCc +/- 0.000000 centring Tol. {(minutes) (4/) 4.800000
optically Eff. Diameter 8.000000 Prot. Chamfer [ 0.100000 --= [ 0.300000
surface Polishing Grade Rms surface Roughness - rq (nm)
sampling Length for Rg (microns): Low Limit [ 0 High vimit [0

surface Form Deviations - 3/A(B/C):

A = 5agitta error, B = Irregularity, C = Rotationally symmetric irregularity

A (fringes) 5. 000000 B (fringes) 1. 000000 ¢ (fringes)
RMS Residual surface peviations (3/):

RMST = Total rms deviation, RMSi = Rms irregularity, RMSa = Rms asymmetry

RMST < RMST < RMSa <
surface Imperfection Tolerances (5/):

surface Imperfections Number Grade

coating Blemishes Number [ 1] Grade

Long Scratches Number Max width (mm)

Edge chips Maximum Extent From Edge (mm)
surface Treatment/Coating specification [EingTe Tayer MgfF2 550nm |

Laser Irradiation Damage Threshold (&/) [ |

ISO 10110 component drawing
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Element drawing
The message appears in the message area:

Element drawing is best viewed in a “portrait window” format.

G
2
N N
e
6N
N o
ko) [de) bt
IS T o T =S :
N
M
o
o N
1.520.1
Left Surface Material Specification: Right Surface:
R 18.4388 CC Schott F4 R 18.4388 CC
ge 8.0 nd 1.616592+0.0006 e 8.0
Prot. Cham. 0.1 - 0.5 v d 36.630.8% Prot. Cham. 0.1 - 0.3
» Single layer MgF2 550nn0/ 20 » Single layer MgF2 550n
3/ 5(1) 1; x0.4 3/ 5(1)
4/ 4.8 2/ 14 4/ 4.8'
5/ 1x0.4;, C 1x0.4; 5/ 1x0.4, C 1x0.4,
L 1x0.008, E 1.0 L 1x0.008; E 1.0
6/ - 6/ -
50 mm /5.6 your _company_name
your_street_name
Lens 2 Ldatel] Ind. acc. ISO 10110 your _town

ISO 10110 component drawing
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Appendix 1 - Index of lens data commands

This table gives an alphabetic listing of the principal commands used in lens data input,

together with the page numbers in the OSLO Program Reference Issue 6.3 (Autumn 2004
edition). The letter in the second column is the label shown on the gray button in the
surface data spreadsheet when the relevant parameter is set. Note that not all of these
commands are available in OSLO-EDU.

Command
ach

ad

ae

af

afo

ag

air

al

alc

amo

ang

ap

apck

apn

ary

as0, asl, etc.
asi

ast
asp
ben
bry
cak
cal
cam
cc
cfg
cns
csd
cslv
ctf
cv
cvX
dcx
dcy
dcz
del

des
dlid,dlIfd,dIha,dlva,
difs,dlls,dlap,dlrs,
dinr etc

doe

O>» » T > TX > > > > T

> W W w

—

Oo0o0 >

Explanation
array chan
aspheric
aspheric
aspheric
afocal mode
aspheric
medium
aplanatic slv
aplanatic slv
abn mode
field angle
aperture

ap checking
special ap
lens array
aspheric

alt srf intersec
aperture stop

aspheric

tilt & bend
birefringent
crystal axis
crystal axis
crystal axis
conic const
oonfiguration
cone

slv delete
slv in alt cfgs
test glass cv
curvature
toric
decentre
decentre
decentre

sif delete
desgr name

lens and ray
drawing  con-
trol

diffractive

Page
65
73
73
73

117
73
53
42
42

118

122
49

117
50
64
75

62
27,

73
68
57
57
57
57
72
20
79
41
118
45
40
72
67
67
67
32

118
228
to
245

85

drw

ebr
ec
eik
end
epxy
esd
fno
frn
gc
gcs
gdt
gih
gla
gor
grd
arp
gsp
hor
idd
ims
ins
itf
inv
jsd
kco
kdp
ldp
len
lid
Ime
Imo
Ise
mco
mer

merge_catalog
nac

nao

nap

GoOoom m

O

M O O N

srf drawing
ent beam rad

edge slv
eikonal srf
end data

ray aiming
eikonal del

F number
Fresnel

global coord
glob ref srf
gradient index
image height
medium
grating order
gradium
group

grating spc
hologram order
zernike

image srf

srf insert
interferogram
srf invert
polarisation
kinoform order
kinoform depth
srf dwg pen
begin data
lens identifier
module end
module begin
spreadsheet
coating

insert lens

insert catalog
lens
non-sequential

obj space NA

im space NA

63
28,
121

a7
108

119
108
121
62
69
118
97
122
54
85
100
34
85
86
91
27
32
112
33
107
89
89
64

20
35
35
17
105
40

37

109
28,
127
28,
121

Graphics reference
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not N surface note 61 ung ungroup 36
nxt next srf uni units 117
object height 28, usd U usersag 110
obh _ 122 user trace 95,
opdw OPD inwaves 118 usr U 110
pfi L perfectlens 70 utp p  user pickup 47
pfm L perfectlens 70 wod G Wood lens 99
pi S margray solve 41 wrsp ref sph posn 117
pic S chief ray solve 42 wavelengths 26,
P pickup 44, wvl... 124
47, spectral wts 26,
pk 54 wwl... _ 124
pre Sys pressure 120 zoe A Zern!ke 80
ou S cvsolve 41 zrr A Zemike 91
puc S cvsolve 42 zrx A Zemike 91
puk S axrayang 121 zZrxr A  Zerike axis 118
py S thsolve 46
pyc S thsolve 46
polarization ray 56,
pzrt trace 120
raim ray aiming 117
rco C coord return 68
rd radius 40
rdt T testglass rd 45
rev srf reverse 33
rfh refl & hatch 53
rfl reflection 53
rfs R refsrf 50
rod F  extrude 63
rtf T testglass fit 45
sasd astig distance 120
scf setup cfg 21
scl scale srfs 40
sdad ap divisions 123
sdaz apodisation 123
diffraction
sdde efficiency 120
sdis im space spd 120
skp F skip 62
sle scale lens 40
snol, sno2, etc... system notes 126
spl S spline 82
F thermal expans
tce coefficient 120
tem sys temp 120
th thickness 46
tir F tir srf 63
tla C tiltangle 67
tlb C tiltangle 67
tic c tiltangle 67
tox c tilt offset 67
toy c filt offset 67
toz c filt offset
ucp p  user pickup 44

Index of lens data commands



In this table, S refers to solves, C refers to tilt/decenter coordinates, and A refers to aspheric
surfaces. Other letters are the flags used in the spreadsheet. A complete listing of the lens
data commands is on pages 508 - 514 of the OSLO Program Reference. These commands
may be used:

1. In the command window, explicitly, as part of an update process:

len upd
gto 2
nxt
th 1.0
end
Note the use of gTO, NXT, end. A semicolon has the same effect as
nxt.
2. As part of a CCL command:
{
len upd;
gto(3);
th(1.0);
end;
+
Note the semicolons at the end of each line.
3. In the command window, as a self-contained command:
th 3 1.0
This is called “global editing”
4. As part of a lens file:

. Lens: DEMO TRIPLET zoom 1 of 1 Efl  50.000541
TH 1 - O Ent beam radius 6.250000 Field angle 20.000000 Primary wavin 0.587560
SRE RADIUS THICKNESS APERTURE RADIUS GLASS SPECIAL
5. Im hCltl when the S read_ 0B1 0.000000 ] 1.0000e+20 ] 3.6397e+13 am[] [
. p y’ p 21.z2s0000 ] z.ooo000 ] 6.500000 SK16 1
sheet is updated, as shown here. -15s.650000 ] 6.000000 ]  6.500000 £ ] P o |
-20.250000 ] 000000 | I R E4 1
19.300000 ] &.000000[ ]  5.000000 am[] [
[ 5] 141250000 ] z.oooooo[ | e.sooooo [ | SKi6 1
21 4> spennnl 1 43 sennnnl™ 1 £ connnn || ate [ —

121
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Alphabetical index

KEY TO COMMAND REFERENCE (in order of preference)

Standard tools

Tools > Special

Accessed via main window menu headers

Accessed via graphics window toolbar using the icon shown
ACVERQIEOEWSIE ~ Accessed via main window toolbar using the icon shown

grindex CCL command accessed via the command line

Function Command Reference Icon ‘21];31 Grid
2D-waveguide coupling Tools > Special > 2D - F. | e10
Astigmatism - S & T over field Evaluate > Ray Fans - dil
Axial chromatic focal shift Ray Analysis H—' h2
CCL example - 4 graphs Tools > Plotting - h9
CCL example - contour Tools > Plotting - b10
CCL example - map Tools > Plotting - cl0
CCL example - pen colours Tools > Plotting - d10
CCL example - XY graph Tools > Plotting - d10
Distortion grid plot Ray Analysis E b3
Distortion at all wavelengths Evaluate > Ray Fans - ell
Doublet - slider-wheel design Tools > Demos - hi-
Draw system 2D Lens Drawing E al
Draw system 2D Standard tools E al
Draw system 3D shaded solid Lens Drawing ,&' dl
Draw system 3D solid Lens Drawing ﬁ cl
Draw system 3D variable view Lens Drawing _@’5 el
Draw system 3D wire-frame Lens Drawing ﬁ bl
Draw system 3D wire-frame Standard tools ,&' bl
Draw system - conditions Lens Drawing Eﬁ; --
Draw system - zoom lens Lens Drawing % S hl
Element drawing Lens Drawing EE; a2
Encircled energy - diffraction Energy @ b7
Encircled energy - geometrical Energy l:] e’
Ensquared energy - diffraction Energy B c’
Ensquared energy - geometrical Energy |:| f7
Extended source image D e9
Footprint - one field point Spot Diagram ﬁ‘ e4
Footprint profile - all field points Spot Diagram .:;’j f4
Gaussian beam movie Tools > Demos - g10

122
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Ghost image movie Spot Diagram L g4
Glass catalogue n-V map Lens >Glass Catalog - a9
GRIN lens - slider-wheel design Tools > Demos - Li | b1l
GRIN axial index grindex - -
Internal transmittance of glass internal_trans - -
Incidence angle statistics langstat - hll
Lateral chromatic aberration Ray analysis I— a3
Lateral colour (pri & sec) Evaluate >Ray Fans - -
Longitudinal aberration Evaluate >Ray Fans - cl1i
LSF/KED - diffraction calc Energy A d7
LSF/KED - geometrical calc Energy i g7
MTF over field - 3 frequencies MTF =2 dé
MTF - one field point MTF L ab
MTF square wave - 1 field point MTF |_n €6
MTF - thru frequency report MTF h5
MTF - thru frequency report Standard tools h5
MTF and spot size thru focus MTF L 6
MTF FFT one field point MTF LT | P. | b6
MTF thru focus - one field point MTF [ h6
MTF thru focus across field MTF 2 a7
MTF thru focus report MTF 4 g6
MTF thru focus report Standard tools *E* g6
OPD - 2D field points Ray Analysis E'SE 24 g2
OPD - one field point Ray Analysis B I = f2
OPD contour - one field point Wavefront i._:_f 3
OPD interferogram Wavefront - f g3
OPD map - 2D field points Wavefront gE:D 24 d3
OPD map - one field point Wavefront : e3
OPD map/contour report Wavefront zz c3
OPD map/contour report Standard tools EE c3
OPD report Ray Analysis h'!" e2
Optimization ray set Spot Diagram l@ S h4
Partial coherence - bar image 'dL_ g9
Photometric plot ridemo - f11
Pixellated image f9
Polarisation map Polarization :% R b8
PSF - 2D contour lines Evaluate > Spread fn - F. | b9
PSF - 2D field points PSF =% b5
PSF - contour PSF i? ch
PSF - FFT - contour PSF 7] e5
PSF - FFT - one field point PSF B 5

Graphics reference
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PSF - one field point PSF ﬂ ds5
PSF - section PSF g5
PSF report PSF ] a5
PSF report Standard tools - ab
PTF - thru frequency MTF bars c6
Public lens database File> Lens Database - h8
Ray analysis - 2D field points Ray Analysis 3'5; 24 dz2
Ray analysis - one field point Ray Analysis —I < c2
Ray analysis report Ray Analysis % b2
Ray analysis report Standard tools %é b2
Ray analysis SIGMA format repsig - gl1
Ray bundles 2D Lens Drawing a¥ fl
Ray bundles 3D Lens Drawing % gl
Ray bundles movie Ffieldscan - 5 hi
RMS spot size & RMS OPD Spot Diagram |_ d4
Seidel aberration demo Tools > Demos > Seidel - 10
Slider-wheel design i} c9
Spot diagram - 2D field points Spot Diagram “3"[‘3 Sy a4
Spot diagram - one field point Spot Diagram b4
Spot diagram - recipolar Spot Diagram c4
Spot diagram report Spot Diagram @ h3
Spot diagram report Standard tools @ h3
Surface reflected phase Polarization —3'| P. f8
Surface reflectivity Polarization _m Em ds
Surface transmission Polarization ﬂ Em e8
Surface transmitted phase Polarization - Em g8
Thin film uniformity Polarization = Em c8
Tolerances - Monte Carlo =F | Fn --
Triplet - slider-wheel design Tools > Demos > Triplet - all
y-ybar diagram Optimize > Support - do
Zoom lens drawing Lens Drawing TR
Zoom lens drawing Zoom % = 5:4 hi
Zoom lens report Zoom Zz. 5{4 a8

Tabular graphics command reference

See below.

Graphics reference



dril;ddr drl wir;ddr drl sol;ddr drl shs;ddr drlrot sol lensdraw 32 lensdraw 32 fieldscan
Standard Tools Standard Tools Standard Tools Standard Tools plan 1.0 oblique 1.0
Lens Drawing Lens Drawing Lens Drawing Lens Drawing Lens Drawing Lens Drawing Lens Drawing 1
Lens>Lens Drawing Lens>Lens Drawing Lens>Lens Drawing Lens>Lens Drawing Tools>Demos>Rays Tools>Demos>Rays
dre rpt_ric ray plr ric2d_ray rpt_ric opd plo ric2d opd chrshft
Standard Tools
Lens Drawing REVZAMEWNE Ray Analysis| Ray Analysis| Ray Analysi Ray Analysis| Ray Analysis| Ray Analysi 2
Lens>Lens Drawing Evaluate>Other Ray Evaluate>Ray Fans Evaluate>Ray Fans Evaluate>Other Ray Evaluate>Ray Fans Evaluate>Ray Fans Evaluate>Other Ray
latshft distplt rpt_wvf pwf2D pwf map pwf con pwf int rpt_spd
Ray Analysis Ray Analysis Spot Diagram K
Evaluate>Other Ray Evaluate>Other Ray Evaluate>Wavefront Evaluate>Wavefront Evaluate>Wavefront Evaluate>Wavefront Evaluate>Wavefront Evaluate>Spot Diag
spdad pls recipolar spsopd footprt footpro ghosts mov grst
Spot Diagram Spot Diagram| Spot Diagram Spot Diagram Spot Diagram Spot Diagram Spot Diagram Spot Diagram 4
Evaluate>Spot Diag Evaluate>Spot Diag Evaluate>Spot Diag Evaluate>Spot Diag Optimize>Support Optimize>Support Optimize>Support Lens>Show Optim
rpt_psf psft2d sprd con sprd map sprd con sprd map pss chr rpt_tfr
0.1 dir 0.1 dir 0.1 fft 0.1 fft Standard Tools 5
PSH PSF PSF PSH PSH PSF PSF MTF
Evaluate>Spread Fn Evaluate>Spread Fn Evaluate>Spread Fn Evaluate>Spread Fn Evaluate>Spread Fn Evaluate>Spread Fn Evaluate>Spread Fn Evaluate>TransferFn
pIm tfr remtef mtfandptf mtf_fid squaremtf sl_otfspd rpt_tfo plm tfo
MTH MTH e |°
Evaluate>TransferFn Evaluate>TransferFn | Evaluate>TransferFn | Evaluate>TransferFn Evaluate>TransferFn Evaluate>TransferFn Evaluate>TransferFn
fcurv prqg chr psq chr pdl bth ple geo ped pgl bth zdrl
MTH SEFNEWSE Energy Analysis| Energy Analysis Energy Analysis| Energy Analysis| Energy Analysi Zoom !
Evaluate>TransferFn Evaluate>Energy Dis | Evaluate>Energy Dis | Evaluate>Energy Dis Evaluate>Energy Dis Evaluate>Energy Dis Evaluate>Energy Dis Lens>Lens Drawing
zrpt polstate thunf surfprop rfl surfprop tns surfprop phr surfprop pht dblib_open
Polarization 8
Evaluate>Pol Evaluate>Pol Evaluate>Pol Evaluate>Pol Evaluate>Pol Evaluate>Pol File>Lens Database
open cdb pub pgq chr 64; sliderwheel yybar source xsource ppi mon gplot_Kkit
o sfg xy chr _design “3barh.ima” _sample
"glass_...cdb"; ?
Lens>Glass Catalogs Evaluate>Spread Fn Optimize>SliderwW Optimize>Support Source>View extnd Source>Pixellated Source>Partial Coh. Tools>Plotting TKit
gplot_sample gplot2d fill_contour colors wvra sl_3rd show_movie sl_doublet 10
Tools> _sample _sample Tools> Tools>Special>2D gbmovie fab
Plotting Toolkit Tools>Plotting TKit Tools>Plotting TKit Plotting Toolkit waveguide Tools>Demos>Seidel | Tools>Demos>Gauss Tools>Demos>Doub
sl_trp gradium demo pla chr plf chr pld chr ridemo repsig iangstat 1
Tools>Demos>Triplet Tools>Demos>Grad Evaluate>Ray Fans Evaluate>Ray Fans Evaluate>Ray Fans
a b c d e f g h
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Tabular graphics index

Draw system 2D Draw system 3D Draw system 3D Draw system 3D Draw system Ray fans 2D Ray fans 3D for Ray fans movi
YZ wire-frame solid shaded solid variable view for vignetting vignetting
Element drawing | Ray analysis report | Ray analysis - one Ray analysis - OPD report OPD - OPD Axial chromat;
ISO 10110 field point* 2D field points 1 field point* 2D field points focal shift
Lateral chromatic | Distortion grid plot | OPD map/contour OPD map -2D | OPD map - 1 field | OPD contour - 1 OPD Spot diagram
aberration pt field points point* field point* interferogram report
Spot diagram - Spot diagram - Spot diagram - RMS spot size & | Footprint of beam - | Footprint profiles - | Ghost image movie | Optimisation rz
2D field points 1 field point* recipolar OPD over field 1 field point all field points patterns
Point spread PSF - PSF - contour  [PSF map - one field| PSF contour (FFT PSF map PSF MTF
function report 2D field points point calc)r (FFT calc) section thru frequency
MTF - 1 field MTF 1 field point Phase - thru MTF over field - 3 MTF - square MTF & spot size | MTF through focus | MTF through fo
point* (FFT calc)* frequency* frequencies wave 1 field pt* through focus report 1 field pt*
MTF thru focus Encircled energy Ensquared en. LSF & KED Encircled energy Ensquared en. LSF & KED Zoom lens draw
across field (diffraction calc) (diffraction calc) (diffraction calc) | (geometrical calc) | (geometrical calc) | (geometrical calc)
Zoom lens Polarisation map Thin film Surface reflectivity Surface Surface Surface Public lens
report uniformity transmission reflected phase transmitted phase database
Glass catalogue - PSF Slider wheel design| y-ybar diagram Extended source Pixellated image | Partial coherence - CCL example
n-V map 2D contour lines image bar image 4 graphs
CCL example - CCL example - CCL example - CCL example - 2D-waveguide Seidel aberration Gaussian beam Doublet slide:
XY graph contour map pen colours coupling demo movie wheel design
Triplet slider wheel | GRIN lens slider Longitudinal Astigmatism - S & Distortion Photometric plot Ray analysis Incidence angl
design wheel design aberration T over field at 3 wavelengths SIGMA format statistics
a b c d e f g h
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The 88 examples of OSLO graphics shown in the table below represent almost the full range of graphics output available to users of OSLO Premium
version. Brief descriptions of each graphic example are given above. The routes for accessing these graphics are listed in the tabular command reference
with the following format:

OSLO commands These are given in short form only. They can be typed as shown, and they are also useful as an index to the HELP
facility.
These refer to the groups of icons called up from the top left corner of any graphics window
These refer to the groups of icons called up from the top left corner of the main window.
Evaluate>Spread Fn These show how most of the graphs can be created from menu headers.

* Graphs indicated are for one field point only, and they can give results only on axis if accessed via the icons. To plot individual graphs for other field
points, either issue the set object point command and then use the command line (for example sop 1 0 O;plr), or work through the menu headers.

Graphics reference
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Graphics reference examples

Graphics reference
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