Mathcad Tutorial
by Prof. Bern Kohler, The Ohio State University
modified by Prof. D.S. Hamilton, University of Connecticut

The goal of this tutorial is to help you to perform basic tasks using Mathcad as quickly as possible. The text below describes some of the most commonly used features of the program—the ones you are most likely to use in your work for Physics 258 and beyond. While you can learn a great deal about Mathcad just by reading the contents of this file, you will find that nothing beats working with the program yourself. This tutorial is a "live" Mathcad worksheet that encourages you to interact with the Mathcad program, so don't just print the contents of this file. Instead, you should read through this worksheet, taking time to try the tasks printed in **bold text**. Don't be afraid to experiment!

Mathcad can do much more than is described in this simple tutorial. To learn more, consult the program's help files (help menu) or copies of the printed manual (available in the 258 lab). In particular, try the "Resource Center", which is accessible from the Help menu.

Mathcad creates worksheets that consist of text regions and math regions.

My Lab Report

The text on the left is a "text region". This comment is also a text region.

3 + 4 = 7

The simple equation on the left is a "math region"

Text regions

The text you are now reading is part of a text region. With time it should be easy for you to distinguish math regions from text regions. Text regions are most often used to add comments to worksheets, making it simpler to follow the calculations. You select a text region by left-clicking it with the mouse. Once a text region is selected, a box with square handles will appear. Moving the mouse over one of these handles changes the cursor to an arrow, indicating that you can resize the box. Moving the mouse to any edge of the box around a text region will change the cursor to a hand, indicating that you can click and drag the text box to a new location.

Use the mouse to select the text region above and resize it so it is no wider than the horizontal line above "Text regions".

↓ The dashed, horizontal line below indicates a page break. ↓

NOTE: Page breaks only affect printing
To create a text region, click the mouse on a blank part of a worksheet. Select "Text Region" from the Insert menu --or-- simply type the double quote character ("), on the keyboard and then begin typing the text you want to enter.

The text in a text region can be edited much like the text in a word processor. Note the vertical red cursor in a selected region which indicates where text you type will be inserted. You can change the font, font size, font color and style using buttons on the toolbars or by selecting commands in the Format menu.

Remove the bold formatting from the text in this sentence.

The solid, vertical line at right → indicates the right margin. The width of the margins can be adjusted using "Page Setup" in the File menu.

You can also enter Greek letter either by using the "Greek" pallet (View-Toolbars-Greek) or if you place the insertion point directly to the right of the letter you want to turn into a Greek letter and then type <ctrl>G, the letter turns into its Greek equivalent. The keysequence <ctrl>G toggles between Greek and roman letters. (If you place the insertion point directly to the right of a Greek letter and press <ctrl>G, the Greek letter will turn back into an equivalent roman letter.) Thus a p turns into a π, a d turns into a δ, and a D becomes a Δ.

Type in below the fist three letters of the Greek alphabet (alpha, beta, and gamma)

There is a text region "hidden" off the right edge of the paper. Scroll the window horizontally so you can find it, then move it between the horizontal lines below:

__________________________________
__________________________________
Math regions

Of course, the most powerful features of Mathcad have to do with math regions. The rest of this tutorial will concentrate on these features.

Mathcad is a WYSIWYG (what-you-see-is-what-you-get) word processor for mathematics.

The following math regions are examples of simple formulas evaluated by Mathcad.

\[ 2 \cdot (3 + 4) = 14 \quad \text{Type: } 2 \cdot (3+4)= \]

\[ 2.3^4 = 27.984 \quad \text{Type: } 2.3^4= \]

\[ \frac{\sqrt{25}}{4 + 1} = 1 \quad \text{Type: } \sqrt{25}/(4+1)= \]

\[ \frac{\exp(2)}{4} + 1 = 2.847 \quad \text{Type: } \exp(2)/4+1= \]

\[ \cos\left(\frac{\pi}{4}\right)^2 = 0.5 \quad \text{Type: } \cos(<\text{ctrl}>G/4)^2= \]

The math regions in a Mathcad document are "live", meaning that they are recomputed as information for any calculation is changed.

To see this, change the "4" in the first expression above to a "2" by clicking and editing. Mathcad automatically recomputes the new result when you hit "enter" or click the mouse anywhere else on the page. Note that editing mathematical expressions is a bit different than editing text, and requires some getting used to. See the on-line help (Help menu) for more information about editing math regions.

Replace 4 everywhere in the above expressions by 2, and observe how the results change.

Another way to enter mathematical expressions is to use the "Calculator palette". Bring up this palette by clicking on the blue calculator icon on the "Math" toolbar.

You will next enter a simple math expression. Click anywhere in the white space below this line, then follow the instructions in the next paragraph.
**Instructions.** Numbers can be entered by clicking on the appropriate buttons on the arithmetic palette (blue calculator icon on tool bar), but it's simplest to use the keyboard to enter them directly. Type 2. The red cross cursor disappears, and a box is displayed containing the number 2. A blue line is visible immediately to the right of the 2. This line is the insertion line for math expressions. Note also that the 2 is underlined by a blue line. A useful rule to remember is that the underlined expression to the left of the insertion line is used as the operand of the next operator you type. An operator can be something like '+', or '-', or exponentiation. Now type '+' (or click on the plus sign in the arithmetic palette), followed by a '3'. Now click on the multiplication symbol in the palette (or type an asterisk '*'). Type '5', then press the equals button on the palette or type ‘=”.

If you followed the above instructions, your result should look like this:

\[ 2 + 3 \cdot 5 = 17 \]

**In the space below type the following sequence of keys:** 2+3<space>*5=

[NOTE: <space> means to type the space bar once.

Typing a space "extends the selection", underlining all of 2+3. Thus, 2+3 became the operand for the next operator (multiplication) that you typed. Note how Mathcad automatically added parentheses to indicate that the result of 2+3 is to be multiplied by 5. Using the space bar in this way is a very useful skill that requires a little practice.

**Variables**

Mathcad can compute with variables that you define and modify. Recall above how you changed all occurrences of "4" to "2" in the three expressions. Whenever you frequently modify input values it may be more convenient to use variables. Like this:

\[ a := 2 \]

This line defines the value of variable "a".

\[ 2(3 + a) = 10 \]

This line and the following two math regions perform computations using the variable "a".

\[ \frac{\sqrt{25}}{(4 + a)} = 0.833 \]

\[ \cos \left( \frac{\pi}{a} \right)^2 = 0 \]
The Lorentz factor “gamma” (entered the $\gamma$ from the GREEK toolbar) $\gamma = \gamma_1 v^2 + c^2 = \frac{1}{\sqrt{1 - \frac{v^2}{c^2}}}$.

Type “3*10^8” to enter the numerical value for the speed of light.

Consider a relativistic electron moving with a velocity of 0.25 c in a magnetic field of 1T. What is the radius of curvature of its circular path?

The following example should make this more clear:

```
myvar_1 := 10  Assignment statement. Note that variable names can use a variety of characters. See program help for exact naming rules.
var := 4  A second variable assignment
var + myvar_1 = 14  Mathcad displays the result of adding the two variables.
var = 4  Display the value of "var".
var := 17  Now change the value of var
var + myvar_1 = 27  New result!
```

Here is a calculation that should start to give you a feeling for the power of a "math word processor" like Mathcad:

Consider a relativistic electron moving with a velocity of 0.25 c in a magnetic field of 1T. What is the radius of curvature of its circular path?:

```
c := 3-10^8  Type "3*10^8" to enter the numerical value for the speed of light.
v := .25*c
\gamma := \frac{1}{\sqrt{1 - \frac{v^2}{c^2}}}  The Lorentz factor "gamma" (entered the $\gamma$ from the GREEK toolbar)
\gamma = 1.033
```
Display the results. This was done by typing \( \text{array2} = \)

Multiply the elements in array1 by two, and store the results in a new array.

To create an array (vector) variable:

Select "Matrix..." from the Insert menu. An array (or vector) with \( n \) elements is just a matrix with \( n \) rows and 1 column. Fill in the values you need in the dialog box and click OK. Try creating an array named array1 with 3 elements (3 rows, 1 column). Enter the values 5, 10, and 15 in the placeholder boxes. You can move between the placeholders using the "Tab" key. The correct result is shown below.

\[
\text{array1} := \begin{pmatrix} 5 \\ 10 \\ 15 \end{pmatrix}
\]

With Mathcad you can easily perform math on vectors.

\[
\text{array2} := 2 \cdot \text{array1}
\]

Display the results. This was done by typing \( \text{array2} = \)

Note about displaying very small numbers. Mathcad displays very small numbers as "0" when they are less than a "zero tolerance". Any number greater than or equal to \( 10^{-Z} \) will be displayed, where \( Z \) is the zero tolerance (set using the Tolerance Tab accessed from the Format->Result menu). Otherwise, the number will be displayed as zero. You should change the zero tolerance to an appropriate value, if you wish to view the magnitude of a very small number.

**Working with arrays**

For many experiments it is simplest to work with data in arrays. This is often the case when multiple measurements or readings are recorded in an experiment. Mathcad has a variety of tools for working with arrays and matrices.

**How to create an array (vector) variable**

Select "Matrix..." from the Insert menu. An array (or vector) with \( n \) elements is just a matrix with \( n \) rows and 1 column. Fill in the values you need in the dialog box and click OK. Try creating an array named array1 with 3 elements (3 rows, 1 column). Enter the values 5, 10, and 15 in the placeholder boxes. You can move between the placeholders using the "Tab" key. The correct result is shown below.

\[
\text{array1} := \begin{pmatrix} 5 \\ 10 \\ 15 \end{pmatrix}
\]

With Mathcad you can easily perform math on vectors.

\[
\text{array2} := 2 \cdot \text{array1}
\]

Display the results. This was done by typing \( \text{array2} = \)

---

e := 1.602 \cdot 10^{-19} \quad m := 9.11 \cdot 10^{-31} \quad \text{electron charge and mass}

B := 1 \quad \text{magnetic field}

\[
\text{Radius} := \frac{m \cdot \gamma \cdot \nu}{e \cdot B}
\]

Mathcad calculates the radius (in meters). By changing the values of "\( B \)" or "\( \nu \)" above, you can perform additional calculations easily.

\[
\text{Radius} = 4.405 \times 10^{-4}
\]

Finally, note that variable names are case-sensitive. Thus,

\[
\text{radius} = 1 \quad \text{"radius" refers to a different (undefined) variable}
\]

Note about displaying very small numbers. Mathcad displays very small numbers as "0" when they are less than a "zero tolerance". Any number greater than or equal to \( 10^{-Z} \) will be displayed, where \( Z \) is the zero tolerance (set using the Tolerance Tab accessed from the Format->Result menu). Otherwise, the number will be displayed as zero. You should change the zero tolerance to an appropriate value, if you wish to view the magnitude of a very small number.
You can also refer to individual elements of an array. This is done by subscripting.

\[
\text{array2}_0 = 10 \quad \text{The first element of array2 is equal to 10. Note that the index of the first element is 0 and not 1. This is because arrays in Mathcad are numbered 0,1,2,... Such arrays are called "zero-based".}
\]

To enter the above expression you type: \text{array2[0=}

The left bracket "[" is used to enter an array subscript.

Try to display the other elements of array2.

What happens when you try to display element 17 of array2? Click below to read the error message.

\[
\text{array2}_{17} =
\]

Reading data from a file into an array

The simplest method is to use the clipboard. Open the data file using a simple Windows utility program like "notepad" or "wordpad". Cut the data to the clipboard, then type your array name, type the assignment operator, then paste the data from the clipboard (Edit menu, or control-v). This creates a new vector using the data you cut from the file. This cut/paste method can also be used to create arrays or matrices from columns in Excel worksheets.

\[
x := \begin{pmatrix}
3 \\
5.2 \\
15 \\
17.9 \\
\end{pmatrix}
\]

This vector was created by pasting data from the clipboard.

Provided the columns are separated by tabs, then you can use this method to create matrices.

\[
data := \begin{pmatrix}
1 & 2 \\
2 & 5 \\
3 & 10 \\
4 & 17 \\
\end{pmatrix}
\]

Contents of a two column data file were cut to the clipboard and then pasted to create this two column matrix.

This will frequently be useful for dealing with x,y datafiles. You will frequently want to manipulate the columns separately. Assuming the first column represents the x values, and the second column contains y values, then we might do the following:

\[
x := \text{data (0)}
\]

To get the result on the left type \text{x: data<ctrl-6>0}

NOTE: \text{<ctrl-6>} means to hold the control key and press 6 at the same time. Alternatively, you can select matrix column from the "Vector and Matrix Palette".

\[
y := \text{data (1)}
\]

Assign the second column of the matrix "data" to the vector y.
Try displaying the values of the vectors \( x \) and \( y \) to make sure you understand what is going on.

An alternative method for reading in data from a file is to use the Mathcad function "READPRN". An example is shown below. Note the full path name is given of the data file to read.

\[
\text{my\_matrix} := \text{READPRN}"c:\temp\myfile.dat"
\]

You will see an error message if Mathcad can't find the given filename.

While this method is slightly more complicated, it has the advantage that you don't have to cut/paste each time the data in the file changes.

Create a simple two column data file in a directory on your computer. Modify the pathname above to point to the file, push F9 to recalculate the worksheet (this insures that Mathcad reads the file), then display the values of \( \text{my\_matrix} \).

### Making Graphs

A frequent task in Physics 258 is making graphs to display your results. While Mathcad can generate a large number of 2D and 3D graphs, the only one you need to learn is the "X-Y Plot". Select graph->X-Y plot from the Insert menu, or simply click on empty space and type the "@" character. When you do you will see an empty template like the one below. Try it.

![Graph Template](image)

The placeholder on the bottom, horizontal axis is used to specify a vector of \( x \) values to plot. The placeholder on the left axis is used to specify an equal length vector of \( y \) values. An example should make this clearer. First let's define
First we create some x values.

\[
xvals := \begin{pmatrix} 1 \\ 2 \\ 3 \\ 4 \end{pmatrix}
\]

We can use this expression to generate an equal length array of y values.

\[
yvals := 2 \cdot xvals + 1
\]

Now we have a set of (x,y) pairs, suitable for graphing.

\[
yvals = \begin{pmatrix} 3 \\ 5 \\ 7 \\ 9 \end{pmatrix}
\]

Display the resulting vector

Now generate the graph.... We type "@" in whitespace below and then fill in the placeholders with our two arrays:

```
1 2 3 4
4
6
8
10
```

Voila. Mathcad graphs the result—a simple straight line.

Try double-clicking the graph above to bring up menus that allow you to change the trace appearance, add a title, label the axes etc. Can you make the graph above look like the one at right? HINT: Check "hide arguments" to hide the names of the mathcad variables and show only the axis labels.

Finally note that graphs can be resized much like text regions. Try increasing the size of these graphs.
That completes the tutorial. Hopefully you found this a useful way to quickly learn some of the basic features of Mathcad.

To learn about some more advanced features, see the appendix below.

**Appendix**

A.1 Other features
Mathcad can do much more than can be described in this short tutorial. Consult the help files for more information. To whet your appetite, here are a few examples of some of these features with pointers to relevant documentation.

1. You can define your own functions: see "functions, user-defined" in the help index

\[
\text{sqr}(x) := x^2 \\
\text{sqr}(2) = 4 \\
\text{sqr}(10) = 100
\]

\[
f(t) := 10 \cdot \exp \left( -\frac{t}{100} \right) \\
f(50) = 6.065 \\
f(\text{sqr}(10)) = 3.679
\]

2. Mathcad can compute with units see "units of measurement" in the help index

\[
T := 298 \text{ K} \\
n := 1 \cdot \text{mol} \\
P := 1 \cdot \text{atm} \\
R := 8.31441 \text{ J K}^{-1} \text{ mol}^{-1}
\]

\[
V := \frac{n \cdot R \cdot T}{P} \\
\text{Solve for volume occupied by 1 mol of an ideal gas}
\]

\[
V = 0.024 \text{ m}^3 \\
\text{Mathcad handles all the unit conversions and displays the result in cubic meters!}
\]

\[
V = 24.453 \text{ L} \\
\text{And we can ask for the volume in liters!}
\]

\[
V = 1.492 \times 10^3 \text{ in}^3 \\
\text{Why not}
\]

3. Mathcad can use complex numbers without a change in notation

\[
\text{acos}(17) = 3.525i
\]

\[
\exp(1 + 2i) = -1.131 + 2.472i
\]
(4) Mathcad can use range variables

\[ i := 0..4 \]

Expression on left was entered by typing: \( i:0;4 \)

\[ i = \]

Display the result using \( i= \)

\[ \begin{array}{c}
0 \\
1 \\
2 \\
3 \\
4 \\
\end{array} \]

\[ X_i := \]

Type: \( X[i:3,4,5,10,11] \)

\[ \begin{array}{c}
3 \\
4 \\
5 \\
10 \\
11 \\
\end{array} \]

\[ \text{sum} := \sum_i X_i \]

Range variables can be used in iterative calculations such as sums.

\[ \text{sum} = 33 \]

Display the result.

\[ Y_i := i \cdot i + 2 \]

Range variables are frequently used for creating new vectors.

See the result at right -->

\[ Y = \begin{pmatrix} 2 \\ 3 \\ 6 \\ 11 \\ 18 \end{pmatrix} \]

(4) Mathcad can do some symbolic math

see "symbolic calculation" in the help index

\[ \int (x^2 + 2 \cdot x + 1) \, dx \rightarrow \frac{1}{3} x^3 + x^2 + x \]

\[ \frac{d}{dz} \exp(z^2) \rightarrow 3z^2 \cdot \exp(z^2) \]

\[ \sum_{i=1}^{N} i^2 \rightarrow \frac{1}{3} (N+1)^3 - \frac{1}{2} (N+1)^2 + \frac{1}{6} \cdot N + \frac{1}{6} \]
Other useful techniques:

A. Fast way to export x,y data

\[ i := 0..19 \]
\[ x_i := 2 + 5 \frac{i}{20} \]
\[ y_i := \left( x_i \right)^2 \]

Copy the columns to a matrix like this:

\[
\begin{array}{c|c}
0 & 1 \\
\hline
0 & 2 & 4 \\
1 & 2.25 & 5.063 \\
2 & 2.5 & 6.25 \\
3 & 2.75 & 7.563 \\
4 & 3 & 9 \\
5 & 3.25 & 10.563 \\
6 & 3.5 & 12.25 \\
7 & 3.75 & 14.063 \\
\end{array}
\]

B. To quickly plot a function \( y(x) \) vs. \( x \) you can type \( y@x \), which will plot over a default range.

Example: \( \text{myfcn}(z) := z^2 \cdot \sin(z) \)

Produced by typing \( \text{myfcn}(z)@z \) and then hitting return.
C. You can also do fancier plots: Use the mouse to change perspective for this 3D plot:

\[
\begin{align*}
    j &:= 1 \ldots 50 \\
    k &:= 1 \ldots 50 \\
    M_{j,k} &:= \frac{1 \cdot 10^4 \cdot \sin \left( \frac{j}{5} \right)}{(k + 10)^2}
\end{align*}
\]